Opóźnienie we wpisywaniu polskich znaków

Użytkowanie edytora dokumentów
Awatar użytkownika
radoslaw87
Posty: 3
Rejestracja: śr lut 02, 2022 9:32 pm

Opóźnienie we wpisywaniu polskich znaków

Post autor: radoslaw87 »

Czy nie zauważyliście w LibreOffice od wersji 7.2 opóźnienia we wpisywaniu polskich znaków? Używałem do tej pory wersji 7.1, dziś zainstalowałem wersję 7.2.5.2. Wszelkie znaki "podstawowe" Writer wpisuje normalnie, ale każdy znak polski pojawia się na ekranie z niewielkim opóźnieniem. Gdyby zaś chciało się napisać ciąg znaków np. "śśśśśśś", to taki ciąg zupełnie się laguje i pojawia po dłuższej chwili.
Może do problemu da się przyzwyczaić, mnie jednak na razie bardzo przeszkadza w pracy. Zainstalowałem też wersję 7.3.0, tam problem również występuje. Próbowałem wyłączyć renderowanie przez Skia, OpenCL i używanie środowiska Java - wszystko to nie przyniosło zmiany. Aktualnie wróciłem do wersji 7.1.8, gdzie wszystko jest w porządku. Korzystam z Windows 10.
Co może być przyczyną problemu? Będę bardzo wdzięczny za pomoc.
LibreOffice 7.2.7 na Windows 10
Awatar użytkownika
Jermor
Posty: 1782
Rejestracja: sob paź 12, 2013 11:09 am
Kontakt:

Re: Opóźnienie we wpisywaniu polskich znaków

Post autor: Jermor »

Zaintrygowany twoim postem sprawdziłem to u siebie. Rzeczywiście taki efekt występuje, lecz tylko w programie Writer i dotyczy wszystkich zdarzeń klawiatury wykonywanych z prawym ALT (np. prawy ALT+U dający symbol waluty euro).
To wygląda tak, jakby przytrzymanie prawego ALT powodowało wstawienie znaku do bufora klawiatury(?) i przeniesienie go do dokumentu dopiero po puszczeniu klawisza znaku. Przytrzymanie naciśniętego klawisza znakowego, generuje kolejne kody na tyle szybko, że bufor nie może zostać opróżniony i ta akcja może się wykonać dopiero po puszczeniu klawisza.
Ponieważ takie zdarzenie zachodzi tylko we Writerze, to nie może zależeć od programów stowarzyszonych obsługujących klawiaturę w innych programach.
Dlaczego takie zjawisko występuje — nie wiem.
AOO 4.1.12, LO 7.2.6 (x64) na Windows 10 64bit
Ważne!
Jeśli twój problem został rozwiązany, wróć do swojego pierwszego postu, przejdź do edycji i dopisz [SOLVED] w temacie.
Inni, którzy mają podobny problem, będą wiedzieli, że istnieje jego rozwiązanie.
Awatar użytkownika
radoslaw87
Posty: 3
Rejestracja: śr lut 02, 2022 9:32 pm

Re: Opóźnienie we wpisywaniu polskich znaków

Post autor: radoslaw87 »

Zgłosiłem to na Bugzillę (https://bugs.documentfoundation.org/sho ... ?id=147133), pozwolę sobie tam w komentarzu napisać o Twoich domysłach. Na komputerze mojej żony z Windows 8.1 problem nie występuje. Gdyby komuś coś jeszcze przyszło do głowy to proszę pisać :)
LibreOffice 7.2.7 na Windows 10
Jan_J
Posty: 4368
Rejestracja: pt maja 22, 2009 1:20 pm
Lokalizacja: Wrocław

Re: Opóźnienie we wpisywaniu polskich znaków

Post autor: Jan_J »

U mnie wciąż 7.1.8 działa szybko i reponsywnie. Ale z ciekawości zaciągnąłem 7.2.5 i jest równie dobrze.
Ale pracuję na Linuksie, a problem widocznie dotyczy Windowsów, i to nie wszystkich.
Może warto zgłosić?
JJ
LO (6.2|7.2) ∙ AOO (4.1) ∙ Python (3.10) ∙ Unicode 14 ∙ LᴬTEX 2ε ∙ XML ∙ Unix tools ∙ Linux (Rocky|CentOS)
Awatar użytkownika
radoslaw87
Posty: 3
Rejestracja: śr lut 02, 2022 9:32 pm

Re: Opóźnienie we wpisywaniu polskich znaków

Post autor: radoslaw87 »

W najnowszej wersji problem zniknął.
LibreOffice 7.2.7 na Windows 10
ODPOWIEDZ