Nem működnek a sablont tartalmazó kiterjesztések OOo 3.1-en

Általában minden ami máshova nem fér

Nem működnek a sablont tartalmazó kiterjesztések OOo 3.1-en

HozzászólásSzerző: mi84a » 2009. június 3., szerda 22:18

A ma letöltött magyar nyelvű OOo 3.1 (FSF.hu) verzióval nem működnek a sablonokat tartalmazó kiterjesztések.
részletesebben:
WIN XP Home-on eddig az OOo 3-t használtam egyebek mellett OxygenOffice-os és SUN-os sablonokat tartalmazó kiterjesztésekkel. A letöltöttem a 3.1-es OpenOffice-t (http://www.openoffice.hu/2009/06/megjel ... iceorg-31/). Telepítés előtt uninstalltam a 3.0-t > újraindít > install OOo 3.1. Eredmény: 3.1 működik, kiterjesztés kezelőben szerepelnek korábbi kiterjesztéseim, de a sablonok között nincs egy sem.
Újabb próba: uninstall 3.1 > registry tisztítás > újraindítás > install 3.1. Eredmény: változatlan.
Próbáltam a kiterjesztéseket újratelepíteni, de ez sem segített.
Mit rontottam el? Várom a megoldási javaslatokat.
Windows 10 Home • LibreOffice 5.1
mi84a
 
Hozzászólások: 10
Csatlakozott: 2008. április 5., szombat 22:46

Re: Nem működnek a sablont tartalmazó kiterjesztések OOo 3.1-en

HozzászólásSzerző: r4zoli » 2009. június 4., csütörtök 13:01

Mit rontottam el? Várom a megoldási javaslatokat.

Semmit, nálam is így működik, a Sun változatban viszont ez nem így van, ott minden sablon a helyére kerül.
Átmeneti megoldásként egyesével hozzá lehet adni a sablonkezelővel a legfontosabb sablonokat, a kiterjesztés telepítési helyéről.


Szerkesztés:
A Kami beleírt a hozzászólásomba, ahelyett, hogy újat készített volna, az ő hozzászólása:

Ha jól emlékszem a Sun sablon-kiterjesztéseken faragtam valamit, hogy jó legyen. Nálam (OxygenOffice) rendbenvalónak tűnik, vagy csak a problémát nem értem :(
A hozzászólást 2 alkalommal szerkesztették, utoljára r4zoli 2009. június 5., péntek 14:27-kor.
Ok: A moderátor javításának visszaállítása
Olvasd el, és lehetőleg tartsd be az útmutatót a fórum használatához.
AOO 3.4.1 win7, LibO 4.0 win7.
Avatar
r4zoli
Site Admin
 
Hozzászólások: 850
Csatlakozott: 2008. február 17., vasárnap 4:52
Tartózkodási hely: Budapest

Re: Nem működnek a sablont tartalmazó kiterjesztések OOo 3.1-en

HozzászólásSzerző: mi84a » 2009. június 4., csütörtök 22:44

r4zoli írta:
Mit rontottam el? Várom a megoldási javaslatokat.

Semmit, nálam is így működik, a Sun változatban viszont ez nem így van, ott minden sablon a helyére kerül.
Átmeneti megoldásként egyesével hozzá lehet adni a sablonkezelővel a legfontosabb sablonokat, a kiterjesztés telepítési helyéről.


Ha jól emlékszem a Sun sablon-kiterjesztéseken faragtam valamit, hogy jó legyen. Nálam (OxygenOffice) rendbenvalónak tűnik, vagy csak a problémát nem értem :(


Le tudnád írni, hogy mit és hogyan faragtál a Sun féle csomagon? (Vagy programozói tudást igényel? - azzal nem rendelkezem :( )
Nem az OxygenOffice-t használom, hanem az általuk készített kiegészítést. Legalábbis azt szeretném használni az FSF.hu féle OpenOffice.org 3.1-hez, de csakúgy, mint a SUN által készített sabloncsomag kiterjesztés, nem igazán akar működni.
Nem élet-halál kérdés a dolog, de jó lenne ha sikerülne.
Windows 10 Home • LibreOffice 5.1
mi84a
 
Hozzászólások: 10
Csatlakozott: 2008. április 5., szombat 22:46

Re: Nem működnek a sablont tartalmazó kiterjesztések OOo 3.1-en

HozzászólásSzerző: Kami » 2009. július 11., szombat 11:05

Közben ellenőrizem, és nem volt igazam. A SUN kiterjesztéseken faragtam valamit, de akkor még működött ez a része a programnak. Most úgy tűnik, hogy valamely GO-OO-ban alkalmazott patch okozza a hibát -- mellékhatásként. Egyelőre nem tudjuk melyik. Ez érinti az FSF.hu és az OxygenOffice-t is, így próbáljuk meghatározni, hogy vajon mi okozza a problémát.
Avatar
Kami
Önkéntesek
 
Hozzászólások: 176
Csatlakozott: 2008. február 20., szerda 23:12
Tartózkodási hely: Budapest

Re: Nem működnek a sablont tartalmazó kiterjesztések OOo 3.1-en

HozzászólásSzerző: Kami » 2009. augusztus 22., szombat 17:33

A hiba oka a ooo-build-ban átrendezett könyvtárrendszerben keresendő, amely miatt az eredeti kód hibásan adta vissza a kiterjesztések valódi helyét a sablonok listázásához.
A hiba javításra került a http://cgit.freedesktop.org/ooo-build/o ... cb19bd1390 folttal, amely a 3.1 és a master (fejlesztői ág) részére is beolvasztásra került.

A hiba így nem fog előfordulni a 3.1.1-ben (vagy a most buildelt 3.1.0-ban). Kísérleti környezetemben tesztelve és valóban működik.
Avatar
Kami
Önkéntesek
 
Hozzászólások: 176
Csatlakozott: 2008. február 20., szerda 23:12
Tartózkodási hely: Budapest


Vissza: Általános kérdések

Ki van itt

Jelenlévő fórumozók: nincs regisztrált felhasználó valamint 2 vendég