Version flatpak et version instable

Les dernières nouvelles du front du libre, débats et autres informations générales sur nos suites bureautiques préférées ou sur ce site, en évitant de provoquer toute polémique (troll).
Aucun support assuré ici : posez votre question dans la section appropriée.

Modérateur: Vilains modOOs

Version flatpak et version instable

Messagepar antistress » 07 Juin 2020 00:48


La modération vous a écrit: Message divisé du fil Album Photo : modifier taille/position des légendes


@tintin : micmac a développé deux points : 1°) la version flatpak, 2°) la version instable.
J'ai fait remarquer – sans volonté de polémiquer je le répète, en tant que connaissant l’environnement GNU/Linux pour en être un utilisateur relativement avancé – un malentendu sur le 1er des deux points, malentendu qui n'est pas sans conséquence puisqu'il est effectivement difficile d'offrir du support sur un logiciel qui a pu être altéré par un tiers. Tel n'est pas le cas de la version flatpak de LibO.
Je n'ai évidemment pas contesté l'autre point qui est incontestable : j'utilise bel et bien la version non-stable (d'ailleurs la seule proposée par les développeurs de LibO en Flatpak à ma connaissance).

Puisque vous me reprenez sur le 2è point sur lequel je m'étais gardé de répondre pour ne pas déborder du sujet, voici mon avis en deux points.
I - À titre personnel je regretterais, si tel était le choix des responsables de forum.openoffice.org/fr, la position consistant à décourager la communauté de tester les versions de développement puisque c'est une façon pour la communauté de participer au projet en faisant remonter les bogues, répondant ainsi à une demande des développeurs. Tout comme vous participez au projet avec ce forum. Et je crois sincèrement que nous sommes une même communauté, chacun participant à sa façon, et je trouverais dommage que les actions des uns et des autres ne se renforcent pas.
Je le regretterais, le désapprouverais, mais respecterais votre choix : c'est votre forum.
II - Je reprends à présent ma casquette d'assez bon connaisseur de l’environnement GNU/Linux pour attirer votre attention sur un point spécifique à cet environnement. Les choix techniques neutres, ça n'existe pas. Si les responsables du forum demandent aux utilisateurs de GNU/Linux, qui fonctionnent tous essentiellement à partir de dépôts logiciels (que ce soit les logiciels compilés par les distributions ou les logiciels compilés par leurs développeurs directement, comme avec la version Flatpak de LibO) de télécharger des exécutables, vous faîtes le choix indirect d'exclure la grande majorité des linuxiens car ce choix technique que vous formulerez sera basé sur un usage typique sur Windows et macOS mais atypique sur GNU/Linux.
Je ferme la parenthèse.

Pour le reste, je vous fais remarquer que ma demande de précision s'adressait à micmac. Ma demande d'aide reste entière.
LibreOffice 6.4.4 sous Debian GNU/Linux Testing
antistress
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 52
Inscrit le : 27 Nov 2008 19:56

Re: Version flatpak et version instable

Messagepar Scrat » 07 Juin 2020 11:54

antistress a écrit: les responsables du forum demandent aux utilisateurs de GNU/Linux, qui fonctionnent tous essentiellement à partir de dépôts logiciels (que ce soit les logiciels compilés par les distributions ou les logiciels compilés par leurs développeurs directement, comme avec la version Flatpak de LibO) de télécharger des exécutables


Bonjour.

Je me permets d'ajouter mon grain de sel sur ce point précis des versions des dépôts.

Après avoir travaillé pendant 11 ans sous Windows Vista , je suis passé à Linux Mint en changeant d'ordinateur. Au début de mon passage à Linux Mint il y a 2 ans, j'ai voulu remplacer la version LibO 6.0.7 des dépôts par la version officielle la plus récente du moment (j'ai oublié le numéro) qui était préconisée par le forum, et j'ai eu des problèmes d'affichage des menus. Donc exit la version officielle, et je suis revenu à la version des dépôts.

Plus tard, cette version des dépôts ayant été régulièrement été mise à jour, mais toujours en 6.0.7, j'ai voulu tester l'envoi de document par mail, et ça n'a jamais fonctionné. Pourtant mon gestionnaire de courrier Thunderbird est bien déclaré dans les options. En lançant LibO en ligne de commande dans un terminal pour avoir les messages d'erreur, je me suis rendu compte qu'il s'agit d'un problème de droits pour le module "senddoc" vis à vis de Thunderbird : "Permission denied".

Récemment, j'ai installé en parallèle de la version des dépôts la version stable officielle, d'abord la 6.3.5, et depuis hier la 6.3.6 : sur ces versions officielles, il n'y a plus de problème d'affichage des menus, et il n'y a aucun problème pour envoyer un document par mail, l'action sur le menu ouvrant immédiatement Thunderbird.

Tout cela pour dire que si l'utilisation des versions des dépôts facilite la mise à jour, je ne comprends pas pourquoi les distributions Linux éprouvent le besoin de modifier le code au point d'y introduire des problèmes qui n'existent pas sur la version officielle. D'un autre côté, la version officielle n'est pas forcément la panacée, puisque elle m'avait apporté des problèmes d'affichage par rapport à la version des dépôts, mais problème corrigé dans les versions officielles ultérieures.

Je conseillerais donc aux Linuxiens de ne pas supprimer la version des dépôts et de faire l'essai d'une version officielle à côté de la version des dépôts qui, hélas, a toujours plusieurs longueurs de retard sur les dernières versions stables. Exemple: Linux Mint qui reste obstinément sur LibO 6.0.7 alors que la dernière version stable est la 6.3.6 ! L'installation d'une version en parallèle, donc avec un profil utilisateur différent, est très simple et bien documentée :

https://wiki.documentfoundation.org/Installing_in_parallel/fr

Autre point évoqué : pourquoi le forum décourage-t-il d'utiliser les dernières versions qualifiées instables car expérimentales ? Il me semble au contraire que leur utilisation est dans l'esprit communautaire qui permet de faire évoluer un logiciel libre en reportant les bogues.

Dernier point : les versions Flatpak. C'est peut-être intéressant pour bénéficier des dernières mises à jour, mais attention au volume à télécharger : près de 1 Go pour la flatpak de LibO 6.4.4, contre moins de 200 Mo pour les 3 zips de la version LibO 6.3.6 ! :o Quand on a une connexion internet pas terrible, ça fait réfléchir ! :?

A+
Libre Office 6.0.7.3 Linux Mint 19.3 x64 (version des dépôts)
Libre Office 6.3.6.2 Linux Mint 19.3 x64 (version officielle en parallèle)
Utilisez l'extension de Sauvegarde incrémentale pour ne pas perdre de document !
Avatar de l’utilisateur
Scrat
HédOOniste
HédOOniste
 
Message(s) : 1938
Inscrit le : 06 Juin 2014 11:39
Localisation : Île d'Oléron

Re: Version flatpak et version instable

Messagepar jbfaure » 07 Juin 2020 22:18

Bonjour,

Il n'y a pas de version instable de LibreOffice et les seules versions expérimentales sont les versions de développement. Actuellement la version 6.4.4 est une version tout autant stable que la version 6.3.6, qui elle en revanche s'approche de sa fin de vie.
Si les modérateurs de ce forum veulent décourager les utilisateurs d'utiliser la version stable la plus en pointe, c'est leur affaire, mais ils n'expriment pas la position de la communauté LibreOffice. La position de la communauté LibreOffice (que l'on retrouvera sur la liste d'entraide users@fr.libreoffice.org et sur https://ask.libreoffice.org/fr) est d'encourager l'utilisation et les tests de toutes les versions selon les compétences techniques de chacun. En procédant ainsi les utilisateurs peuvent apporter par leurs retours d'expérience une aide inestimable à l'amélioration de la qualité de LibreOffice.

Bonne journée
Jean-Baptiste Faure, pour la Communauté LibreOffice Francophone
LibreOffice 6.4 (avec la dernière mise à jour corrective) sous Linux Ubuntu 18.04
Listes de discussions francophones : http://nabble.documentfoundation.org/Fr ... 44075.html
jbfaure
Membre cOOnverti
Membre cOOnverti
 
Message(s) : 367
Inscrit le : 10 Juil 2008 07:42
Localisation : Lyon - France

Re: Version flatpak et version instable

Messagepar Jean-Louis Cadeillan » 07 Juin 2020 23:42

Bonsoir,
jbfaure a écrit:Il n'y a pas de version instable de LibreOffice et les seules versions expérimentales sont les versions de développement
Alors cette page est équivoque ou souffre d'un problème de traduction :
LibO_Versions.jpg
Cliquer pour agrandir
Cordialement,
Jean-Louis
LibO 6.3.6.2 (x64 avec Java 1.8.0_241) et AOO 4.1.7 (avec Java x32 1.8.0_261), Windows 7 Édition Intégrale 64 SP1, (Domicile)
LibO 5.4.1.2 (x86) sous Ubuntu LTS 16.04.1, noyau 4.4.0-93 et Xfce 4.12, Java (x86) 1.8.0_131 (Travail) [obligation de version]
Avatar de l’utilisateur
Jean-Louis Cadeillan
GourOOu
GourOOu
 
Message(s) : 5017
Inscrit le : 03 Jan 2009 00:56

Re: Version flatpak et version instable

Messagepar Bidouille » 08 Juin 2020 07:32

Bonjour,

jbfaure a écrit:Si les modérateurs de ce forum veulent décourager les utilisateurs d'utiliser la version stable la plus en pointe, c'est leur affaire, mais ils n'expriment pas la position de la communauté LibreOffice.

La position des bénévoles qui s'occupent de ce forum n'a jamais dévié d'un iota sur la confusion entretenue sur vos deux versions.
Ceux qui veulent tester la version expérimentale sont libres de le faire mais s'ils viennent rapporter ici un dysfonctionnement, on leur demande alors :
  1. d'installer la version stable et de tester à nouveau
  2. si le problème est résolu de le rapporter aux développeurs en suivant notre tutoriel
  3. revenir ensuite nous dire ce qu'il en est mais ça, c'est une autre histoire

Quand à la position de LibreOffice vis-à-vis de ce forum, on la connait : jamais de publicité pour OpenOffice et toujours venir placer des petits liens vers ses ressources.
Avatar de l’utilisateur
Bidouille
RespOOnsable forum
RespOOnsable forum
 
Message(s) : 10431
Inscrit le : 08 Nov 2005 17:23
Localisation : Brest, France

Re: Version flatpak et version instable

Messagepar tintin » 08 Juin 2020 08:39

On se souvient qu'il n'y a pas si longtemps dans sa page d'accueil LibO annonçait que sa version évolution – du temps où elle s'appelait encore Évolution – pouvait être considérée comme stable à partir de la 4eme mise à jour.
Donc elle n'est pas stable avant cette 4eme mise à jour.
AOO 4.1.7 et LibO 6.4.5.2 / macOS 10.15.5 Catalina.
AdoptOpenJDK_11.0.8 / Firefox / Thunderbird / Safari / Time Machine
Pour préserver vos documents, faites régulièrement des sauvegardes.
Avatar de l’utilisateur
tintin
GourOOu
GourOOu
 
Message(s) : 6796
Inscrit le : 18 Juil 2008 16:29
Localisation : F-Oise + F-Savoie

Re: Version flatpak et version instable

Messagepar antistress » 08 Juin 2020 16:39

Ce que tu écris, Bidouille, ne correspond pas à mon expérience du forum.
Ce que Bidouille écrit ne correspond pas à mon expérience du forum.

Pour parler de mon cas personnel, sur le fil dont a été détaché celui-ci, il n'était pas question de dysfonctionnement mais d'une demande d'aide à la prise en main de l'outil.

Je suis sur la 6.4.4 de LibO :

tintin a écrit:Le modérateur vous signale que la version installée (6.4.4) est une version expérimentale.
Si toutefois cette version 6.4.4 vous était imposée (employeur, administration…), il vous demandait de l'indiquer dans votre signature.
Comme ce n'est pas le cas, et que le forum ne peut fournir d'entraide sur des versions expérimentales il vous recommande d'installer la dernière version stable.


micmac a écrit:On vous a signalé que la version installée (6.4.4] est une version expérimentale. Nous n'intervenons pas sur ces versions.
[...] Installez la version stable comme recommandé.
Dernière édition par antistress le 08 Juin 2020 18:29, édité 1 fois.
LibreOffice 6.4.4 sous Debian GNU/Linux Testing
antistress
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 52
Inscrit le : 27 Nov 2008 19:56

Re: Version flatpak et version instable

Messagepar Bidouille » 08 Juin 2020 18:04

antistress a écrit:Ce que tu écris, Bidouille, ne correspond pas à mon expérience du forum.

Relisez mieux car je ne m'adresse pas à vous.
Avatar de l’utilisateur
Bidouille
RespOOnsable forum
RespOOnsable forum
 
Message(s) : 10431
Inscrit le : 08 Nov 2005 17:23
Localisation : Brest, France

Re: Version flatpak et version instable

Messagepar antistress » 08 Juin 2020 18:30

Bidouille a écrit:
antistress a écrit:Ce que tu écris, Bidouille, ne correspond pas à mon expérience du forum.

Relisez mieux car je ne m'adresse pas à vous.


Ha, ok. J'ai modifié mon post en conséquence.
LibreOffice 6.4.4 sous Debian GNU/Linux Testing
antistress
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 52
Inscrit le : 27 Nov 2008 19:56


Retour vers Nouvelles du front et Tribune du Libre

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 3 invité(s)