ERROR

Discute sobre las herramientas de la base de datos

ERROR

Notapor ugab » Jue Jul 29, 2021 5:31 pm

Estimados estoy realizando un pequeño sistema en base y cuando va a abrir automaticamente el formulario me sale el error que adjunto, además de ajuntar el programita
En la máquina que lo hice no da dicho error, lo da cuando lo traslado a otro equipo.
Desde ya muchas gracias por la ayuda que me puedan brindar.
Adjuntos
Error (Personalizado).jpg
Expedientes.rar
(74.88 KiB) 39 veces
OpenOffice 4.1.5 en Windows 10 - Ubuntu
ugab
 
Mensajes: 123
Registrado: Mar May 17, 2011 9:46 pm

Re: ERROR

Notapor iagodb » Vie Jul 30, 2021 11:23 am

Yo no soy un experto pero parecería que el programita lee "algo", que en el equipo en que lo hiciste está en una determinada ubicación (LOCAL) y que cuando el programita intenta leer eso mismo en la misma ubicación local de la nueva máquina pues no encuentra nada, o lo encuentra pero si va con contraseña es una distinta, o algo así...

No sé si te servirá. En general te diría que revises qué orígenes de datos necesitas y cómo se puede acceder a ellos. Así detectarás tú mismo cuál es el problema, seguro.
Libreoffice 7.0 (x64) / Windows 10 Pro
Avatar de Usuario
iagodb
 
Mensajes: 212
Registrado: Lun Jul 18, 2016 11:03 am
Ubicación: Narón (A Coruña)

Re: ERROR

Notapor Longi » Vie Jul 30, 2021 4:03 pm

Buenas!
Parece que la base la tienes hecha con firebird, sin embargo la firma es de openoffice.
Así que es posible que la base la generas es con Libreoffice (firebird embebido) y quieres abrirla con OpenOffice, que se puede, pero no como embebida, sino con una conexión a la base ya generada.
Mira a ver si dejas la base en el escritorio y abres openoffice desde el lanzador general dale a base nueva y en el asistente en vez de base nueva escoges 'conectar con base de datos existente', o algo así.
Sigues los pasos y conectaría a con tu 'programita'.
Igual meto la pata de medio a medio, pero intenta por ahí.
Un saludo! ;)
Openoffice 4.1.7, en Windows 10
Libreoffice 6.4.2, en Windows 10
Longi
 
Mensajes: 764
Registrado: Dom Ene 20, 2013 9:05 pm
Ubicación: Ourense, Galicia, España

Re: ERROR

Notapor ugab » Lun Sep 20, 2021 6:44 pm

Buenas estoy utilizando en ambas máquinas libreoffice, el error continua apareciendo.
Agredezco la layuda que me puedan brindar
Saludos
OpenOffice 4.1.5 en Windows 10 - Ubuntu
ugab
 
Mensajes: 123
Registrado: Mar May 17, 2011 9:46 pm

Re: ERROR

Notapor Longi » Mié Sep 22, 2021 1:56 pm

Buenas de nuevo!
Como quise explicarte, la base de datos parece hecha con el motor Firebird, y es posible que tengas el motor HSQLDB trabajando.
Intenta lo siguiente:(solo como prueba)
Menú Herramientas>Opciones>Avanzadas>Activar las funcionalidades experimentales, y no te preocupes por la anotación de que pueda resultar inestable.
Te va a pedir permiso para reiniciar, y tu amablemente se lo concedes.
Si no me equivoco, con estos pasos te podrá abrir una base de datos que se generó con Firebird (al menos a la hora de generar una base de datos nueva te deja escoger el motor).

Ya nos cuentas.

Un saludo! ;)
Openoffice 4.1.7, en Windows 10
Libreoffice 6.4.2, en Windows 10
Longi
 
Mensajes: 764
Registrado: Dom Ene 20, 2013 9:05 pm
Ubicación: Ourense, Galicia, España

Re: ERROR

Notapor ugab » Vie Sep 24, 2021 6:46 pm

-Hice lo que me decis y continua el error.
En el equipo que copie el programita la base de datos inscrustada dice firebird.
Adjunto para ver si uds pueden ver donde esta el error.
Gracias
Adjuntos
Expedientes.rar
(74.89 KiB) 22 veces
OpenOffice 4.1.5 en Windows 10 - Ubuntu
ugab
 
Mensajes: 123
Registrado: Mar May 17, 2011 9:46 pm

Re: ERROR

Notapor Longi » Sab Sep 25, 2021 10:22 pm

Buenas!

He activado las funcionalidades experimentales y he abierto sin ningún problema la base de datos. No he añadido datos ni nada por el estilo, pero el formulario lo abrió a la primera, por lo que la conexión con la base fue correcta.

Comprueba que has activado las funcionalidades experimentales.

Un saludo! ;)
Openoffice 4.1.7, en Windows 10
Libreoffice 6.4.2, en Windows 10
Longi
 
Mensajes: 764
Registrado: Dom Ene 20, 2013 9:05 pm
Ubicación: Ourense, Galicia, España


Volver a Base

¿Quién está conectado?

Usuarios navegando por este Foro: Google [Bot] y 0 invitados