Tablas que no existen

Discute sobre las herramientas de la base de datos

Tablas que no existen

Notapor James07 » Vie Ago 07, 2020 8:04 am

Hola. He desarrollado una aplicación en Base que después de mucho esfuerzo ya que no soy experto he conseguido que funcione. El problema es que como he ido añadiendo módulos de distintas aplicaciones, el formulario principal cuando carga me dice que algunas tablas no existen. Voy a explicarme. Cuando acabé el programa borré algunas tablas que ya no me eran necesarios porque o bien eran de pruebas o venían de otros ejemplos y me encontré con la sorpresa que al cargar el formulario me pedía precisamente esas tablas aunque ya no había campos de esas tablas en ese formulario. Para salvar el problema lo que dice es volver a crear esas tablas nominalmente pero sin datos y todo funciona pero me gustaría saber cómo borrar o desactivar esa llamada a tablas que ya no existen. Gracias
OpeOffice 6.4 en Windows 10
James07
 
Mensajes: 13
Registrado: Sab Jul 04, 2020 12:15 pm

Re: Tablas que no existen

Notapor Longi » Vie Ago 07, 2020 8:14 am

Mucho me temo que en algún lugar del formulario sí que se hace referencia a esas tablas (en un SQL o algo así)
Mira si borraste subformularios que no necesitabas (basados en esas tablas), o si solo borraste los campos, pero quedaron los subformularios por ahí danzando.

Un saludo!
Openoffice 4.1.7, en Windows 10
Libreoffice 6.4.2, en Windows 10
Longi
 
Mensajes: 721
Registrado: Dom Ene 20, 2013 9:05 pm
Ubicación: Ourense, Galicia, España

Re: Tablas que no existen

Notapor RMG » Vie Ago 07, 2020 11:14 am

Hola,

También revisa los cuadros combinados y cuadros de lista, si hacen referencia a esas tablas.

Saludos
OpenOffice 4.1.9 y LibreOffice 6.2.4.2 en W-10, y LibreOffice 4.1.6.2 en Open Suse 13.1(VirtualBox)
RMG
 
Mensajes: 3810
Registrado: Mar Nov 17, 2009 6:59 am
Ubicación: Valencia - España


Volver a Base

¿Quién está conectado?

Usuarios navegando por este Foro: Google Feedfetcher y 4 invitados