[Solved] AutoIt: howto attach to OOo Calc

The Application Programming Interface and the OASIS Open Document Format

[Solved] AutoIt: howto attach to OOo Calc

Postby Leagnus » Mon Mar 02, 2009 11:18 pm

I'm trying to attach to existing com.sun.star.ServiceManager object and unsuccesfully.
Why creation of the object is possible and attaching is not?
if OpenOffice Calc is runnin ObjGet("", "com.sun.star.ServiceManager") returns 0.
May be UNO – Universal Network Objects – aren't com-objects.
There is UNO-OLE Bridge, but I'm not so tough to get what is this about. Does someone have an idea?
I'm using OOo 3.0.1 and AutoIt 3.2.12.1 on WinXP SP3.
Last edited by Leagnus on Sun Mar 08, 2009 10:15 pm, edited 2 times in total.
OOo 3.0.X on MS Windows Vista
Leagnus
 
Posts: 3
Joined: Mon Mar 02, 2009 10:39 pm

Re: AutoIt: howto attach to OOo Calc

Postby Leagnus » Sat Mar 07, 2009 8:50 pm

ms777 have responded to my attach request: http://www.oooforum.org/forum/viewtopic.phtml?t=81104
OOo 3.0.X on MS Windows Vista
Leagnus
 
Posts: 3
Joined: Mon Mar 02, 2009 10:39 pm

Re: AutoIt: howto attach to OOo Calc

Postby ms777 » Sun Mar 08, 2009 6:46 pm

Could you please add [solved] to the title of your post ?

Cheers ms777
ms777
Volunteer
 
Posts: 131
Joined: Mon Oct 08, 2007 1:33 am

Re: [Solved] AutoIt: howto attach to OOo Calc

Postby Gabrielwer » Tue Sep 13, 2011 9:31 am

This so much needs to be on the top of the forums.. I decided to look ONE MORE time on the forum and found this post!
Thanks You are a life saver. :super:
OpenOffice 3.1 on Windows Vista / NeoOffice 2.2.3 with MacOS 10.4 / OpenOffice 2.4 on Ubuntu 9.04
Gabrielwer
 
Posts: 3
Joined: Fri Sep 09, 2011 3:31 pm


Return to UNO API and ODF

Who is online

Users browsing this forum: No registered users and 0 guests