Report gives ID# but not text

Discuss the database features

Report gives ID# but not text

Postby ChuckW44 » Sun Mar 14, 2021 1:07 am

I have created a small DB with two tables. Main info in table 1, linked to table 2, which is a drop-down list. I need a report showing the text list, but I can only get the ID numbers in table 2 on the report. How can I get the text column instead of the ID numbers?
OpenOffice 4.1.6 on Windows 10
ChuckW44
 
Posts: 1
Joined: Sun Mar 14, 2021 12:54 am

Re: Report gives ID# but not text

Postby Villeroy » Sun Mar 14, 2021 3:06 am

Creating a query from both tables analog to this:
Code: Select all   Expand viewCollapse view
SELECT "Table1".* , "Table2"."Name" FROM "Table1", "Table2" WHERE "Table1"."XID" = "Table2"."ID"

Build the report from that query.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04 with LibreOffice 6.0, latest OpenOffice and LibreOffice
User avatar
Villeroy
Volunteer
 
Posts: 30168
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Report gives ID# but not text

Postby Villeroy » Sun Mar 14, 2021 12:59 pm

I forgot to add a link to [Example] Relations reflected by list boxes in forms including an example database demonstrating a query "qReport" merging all kinds of data and a report based on that query.
Running the report requires LibreOffice or the report builder extension for OpenOffice. The report simply wraps the query result into a printable layout. The important thing is the query.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04 with LibreOffice 6.0, latest OpenOffice and LibreOffice
User avatar
Villeroy
Volunteer
 
Posts: 30168
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany


Return to Base

Who is online

Users browsing this forum: No registered users and 3 guests