[Solved] OpenOffice malfunctions, read-only files

Issues installing under the Mac OSX - X11 - Aqua

[Solved] OpenOffice malfunctions, read-only files

Postby lauren1056 » Sat Jan 16, 2021 2:04 am

I have been using OpenOffice on Macs for years. I just bought a new mac, Big Sur. OpenOffice now opens all my docs was "read only" files. I have never locked any of them. How can I remove the "read only" lock?
Also when I use the "find & replace" function in my spreadsheet, it finds some of the terms I search for, other terms I search for it cannot find, even though I can see the search term in the spreadsheet.
OO also crashes sporadically. My necessary docs I have had to "open a copy
My business depends on finding terms in my spreadsheets. Can anyone help?
Last edited by Hagar Delest on Sun Jan 17, 2021 11:58 am, edited 1 time in total.
Reason: tagged solved.
OpenOffice version 4.1.8
Mac Big Sur
lauren1056
 
Posts: 6
Joined: Sat Jan 16, 2021 1:55 am

Re: OpenOffice malfunctions on Big Sur

Postby RusselB » Sat Jan 16, 2021 3:47 am

You would've saved yourself time if you had searched the forum for the term Big Sur,
The search https://forum.openoffice.org/en/forum/search.php?keywords=Big+Sur now returns these posts as well.
OpenOffice 4.1.7, LibreOffice 7.0.1.2 on Windows 7 Pro, Ultimate & Windows 10 Home (2004)
If you believe your problem has been resolved, please go to your first post in this topic, click the Edit button and add [Solved] to the beginning of the Subject line.
User avatar
RusselB
Moderator
 
Posts: 6422
Joined: Fri Jan 03, 2014 7:31 am
Location: Sarnia, ON

Re: OpenOffice malfunctions on Big Sur

Postby Hagar Delest » Sat Jan 16, 2021 11:04 am

Indeed several topics about this issue, see this query (I prefer the sorting by topics).
You can either switch to LibreOffice, wait for the AOO 4.1.9 or install a RC for 4.1.9. See this post.

Please add [Solved] at the beginning of the title in your first post (top of the topic) with the *EDIT button if your issue has been fixed.
LibreOffice 7.0.5 on Xubuntu 21.04 and 7.0.5 portable on Windows 10
User avatar
Hagar Delest
Moderator
 
Posts: 29836
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: OpenOffice malfunctions on Big Sur

Postby robleyd » Sat Jan 16, 2021 11:22 am

OpenOffice now opens all my docs was "read only" files


Possibly the files show as owned by another user than the one on your new computer and/or have no permission to change content. Use whatever tool MacOS provides to check this; possibly a file manager will show file permissions and ownership and allow changes.
Cheers
David
Apache OpenOffice 420m2(Build:9821) - Slackware 14.2 - 64 bit
LibreOffice 6.4.6.2 (SlackBuild for 6.4.6 by Eric Hameleers) - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
robleyd
Moderator
 
Posts: 4052
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: OpenOffice malfunctions on Big Sur

Postby Hagar Delest » Sat Jan 16, 2021 11:33 am

This issue is indeed a bit different from the other related Big Sur topics. Could it be another kind of problem linked to the Big Sur main one???
LibreOffice 7.0.5 on Xubuntu 21.04 and 7.0.5 portable on Windows 10
User avatar
Hagar Delest
Moderator
 
Posts: 29836
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: OpenOffice malfunctions on Big Sur

Postby RoryOF » Sat Jan 16, 2021 12:11 pm

How were the files transferred to the new computer? It may be that they acquired "Read-only" attributes from the transfer process (often when using DVDs); Check that there are no hidden lock files, and that you are accessing them as the same User (spelling, capitalisation) as on the old computer. Also that the User has read write permissions to the target folder.

 Edit: As Mac OS is based on linux, I mention that often when transferring files by USB from one linux computer to another, I have to change ownership of the files on the target computer from "root" to the logged on user before such files can be edited. 
Apache OpenOffice 4.1.10 on Xubuntu 20.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 32719
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: OpenOffice malfunctions on Big Sur

Postby MrProgrammer » Sat Jan 16, 2021 5:41 pm

Hi, and welcome to the forum.

lauren1056 wrote:I just bought a new mac, …. OpenOffice now opens all my docs was "read only" files.
• Why do you believe the files are read-only?
• Are "all my docs" files which you transferred from an old Mac to a new one?
• If so, how were the files transferred?
You did not tell us any of this. It is hard to help with incomplete information.

The read-only status may be due to the manner in which the files were transferred. Look at instructrions to remove lock files in
Q16/A16: Open document read-only or open a copy … for editing

Hagar Delest wrote:Could it be another kind of problem linked to the Big Sur main one???
My guess is that the problem is related to the transfer, not to Big Sur. However the OP could later experience problems related to OpenOffice on Big Sur since that release of MacOS was not available when any release of OpenOffice prior to 4.1.9 was created. This is why I don't install MacOS updates until a later OpenOffice version has been released. I do thank the others who test them for me.

robleyd wrote:Possibly the files show as owned by another user than the one on your new computer and/or have no permission to change content. Use whatever tool MacOS provides to check this; possibly a file manager will show file permissions and ownership and allow changes.
RoryOF wrote:How were the files transferred to the new computer? It may be that they acquired "Read-only" attributes from the transfer process (often when using DVDs); Check that there are no hidden lock files, and that you are accessing them as the same User (spelling, capitalisation) as on the old computer. Also that the User has read write permissions to the target folder. As Mac OS is based on linux, I mention that often when transferring files by USB from one linux computer to another, I have to change ownership of the files on the target computer from "root" to the logged on user before such files can be edited.
These ideas might be the case since many details are unknown. The proper place to ask about changing MacOS file permissions is an Apple forum, not an OpenOffice forum. If the OP hs purchased the new Mac from Apple, they qualify for techincal support from the company for a period of time. If an Apple store is convenient, Apple wizards there can fix a "file permission" problem. Apple will not be familar with the lock files discussed in Q16/A16, though their technicians will understand the solution if it is shown to them. I acquired a new Mac about a year ago and did not experience read-only difficulties.
[Solved] User experience: OpenOffice 4.1.7 on MacOS 10.14.6


If this solved your problem please go to your first post use the Edit button and add [Solved] to the start of the subject field. Select the green checkmark icon at the same time.
Mr. Programmer
AOO 4.1.7 Build 9800 on MacOS 10.14.6.   The locale for any menus or Calc formulas in my posts is English (USA).
User avatar
MrProgrammer
Moderator
 
Posts: 4048
Joined: Fri Jun 04, 2010 7:57 pm
Location: Wisconsin, USA

Re: OpenOffice malfunctions on Big Sur

Postby lauren1056 » Sat Jan 16, 2021 7:18 pm

I am the creator of all of my files, no other user created or locked them. No one else uses my computers. I did not upgrade to Big Sur, I bought a new computer that came with Big Sur.
I backed up my files onto an external harddrive. I bought a new Mac, Catalina and transferred the files onto it. They all worked fine. I then bought another new Mac, Big Sur. Transferred the files from the same external HD to that new Mac and I get a message telling me it can only open the files as read only. But the message is random, some files it opens fine. These are all text or spreadsheet files I created over the years, all created using OO.
The bigger frustration is that the Find & Replace function (ctrl+f) is malfunctioning. I have to find entries in spreadsheets and when I search for entries, it will find some and others it will not find. I can be looking right at an entry in the spreadsheet so I know it is there, but it will not find it. I have tried dozens of time checking to be sure I am not misspelling, etc. I am searching for simple one word entries, nothing complicated, so it's not characters entered wrong.
OpenOffice version 4.1.8
Mac Big Sur
lauren1056
 
Posts: 6
Joined: Sat Jan 16, 2021 1:55 am

Re: OpenOffice malfunctions on Big Sur

Postby RoryOF » Sat Jan 16, 2021 7:37 pm

If it only happens for some files, enable viewing of hidden and archive files (look it up if you don't know how), then look in the folder in which the files are Saved for a lock file. With OpenOffice closed, these may safely be deleted.

They have the form
Code: Select all   Expand viewCollapse view
.~lock.MyFile.odt#

They have a size of a few hundred bytes, whereas the file they lock is typically several kilobytes - make sure you delete only the smaller file.
Apache OpenOffice 4.1.10 on Xubuntu 20.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 32719
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: OpenOffice malfunctions on Big Sur

Postby lauren1056 » Sun Jan 17, 2021 1:30 am

Thank you. It seems like that may have fixed the problem.

 Edit: This topic was about read-only files. Topic locked due to introduction of an unrelated question.
-- MrProgrammer, forum moderator 
Do you have any suggestions on what to do about the OO Find & Replace function only randomly successfully finding terms I search for?
When I search for entries (simple one word searches), it sometimes finds what I search for, and other times it will not find my search term. Even when I can see the entry in the spreadsheet so I know it is there, it will not find it. The searches it successfully finds, it will always find on future searches. The searches where it does not find the term (even though it exists in the spreadsheet), it will never find. That it, it likes some of the data (will find it) and does not like other data. It see no pattern other than that. Some data entered into the spreadsheet BEFORE transferring the files to the new computer it will find and some it will not. Some data entered into the spreadsheet AFTER transferring the files to the new computer it will find and some it will not. The problem of not finding an entry is not limited to any specific column in the spreadsheet. Both text and currency formats have the problem.
OpenOffice version 4.1.8
Mac Big Sur
lauren1056
 
Posts: 6
Joined: Sat Jan 16, 2021 1:55 am

Re: OpenOffice malfunctions on Big Sur

Postby RusselB » Sun Jan 17, 2021 2:31 am

Please repost your last query as a separate topic.
Forum rules state one question per topic.
OpenOffice 4.1.7, LibreOffice 7.0.1.2 on Windows 7 Pro, Ultimate & Windows 10 Home (2004)
If you believe your problem has been resolved, please go to your first post in this topic, click the Edit button and add [Solved] to the beginning of the Subject line.
User avatar
RusselB
Moderator
 
Posts: 6422
Joined: Fri Jan 03, 2014 7:31 am
Location: Sarnia, ON


Return to Mac OSX

Who is online

Users browsing this forum: No registered users and 2 guests