Paste unformatted problem

Discuss the word processor

Paste unformatted problem

Postby TalonsPryde » Mon Dec 16, 2019 3:54 am

Nearly all the time, if I do anything in a document, the paste as unformatted text button I have on my bar grey's out. I can type a single character and it will do it. I have to save and reload the document to get the button to light back up. This is really annoying as I do a lot of C+P for archiving and referencing. To paste normally and then get them into the default format is a long drawn out process especially when I have links involved.

Anyone have an idea what I can do to get this rectified?

I am now running 4.1.7 on windows 10
Open Office 4.1.6 on windows 7 with sp1
User avatar
TalonsPryde
 
Posts: 16
Joined: Sun Nov 04, 2018 8:41 pm

Re: Paste unformatted problem

Postby FJCC » Mon Dec 16, 2019 4:39 am

I cannot replicate this. I added a Paste Unformatted Text button to the standard tool bar and it seems to work fine. Can you describe the exact sequence actions from opening the document to the button becoming inactive? Also, next to the regular paste icon on the standard tool bar there is a small black triangle. If you click that, you should see an option to paste as unformatted text. Is that active?
Windows 10 and Linux Mint, since 2017
If your question is answered, please go to your first post, select the Edit button, and add [Solved] to the beginning of the title.
FJCC
Moderator
 
Posts: 7540
Joined: Sat Nov 08, 2008 8:08 pm
Location: Colorado, USA

Re: Paste unformatted problem

Postby TalonsPryde » Mon Dec 16, 2019 5:18 am

I open the document, switch windows to copy text or what have you, switch back, paste unformatted, switch to another window copy, switch back, and the button is no longer available. I then have to save, refresh the document (reload), and then the button lights back up. Sometimes it happens when I scroll down to another part of the document. Sometimes I type or hit enter. It is so unpredictable that I waste time constantly saving my changes (in a 300+ page document) and reloading that it is driving me nuts. And it is not just in this document. I have a short quick notes dock that this happens to as well. That doc is around 3 pages long. I am thinking about doing a screen video with commentary to show what happens. I am hoping with my just updated to .7 that it will stop. This started about 6 weeks ago while I had 4.1.6. The auto update would never engage so until I came here today, I had no idea about 4.1.7
Open Office 4.1.6 on windows 7 with sp1
User avatar
TalonsPryde
 
Posts: 16
Joined: Sun Nov 04, 2018 8:41 pm

Re: Paste unformatted problem

Postby FJCC » Mon Dec 16, 2019 5:52 am

I just cannot get that to happen, so I suggest you reset your user profile. This will cause you to lose your customizations, so you will have to make the button again. First shutdown OpenOffice. Open any folder and enter
%appdata%\openoffice\4
in the address bar near the top. That will take you to a folder containing a folder named user. Rename that to user_old. Restart OpenOffice and you should get the registration screen. Is the problem gone? If it isn't gone, you can go back to your previous user profile by renaming the user_old folder back to user.
Windows 10 and Linux Mint, since 2017
If your question is answered, please go to your first post, select the Edit button, and add [Solved] to the beginning of the title.
FJCC
Moderator
 
Posts: 7540
Joined: Sat Nov 08, 2008 8:08 pm
Location: Colorado, USA

Re: Paste unformatted problem

Postby John_Ha » Mon Dec 16, 2019 1:21 pm

Windows' Ctrl+SHIFT+V pastes without formatting.
LO 6.3.5.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 7380
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Paste unformatted problem

Postby TalonsPryde » Mon Dec 16, 2019 7:24 pm

Nothing. Not even the shortcut works. And this is today.
Open Office 4.1.6 on windows 7 with sp1
User avatar
TalonsPryde
 
Posts: 16
Joined: Sun Nov 04, 2018 8:41 pm

Re: Paste unformatted problem

Postby RoryOF » Mon Dec 16, 2019 7:43 pm

On /Edit menu, is there an entry for /Paste Special ? Have you any Clipboard utilities installed?
Apache OpenOffice 4.1.7 on Xubuntu 18.04.4 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 30658
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Paste unformatted problem

Postby TalonsPryde » Mon Dec 16, 2019 8:06 pm

No clipboard utilities. I tried that method and it would not let me click it. It was greyed out.
Open Office 4.1.6 on windows 7 with sp1
User avatar
TalonsPryde
 
Posts: 16
Joined: Sun Nov 04, 2018 8:41 pm

Re: Paste unformatted problem

Postby John_Ha » Mon Dec 16, 2019 9:12 pm

Does Windows' Ctrl+SHIFT+V pastes without formatting. work as suggested above?

Test after booting in Safe Mode.

Strange problems are sometimes fixed by resetting the profile - see Resetting the user profile.

Google for PureText.
LO 6.3.5.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 7380
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Paste unformatted problem

Postby TalonsPryde » Mon Dec 16, 2019 9:43 pm

The control shift v did not work. And in safe mode it did not work. I am going to try the resetting the profile next.
Open Office 4.1.6 on windows 7 with sp1
User avatar
TalonsPryde
 
Posts: 16
Joined: Sun Nov 04, 2018 8:41 pm

Re: Paste unformatted problem

Postby John_Ha » Tue Dec 17, 2019 1:14 am

TalonsPryde wrote: the paste as unformatted text button I have on my bar ...

A paste as unformatted text button is not standard in AOO.

Q1. How have you got it?
Q2. Which toolbar is it on?
Q3. Is it an AOO supplied function?
Q4. Is it a user created icon which runs a user macro? If so, the macro may be faulty. If it is a macro you will need to copy it back to C:\Users\xxxxxx\AppData\Roaming\OpenOffice\4\user\basic\ after resetting the profile.

Q5. Can you please upload an image of the toolbar with the button.
Q6. Also please give any information you can add about what it is - eg right-click in the toolbar > Visible buttons. What does it show?

Clipboard02.gif
Right-click the Toolbar > Visible buttons

Q7. What happens when you click on the arrow next to the Paste icon and select Unformatted text? I note that this drop down menu only appears if I have text on the clipboard - if I have an image I get Bitmap instead.
Q8. Does your icon grey out if you do not have text on the clipboard but it works OK if you do have text on the clipboard?

Clipboard03.gif
Clipboard03.gif (18.28 KiB) Viewed 566 times
LO 6.3.5.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 7380
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Paste unformatted problem

Postby TalonsPryde » Tue Dec 17, 2019 2:28 am

It IS a built in function.
2019-12-16 (4).png

2019-12-16 (5).png


I have no macros uploaded. I have no unnecessary scripts (the python spell check one is all I use). I only use what AOO gives me or official add ons. This is why I am completely confused. Even after creating a new profile, this continues. It greys out sometimes when I have clipboard text. Sometimes I will have clip text, move to another part of my document, and click where I want it, and the arrow deactivates and the rest of the paste special does not work. However, the regular paste does work. This is what frustrates me.
Open Office 4.1.6 on windows 7 with sp1
User avatar
TalonsPryde
 
Posts: 16
Joined: Sun Nov 04, 2018 8:41 pm

Re: Paste unformatted problem

Postby John_Ha » Tue Dec 17, 2019 1:35 pm

I cannot seem to find it in my AOO 4.1.7. Please describe the command sequence to get to your Add Commands window above. I can find it in LO.

In AOO go Tools > Customise > Toolbars. Select Toolbar = Standard. Click Add button to open a list with Paste Unformatted Text as an option. Add it to the Standard Toolbar. It works for me.

If it fails in Safe Mode and fails after resetting the profile then:

1. do a complete uninstall of AOO.
2. Rename C:\Users\xxxxxx\AppData\Roaming\OpenOffice\4\user to C:\Users\xxxxxx\AppData\Roaming\OpenOffice\4\user_OLD.
3. Download AOO from http://www.openoffice.org/download/index.html.
4. Install it.

I use PureText which pastes formatted with Ctrl+V and unformatted with Windows+V and works in any application.
LO 6.3.5.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 7380
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Paste unformatted problem

Postby DiGro » Tue Dec 17, 2019 7:47 pm

Just followed John-Ha's instructions.

Works for me too.

Option is added to Standard toolbar and work
____________
DiGro

AOO 4.1.7 on Windows 10. Scanned with ZIGGO Safe Online (F-Secure)
User avatar
DiGro
 
Posts: 94
Joined: Mon Oct 08, 2007 1:31 am
Location: Hoorn NH, The Netherlands


Return to Writer

Who is online

Users browsing this forum: No registered users and 21 guests