Still not able to load OpenOffice

Issues installing under the Mac OSX - X11 - Aqua

Still not able to load OpenOffice

Postby Oldgit » Tue Oct 29, 2019 1:52 pm

Still suffering from the problem (a box stating "The OpenOffice configuration has been changed. Under Tools-Options-OpenOffice-Java, select the Java runtime environment you want to have used by OpenOffice.") Not able to resolve this.

Now about to revert back to previous version.

Is this likely to compromise my security?

Thank-you for any help.

(God knows what will happen if/when I upgrade to my OSX to Catalina! :shock: )
Open Office 4.1.7 on MacOS 10.14
Oldgit
 
Posts: 3
Joined: Sat Oct 26, 2019 12:39 pm

Re: Still not able to load Open Office

Postby RoryOF » Tue Oct 29, 2019 2:40 pm

I cannot recollect if you have been directed to the Mac FAQ; this solves many Mac related problems.
[Tutorial] Mac FAQ

I recollect that some versions of Mac need Oracle's Java 6 installed, which can then be overlaid with a later Java version.

Note: I am not a Mac user, so my information is based on memory, not personal experience and should be judged with care.

OO seems to work OK on Catalina, but there may need to be some fine tuning.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.4 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 30414
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Still not able to load Open Office

Postby robleyd » Tue Oct 29, 2019 2:56 pm

There is information about Java and Macs in Q06/A06 of [Tutorial] Mac FAQ. You may also find some useful advice in Troubleshooting Open/LibreOffice and Java

With reference to Catalina, there may be problems with an error along the lines of "OpenOffice can’t be opened because Apple cannot check it for malicious software'; the solutions in Q05/A05 of [Tutorial] Mac FAQ will work for this situation.
Cheers
David
Apache OpenOffice 420m2(Build:9821) - Slackware 14.2 - 64 bit
LibreOffice 6.0.7.3 - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
robleyd
Moderator
 
Posts: 3141
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: Still not able to load Open Office

Postby Oldgit » Tue Oct 29, 2019 3:16 pm

Thank-you "RoryOF" and "robleyd" for your responses and suggestions. Unfortunately, this still hasn't resolved the issue. I installed Java 6, then reinstalled OO 4.1.7 but still got the same dialogue box.

I have reverted to my trusty old 4.1.6 for now, as it works. Shame, as I really like Open Office. It is simple, intuitive and does the job.

I am also holding off Catalina as that appears to be the current words of wisdom. Too much to go wrong and not enough time to figure it all out.

Once again, thank-you and if anyone becomes aware of any other potential fixes, do let me know.
Open Office 4.1.7 on MacOS 10.14
Oldgit
 
Posts: 3
Joined: Sat Oct 26, 2019 12:39 pm

Re: Still not able to load Open Office

Postby RoryOF » Tue Oct 29, 2019 3:36 pm

When one starts OpenOffice after installation it is sometimes necessary to use

(On PC/Linux) /Tools /Options /OpenOffice /Java,
(on Mac) Preferences - Options -OpenOffice -Java (I think this is the correct path)

and there select the installed Java if it is not automatically detected (detection may take a minute or two).
Apache OpenOffice 4.1.7 on Xubuntu 18.04.4 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 30414
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Still not able to load OpenOffice

Postby lgusaas » Sat Nov 30, 2019 9:32 pm

Get the latest version of Java from Oracle.
https://www.oracle.com/technetwork/java ... index.html
Larry I. Gusaas
Moose Jaw, SK Canada
Website: http://larry-gusaas.com
"An artist is never ahead of his time but most people are far behind theirs." Edgard Varese
Apache OpenOffice 4.1.7 — MacBook Pro(Retina)—macOS Ver.10.15.3 Catalina
lgusaas
Volunteer
 
Posts: 1553
Joined: Sun Mar 30, 2008 8:32 pm
Location: Moose Jaw, SK Canada

Re: Still not able to load OpenOffice

Postby Villeroy » Sat Nov 30, 2019 10:32 pm

AOO 4.1.7 supports https://adoptopenjdk.net/ as well.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 27731
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany


Return to Mac OSX

Who is online

Users browsing this forum: No registered users and 1 guest