[SOLVED] "out of memory"

Creating tables and queries

[SOLVED] "out of memory"

Postby Jerold » Mon Nov 12, 2018 8:44 pm

When I double click MyODB.odb and then select Tables, I received:
"The connection to the data source "Myodb" could not be established.

error in script file line 12 out of memory".

Expanding the error yielded:
SQL Status S1000
Error Code 78

I was also unable to open TOOLS/SQL.

I restarted my computer and that didn't help.

I then tried 2 different backup files that had previously worked, without any success.

I tried the ZIP trick from https://forum.openoffice.org/en/forum/v ... 61&t=63857 without any luck.

Finally, I openned the program OpenOffice Base and told it to open an existing database AND to my delight, IT WORKED.

I immediatly openned TOOLS/SQL and ran:

which shrunk the database significantly (over 100 times smaller)

Hope the helps someone.
Last edited by robleyd on Tue Nov 13, 2018 1:17 am, edited 1 time in total.
Reason: Add green tick [robleyd, Moderator]
OpenOffice 4.1.5 on Windows 10 Home
Posts: 9
Joined: Sun Sep 16, 2018 11:18 pm

Re: [SOLVED] "out of memory"

Postby RusselB » Mon Nov 12, 2018 9:52 pm

Thanks for the helpful post.
Sharing information like this is part of what makes these forums work.
OpenOffice 4.1.7 and LibreOffice on Windows 7 Pro & Ultimate
If you believe your problem has been resolved, please go to your first post in this topic, click the Edit button and add [Solved] to the beginning of the Subject line.
User avatar
Posts: 6116
Joined: Fri Jan 03, 2014 7:31 am
Location: Sarnia, ON

Return to Tables & Queries

Who is online

Users browsing this forum: No registered users and 1 guest