Inserted Object is not shown any longer

Writing a book, Automating Document Production - Discuss your special needs here

Inserted Object is not shown any longer

Postby Stupsi76 » Mon Feb 01, 2016 12:05 pm

Dear all,

I am an advanced user of Open Office. I already repaired a lot of issues directly in the source code of the documents (format of Open Office documents is zip-file).

BUT I would like to know why it happens during editing a document that an integrated object is disappearing without doing anything. (see attached file)
And the second question is: What do I have to do to reactivate it (clicking on the object it is opening and it is editable).

I am looking forward to receive some hints (by-the-way: option View/Graphics and Objects is switched on!)

Many thanks!
Attachments
object_view.jpg
Object is not shown correctly
OpenOffice 4.1 on Windows 7
Stupsi76
 
Posts: 9
Joined: Sun Aug 23, 2015 2:47 pm

Re: Inserted Object is not shown any longer

Postby Zizi64 » Wed Feb 03, 2016 9:00 am

What is that object?
A picture? Which filetype is it?
A Chart? Where you inserted it from?
An another document? Which type is it?

Is that object embedded, or linked only?


Can you upload (or link from a file sharing service) your example .odt file here?
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.3;AOO4.1.7
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 9179
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Inserted Object is not shown any longer

Postby Stupsi76 » Wed Feb 03, 2016 10:15 am

Good morning Zizi64,

this object is a draw file (.odg) and it is embedded. Clicking on this object is opening the draw correctly but it is neither not shown in normal writing mode of the odt file nor able to be exported to pdf-File.

I am not able to upload the file due to confidential reasons.
OpenOffice 4.1 on Windows 7
Stupsi76
 
Posts: 9
Joined: Sun Aug 23, 2015 2:47 pm

Re: Inserted Object is not shown any longer

Postby RoryOF » Wed Feb 03, 2016 10:35 am

Why not export the drawing in .png format and insert that in the Writer file?
Apache OpenOffice 4.1.7 on Xubuntu 18.04.4 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 30882
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Inserted Object is not shown any longer

Postby Stupsi76 » Wed Feb 03, 2016 10:47 am

That was my short notice solution now BUT the quality of this drawing is not the same as importing it directly from drawing. So for long term I am looking for a solution to use the option import object.
OpenOffice 4.1 on Windows 7
Stupsi76
 
Posts: 9
Joined: Sun Aug 23, 2015 2:47 pm

Re: Inserted Object is not shown any longer

Postby RoryOF » Wed Feb 03, 2016 10:55 am

In the Export as .png one gets an option to specify the resolution, which by default is set quite low; have you tried increasing this?

Is your embedded file not working on the design computer, or is it failing when you move to another computer?
Apache OpenOffice 4.1.7 on Xubuntu 18.04.4 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 30882
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Inserted Object is not shown any longer

Postby Zizi64 » Wed Feb 03, 2016 11:12 am

Why not export the drawing in .png format and insert that in the Writer file?

That was my short notice solution now BUT the quality of this drawing is not the same as importing it directly from drawing.


Yes, the compressed pixel based picture has not same quality as the original vectorgraphic content. But you can copy these object from the Draw application into the Writer by select/copy/paste the objects what you want to embed into the .odt document.

Or you can try the vectorgraphic export/import function (.svg or other)
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.3;AOO4.1.7
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 9179
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Inserted Object is not shown any longer

Postby RoryOF » Wed Feb 03, 2016 11:18 am

Just as a test, using OO 4.1.2, I made a simple .odg file and embedded it into a Writer file. I've closed OO and reopened the Writer file several times; it asks if it should update links on opening, then the current version of the .odg file shows up. I attach the content.xml file from Writer - the embedded file is called diamond.odg; perhaps it may be worth looking at content.xml on the damaged Writer file to see if there is some form of corruption or error in the linking code.
Attachments
content.xml
simple file to show OLE link
(3.7 KiB) Downloaded 187 times
Apache OpenOffice 4.1.7 on Xubuntu 18.04.4 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 30882
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Inserted Object is not shown any longer

Postby Zizi64 » Wed Feb 03, 2016 11:32 am

I made a simple .odg file and embedded it into a Writer file. I've closed OO and reopened the Writer file several times; it asks if it should update links on opening, then the current version of the .odg file shows up.


Then you linked only that Draw file, is not? Object embedded _really_ will not ask any link update.
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.3;AOO4.1.7
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 9179
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Inserted Object is not shown any longer

Postby Stupsi76 » Wed Feb 03, 2016 12:03 pm

This is happening in larger documents. The problem occurs not only with embedded drawings but with linked drawings, too. I repaired the document by deletion of the corrupt drawing and afterwards deleting the history content in the content.xml.
May be the option Changes tracking is having an influence on this, too.
OpenOffice 4.1 on Windows 7
Stupsi76
 
Posts: 9
Joined: Sun Aug 23, 2015 2:47 pm

Re: Inserted Object is not shown any longer

Postby RoryOF » Wed Feb 03, 2016 12:04 pm

Good catch, Tibor. I've made the file again, this time definitely embedding the graphic and am able to open and close with no loss of the embedded object, which maintains its identity as a distinct object.

Stupsi76's problem may be related to other cases of graphics vanishing, as investigated by John_Ha and discussed in
https://forum.openoffice.org/en/forum/viewtopic.php?f=7&t=80925

John_Ha suggests a possible fix in that thread, which involves changing a default directory. I've never had any problem with vanishing images, but I work on linux and only very rarely have I needed to prepare an image-using booklet; the "vanishing images" problem may not apply to that operating system.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.4 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 30882
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland


Return to Advanced Uses

Who is online

Users browsing this forum: No registered users and 1 guest