odb.lck files

Creating tables and queries

odb.lck files

Postby rmatosoffice » Mon Nov 09, 2015 10:54 pm

Hi, I'm using open office ver 4.1.1, my os windows 7.
I created a database, everything was fine, now I try to open it and it shows a table with Filter Selection option .. I tried with all of them but it doesn't open.
Now it duplicated 2 files .odb and . odb.lck
Open office 4.1.1
Windows 7
Posts: 1
Joined: Mon Nov 09, 2015 10:04 pm

Re: odb.lck files

Postby RusselB » Tue Nov 10, 2015 12:13 am

The .lck file implies that the associated database (as indicated by the .odb in the filename) is an open database or was not properly closed.
This may happen if the computer is shutdown before the file is properly written to the hard drive.... fairly common for those using laptops that are set to shut down when the lid is closed.
Check the sizes and date/time of the .odb and the .lck files. If the size is the same and the date/time is close (ie: within a minute or two), then you should be safe to delete the .lck file (ie: send it to the Windows Recycle Bin)
As you are using Windows 7, I suggest that you create a system restore point just in case.... also don't empty your recycle bin.
If you still can't open the .odb file, then copy the file and rename the copy changing the .odb extension to .zip, then extract the file called contents.xml
Other helpers on this forum have more experience with this type of thing, thus I will bow my head to their expertise if they should advise you differently and/or with additional information.
OpenOffice 4.1.7, LibreOffice on Windows 7 Pro, Ultimate & Windows 10 Home (2004)
If you believe your problem has been resolved, please go to your first post in this topic, click the Edit button and add [Solved] to the beginning of the Subject line.
User avatar
Posts: 6171
Joined: Fri Jan 03, 2014 7:31 am
Location: Sarnia, ON

Re: odb.lck files

Postby MTP » Tue Nov 10, 2015 9:47 pm

It sounds like your file got corrupted.

Taking a look at the xml as RusselB suggested is probably the best bet at fixing it. (All OpenOffice files can are actually zip files with, among other things, xml files inside.) A lot of times the error is obvious (a misspelled word or a missing space or something); fixing the error then rezipping can make the file work again.

If you'd like someone else to take a stab at it, if there is no sensitive information you could post it to these forums - or if the file is to big you could upload to a file sharing site (mediafire or dropbox, that kind of thing) and post a download link.

If the file is sensitive you could PM one of the volunteers to ask one to look at it privately. There's only one volunteer that I'm aware of who is good at fixing Base files specifically (not me), but I'm sure many of us would give it a try.
OpenOffice 4.1.1 on Windows 10, HSQLDB 1.8 split database
User avatar
Posts: 1620
Joined: Mon Sep 10, 2012 7:31 pm
Location: Midwest USA

Return to Tables & Queries

Who is online

Users browsing this forum: No registered users and 5 guests