Formula works in Excel but not in Calc. Bug?

Discuss the spreadsheet application

Formula works in Excel but not in Calc. Bug?

Postby hozedhead » Sat Apr 12, 2008 2:06 am

I copied this cell formula from an Excel spreadsheet and plugged it into a cell in a template for OO.oCalc 2.3.1:

=IF($F$19>10.99%;"8.5%";IF($F$19>9.99%;"7.5%";IF($F$19>8.99%;"6.75%";IF($F$19>7.99%;"6.0%";IF($F$19>6.99%;"5.0%";IF($F$1
9>5.99%;"3.50%";IF($F$19>4.99%;"2.75%";IF($F$19<4.99%;"0"))))))))

It's a template to figure out rebates from my wholesaler. The correct percentage appears in the cell, but when I try to multiply another cell value by the percentage, I always get 0.00. It works in Excel, but not in Calc. Any ideas?
hozedhead
 
Posts: 2
Joined: Sat Apr 12, 2008 1:53 am

Re: Formula works in Excel but not in Calc. Bug?

Postby acknak » Sat Apr 12, 2008 2:54 am

The single biggest source of problems in moving between Calc and Excel has bitten you too.

Excel treats text that looks like a number, as a number. Calc treats text that looks like a number, as zero.

Just remove all the quote from around the percentage values in your formula. Then the result will be a purely numeric value and you can use it in further calculations.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Formula works in Excel but not in Calc. Bug?

Postby hozedhead » Sat Apr 12, 2008 2:58 am

Thanks for the fast reply! I'll try it Monday.
hozedhead
 
Posts: 2
Joined: Sat Apr 12, 2008 1:53 am


Return to Calc

Who is online

Users browsing this forum: No registered users and 24 guests