Page 1 of 1

[TIP]Math objects: alignment and spacing on Writer documents

PostPosted: Thu Nov 22, 2007 4:50 pm
by RGB
With the default set-up, Math objects are inserted on a Writer document with a huge space before and after them. In order to get rid of that space for ever (at least, on new objects), you need to follow two simple steps:
  • Open the stylist (F11) and go to the “Frame styles” (the third button from left to right). There, edit (Right click -> Modify) the style “Formula”. On the “Wrap” tab, set the left and right spacing to zero. Finally, save that document as your default template.
  • Open (or create) a Math object and go to Format -> Spacing. Under “Category” you must select “Borders” and set the spacing to zero. Finally, press the “Default” button.

There is an old (and still unresolved) issue about alignment for Math objects ( Issue 972 ): Specially when there is no equal sign, the alignment with the text could be very bad. There is no “automatic” solution, but you can change the object's position easily and with high precision by selecting it and using Alt+Arrow keys (Yes, that use of the Alt key is documented: on the OOo help, look for “objects;moving/resizing using keyboard”)

 Edit: (February, 2012) AOO 3.4 will include automated alignment of Math objects on Writer documents. A new option (enabled by default on new documents) under Tools → Options → Writer → Formatting aids → Layout assistance → Math baseline alignment is introduced. 

Re: [TIP]Math objects: alignment and spacing on Writer documents

PostPosted: Thu Nov 22, 2007 9:59 pm
by pratanakangsadal
I don't know how else to offer for your kindness but saying many thanks. I followed your clear directions and got everything done in 3 minutes. Need to use the Math now. May you be just a little more happy as I am now for the rest of your life. Bye.

Re: [TIP]Math objects: alignment and spacing on Writer documents

PostPosted: Thu Aug 07, 2008 7:51 pm
by max5555
Thank you very much!


What about spacing INSIDE formulas? I have big spaces between letters, when they are separated by space in script (I don't know the right name for the text in the formula editing window). As far as I remember in previous version of 1:2.4.0-3ubuntu6 (hardy) and earlier ones the spaces were used omitted. My current version is 1:2.4.1-1ubuntu2 (hardy-updates). Also there are huge spaces between variables and indexes something like "A b" instead of "Ab" for A_b. Is it a bug?


O'k it is a bug. You will face this problem if you will open and save the document with formulas without installed. To fix broken formulas you have to copy the text entry (script) for the formula, then you have to go out from the formula editor and open a new one and paste the script.