[Solved] Add button in spell checker doesn't work

Discuss the word processor
Post Reply
ostenh
Posts: 8
Joined: Tue Sep 01, 2009 9:40 am

[Solved] Add button in spell checker doesn't work

Post by ostenh »

Hello,

The Add (to dictionary) button in the spell checker dialog doesn't seem to work. Nothing happens when I click it. Anyone else who has this problem?

Longer explanation: When I press F7, the spelling dialog box opens. I want to add the the redmarked word (which has no correct suggestion) because it's a technical term I use often. I click the Add button ("Lägg till" in Swedish), but nothing happens.

I use the Swedish version on Windows XP.

Thanks in advance,
Last edited by Hagar Delest on Wed Sep 02, 2009 1:23 pm, edited 1 time in total.
Reason: tagged [Solved].
OpenOffice 3.1 on Windows XP
pingju
Volunteer
Posts: 233
Joined: Fri Jul 31, 2009 11:09 pm

Re: Add button in spell checker doesn't work

Post by pingju »

I assume that you need to select a dictionary to which to add new vocabulary, normally it is "standard". Sure you can have you customized dictionary.
OpenOffice 3.1 on Windows Vista / XP SP3 EN
User avatar
Hagar Delest
Moderator
Posts: 30420
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Add button in spell checker doesn't work

Post by Hagar Delest »

Have you tried to add it through the right click in the main text?
LibreOffice 7.2.6 on Xubuntu 22.04 and 7.2.6 portable on Windows 10
ostenh
Posts: 8
Joined: Tue Sep 01, 2009 9:40 am

Re: Add button in spell checker doesn't work

Post by ostenh »

Thank you for your answers.
pingju wrote:I assume that you need to select a dictionary to which to add new vocabulary, normally it is "standard". Sure you can have you customized dictionary.
I think the Add button should open a dialog for chosing which user dictionary to add the word to, but it doesn't. It seems dead...
Hagar de l'Est wrote:Have you tried to add it through the right click in the main text?
I don't see a menu choice for "Add word" in the right click menu, but there is a choice to open the same dialog window as F7, which puts me back to square one. :?

Is it just me? I have Openoffice installed on both my laptop and my desktop, and I have the same problem on both machines.
OpenOffice 3.1 on Windows XP
User avatar
Hagar Delest
Moderator
Posts: 30420
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Add button in spell checker doesn't work

Post by Hagar Delest »

Don't you have that option?
Add to dictionary.png
Add to dictionary.png (24.76 KiB) Viewed 12335 times
Have you tried to reset your OOo user profile? but don't transfer your personal data during the welcome process (if you had 2.x before), configuration files from the former version might corrupt the new profile.
LibreOffice 7.2.6 on Xubuntu 22.04 and 7.2.6 portable on Windows 10
ostenh
Posts: 8
Joined: Tue Sep 01, 2009 9:40 am

Re: Add button in spell checker doesn't work

Post by ostenh »

Actually, strangely enough I don't. In your picture it's between "Ignore all" and "Autocorrect", but I don't have that. Hope this image comes through OK:
Fullskärmsinfångning 2009-09-01 222018.jpg
Fullskärmsinfångning 2009-09-01 222018.jpg (17.67 KiB) Viewed 12330 times
OpenOffice 3.1 on Windows XP
User avatar
Hagar Delest
Moderator
Posts: 30420
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Add button in spell checker doesn't work

Post by Hagar Delest »

Have you tried to reset your user profile? Do you have a user-defined dictionary in Tools>Options>Language Settings>Writing Aids?
LibreOffice 7.2.6 on Xubuntu 22.04 and 7.2.6 portable on Windows 10
ostenh
Posts: 8
Joined: Tue Sep 01, 2009 9:40 am

Re: Add button in spell checker doesn't work

Post by ostenh »

Thanks Hagar for taking your time to answer!
Hagar de l'Est wrote:Have you tried to reset your user profile?
Yes, but it didn't change anything.
Hagar de l'Est wrote:Do you have a user-defined dictionary in Tools>Options>Language Settings>Writing Aids?
OK, I have the Swedish version, but is this what you mean:
options.jpg
OpenOffice 3.1 on Windows XP
User avatar
RoryOF
Moderator
Posts: 33547
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Add button in spell checker doesn't work

Post by RoryOF »

I wonder are the dictionaries in case in question set ReadOnly, and in consequence the system did not install the Add to dictionary entry? I suggest you create your own dictionary: /Tools /Options / Writing Aids / User Defined Dictionaries and press New. Then OK out and restart OpenOffice to give it every chance to find the New dictionary.
Apache OpenOffice 4.1.12 on Xubuntu 20.04.4 and very infrequently on Win2K/XP
ostenh
Posts: 8
Joined: Tue Sep 01, 2009 9:40 am

Re: Add button in spell checker doesn't work

Post by ostenh »

RoryOF wrote:I wonder are the dictionaries in case in question set ReadOnly, and in consequence the system did not install the Add to dictionary entry? I suggest you create your own dictionary: /Tools /Options / Writing Aids / User Defined Dictionaries and press New. Then OK out and restart OpenOffice to give it every chance to find the New dictionary.
I did this even before you suggested it, but to no avail. Just in case, I added another dictionary just now, but unfortunately that didn't help.

It all seems a bit strange. How difficult is it to switch to the English version of Openoffice? Perhaps this is some issue with the Swedish version.
OpenOffice 3.1 on Windows XP
User avatar
RoryOF
Moderator
Posts: 33547
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Add button in spell checker doesn't work

Post by RoryOF »

It is possible that some lines of code have been omitted in the Swedish version. The English version works well under XP, and I wouldn't think there will be any difficulty in installing it. If your English is as good as many Swedes, and from your postings it is, you wil not have any difficulty in using OpenOffice in English.
Apache OpenOffice 4.1.12 on Xubuntu 20.04.4 and very infrequently on Win2K/XP
ostenh
Posts: 8
Joined: Tue Sep 01, 2009 9:40 am

Re: Add button in spell checker doesn't work

Post by ostenh »

RoryOF wrote:I wonder are the dictionaries in case in question set ReadOnly,
Perhaps this has something to do with it after all. If I create a new user dictionary, the New and Edit buttons are greyed out in the "Edit user dictionary" dialog box (I'm guessing about the English title). It seems not possible to edit them.

Secondly, the user dictionary I created myself disappear from Options/.../writing aids/user dictionaries/ when I restart the computer. Closing and restarting Writer is OK, but if I restart Windows they disappear. I don't know what this means...

Edit: I have installed the 3.1.1 US eng version, but the problem remains. I found this in the help file:
Available Language Modules
Contains the installed language modules.
A language module can contain one, two or three submodules: Spellcheck, hyphenation and thesaurus. Each sub-module can be available in one or more languages. If you click in front of the name of the module, you activate all the available sub-modules simultaneously. If you remove a set mark, you deactivate all the available sub-modules simultaneously. If you wish to activate or deactivate individual sub-modules, click the Edit button to open the Edit Modules dialog.

The configuration allows for two different directories: one folder where the user has write permissions, and one without write permissions. The user can only edit and delete the user dictionaries that are located in the writable path. Other dictionaries can be read only.
I don't understand what this last part means really.
OpenOffice 3.1 on Windows XP
User avatar
franx
Volunteer
Posts: 540
Joined: Wed Nov 12, 2008 9:25 pm
Location: FRA 'n' QXB

Re: Add button in spell checker doesn't work

Post by franx »

Hi,
have you checked the folder ...\user\wordbook?
Do you find there a file standard.dic?

Please, open the file Linguistic.xcu with a text editor.
(Path: ...\OpenOffice.org\3\user\registry\data\org\openoffice\Office\Linguistic.xcu).
Do you find standard.dic under "ActiveDictionaries"?

Sample →

Code: Select all

  <node oor:name="DictionaryList">
   <prop oor:name="ActiveDictionaries" oor:type="oor:string-list">
    <value>blabla.dic intern.dic names.dic standard.dic test.dic IgnoreAllList</value>
   </prop>
  </node>
Please, try to paste the attached standard.dic in your folder ...\user\wordbook.
(It contains the words: OpenOffice.org, Ägäis, Sverige, Öresund, Gothenburg, Malmö)
- Close OOo (+ quickstarter)
- Paste standard.dic in the folder wordbook
- Launch OOo and check (Options ... Writing Aids) whether standard.dic has the check mark
- Test the words OpenOffice.org, Ägäis, Sverige, Öresund, Gothenburg, Malmö
- Try to add a word to standard.dic ...
standard.zip
(75 Bytes) Downloaded 620 times
[default through OOo 3.2.1 / WBSWG6 format]

EDIT: [2010-08-22]
Please don't download the file above for OOo 3.3.0 and higher.
For OOo 3.3.0 and higher →

standard.dic in user-editable OOoUserDict1 format

Code: Select all

OOoUserDict1
lang: <none>
type: positive
---
Gothenburg
Malmö
OOo
Sverige
Ägäis
Öresund
standard.zip
(102 Bytes) Downloaded 265 times
[default from OOo 3.3.0 / OOoUserDict1 format]

[uploading *.dic isn't allowed - so I renamed it as *.zip.
Please, rename as *.dic]
HTH ...
Last edited by franx on Sat Nov 13, 2010 1:13 am, edited 2 times in total.
LibreOffice 4.0.4 · WinXP
ostenh
Posts: 8
Joined: Tue Sep 01, 2009 9:40 am

Re: Add button in spell checker doesn't work

Post by ostenh »

You solved it, Franx! I followed your steps and here are the results:
franx wrote:Hi,
have you checked the folder ...\user\wordbook?
Do you find there a file standard.dic?
No, the folder ...\user\wordbook is empty.
franx wrote: Please, open the file Linguistic.xcu with a text editor.
(Path: ...\OpenOffice.org\3\user\registry\data\org\openoffice\Office\Linguistic.xcu).
Do you find standard.dic under "ActiveDictionaries"?

Sample →

Code: Select all

  <node oor:name="DictionaryList">
   <prop oor:name="ActiveDictionaries" oor:type="oor:string-list">
    <value>blabla.dic intern.dic names.dic standard.dic test.dic IgnoreAllList</value>
   </prop>
  </node>
No, there is not even a node entry "DictionaryList" in the linguistic.xcu.
franx wrote: Please, try to paste the attached standard.dic in your folder ...\user\wordbook.
(It contains the words: OpenOffice.org, Ägäis, Sverige, Öresund, Gothenburg, Malmö)
- Close OOo (+ quickstarter)
- Paste standard.dic in the folder wordbook
- Launch OOo and check (Options ... Writing Aids) whether standard.dic has the check mark
- Test the words OpenOffice.org, Ägäis, Sverige, Öresund, Gothenburg, Malmö
- Try to add a word to standard.dic ...
It works! Spelling works as it should, and I can now add to and edit user dictionaries.

Any idea why this happened? I installed Oo on two different computers just a few weeks ago, an older desktop and a brand new laptop, and both installs had exactly the same problem.

I have a project to digitize an old technical paper which only exists as a stencil, and at the same time wanted to give Oo a chance and see if I could learn how to use it. I got stuck already on the first sentences you might say. ;) But the help here in the forum was really great, fast and to the point. Thanks to everyone that contributed.

Edit: phrasing
OpenOffice 3.1 on Windows XP
User avatar
Hagar Delest
Moderator
Posts: 30420
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Add button in spell checker doesn't work

Post by Hagar Delest »

Strange :shock:
First time I see that. Have you downloaded the installer from the official OOo web site?
LibreOffice 7.2.6 on Xubuntu 22.04 and 7.2.6 portable on Windows 10
User avatar
franx
Volunteer
Posts: 540
Joined: Wed Nov 12, 2008 9:25 pm
Location: FRA 'n' QXB

Re: [Solved] Add button in spell checker doesn't work

Post by franx »

It's really strange ... and it's a silly workaround ...
I know about two other users who had also mentioned a similar issue (maybe the same?).
But I don't have any further idea: What could be the cause of this effect ...

@ostenh:
You might download the Swedish language pack for help, user interface etc. in Swedish language.
Direct download link: OOo_3.1.1rc2_20090820_Win32Intel_langpack_sv.exe
LibreOffice 4.0.4 · WinXP
ostenh
Posts: 8
Joined: Tue Sep 01, 2009 9:40 am

Re: [Solved] Add button in spell checker doesn't work

Post by ostenh »

Hagar de l'Est wrote:Strange :shock:
First time I see that. Have you downloaded the installer from the official OOo web site?
Yes, absolutely.
franx wrote:@ostenh:
You might download the Swedish language pack for help, user interface etc. in Swedish language.
Direct download link: OOo_3.1.1rc2_20090820_Win32Intel_langpack_sv.exe
No, I'm going to use the English version from now on. This makes problem-solving like this much easier, and also if you want to search for help etc. I just installed US English version 3.1.1 over my old Swedish 3.1.0 without problems. Spelling still works great. :)
OpenOffice 3.1 on Windows XP
andreesc
Posts: 1
Joined: Thu Mar 18, 2010 7:25 pm

Re: [Solved] Add button in spell checker doesn't work

Post by andreesc »

Thank franx! that was I needed!
OpenOffice 3.2 on Windows XP
Post Reply