[Solved] Accidentally wrecked document with "read only" code

Discuss the word processor

[Solved] Accidentally wrecked document with "read only" code

Postby revben » Sun Sep 06, 2020 12:14 am

Hello, friends - I'm not sure of the exact terms for the issue I'm experiencing, but I'll add a screen shot in case that's helpful. If anybody has an idea how to fix this issue, I'd be forever grateful!

I was nearly complete with a document that includes text and inserted images in open office. I tried to bring in one other image (a PDF, I believe, which might have been the problem). When I dragged it into the document, and a dialogue box popped up. I was a bit fast and careless, and I don't remember what option I selected. Just wanted to see what would happen, which was a mistake.

Next, my document went from about 30 to about 1,000 pages, and the new pages were filled with odd characters. I tried to select and delete the characters, but they can't be deleted.

Anybody have a suggestion for something to try before I restart the whole project?
Attachments
Screen Shot 2020-09-05 at 6.05.03 PM.png
Screen shot of the document. The upper segment is the text of document. The lower side shows the odd characters that cannot be deleted.
Last edited by MrProgrammer on Sun Sep 06, 2020 4:16 am, edited 1 time in total.
Reason: Tagged ✓ [Solved]
Apache Open Office 4.1.7

mac OSX Mojave 10.14.6
revben
 
Posts: 5
Joined: Sun Sep 06, 2020 12:08 am

Re: Accidentally wrecked document with "read only?" code

Postby FJCC » Sun Sep 06, 2020 12:34 am

What happens if you select the menu item Edit -> Undo? You might try using it a few times.
Windows 10 and Linux Mint, since 2017
If your question is answered, please go to your first post, select the Edit button, and add [Solved] to the beginning of the title.
FJCC
Moderator
 
Posts: 7789
Joined: Sat Nov 08, 2008 8:08 pm
Location: Colorado, USA

Re: Accidentally wrecked document with "read only?" code

Postby revben » Sun Sep 06, 2020 1:08 am

Yes - that's a good idea. I did try that right after I made the mistake. I used Command z a few times, then used the edit menu, and undoing a few steps back didn't do anything to the odd characters.

I've since closed and re-opened the document. When I reopen it, I get a dialogue box I Haven't seen before. it says "update all links?" Yes / No. I've used both options and it doesn't seem to do anything different.
Apache Open Office 4.1.7

mac OSX Mojave 10.14.6
revben
 
Posts: 5
Joined: Sun Sep 06, 2020 12:08 am

Re: Accidentally wrecked document with "read only?" code

Postby FJCC » Sun Sep 06, 2020 1:58 am

I think what happened is you inserted the code of the PDF document into your file. You should be able to just delete all that. Just click at the beginning of the junk, scroll down and Shift + Click several page into the junk and press Delete. You could try doing the whole chunk at once. Be sure to make a copy of the document before you try anything.
Windows 10 and Linux Mint, since 2017
If your question is answered, please go to your first post, select the Edit button, and add [Solved] to the beginning of the title.
FJCC
Moderator
 
Posts: 7789
Joined: Sat Nov 08, 2008 8:08 pm
Location: Colorado, USA

Re: Accidentally wrecked document with "read only?" code

Postby revben » Sun Sep 06, 2020 2:07 am

Thanks, FJCC! Yes, I think you're exactly right about the code being a PDF link. It's the strangest thing, though. I can put my cursor at any point in the code characters and press delete, and nothing happens. I also have selected it, both the entire code, and parts of it and tried to delete with no result.

You have me thinking, though, and maybe there's some feature in open office that will "remove all PDF links" or something similar.
Apache Open Office 4.1.7

mac OSX Mojave 10.14.6
revben
 
Posts: 5
Joined: Sun Sep 06, 2020 12:08 am

Re: Accidentally wrecked document with "read only?" code

Postby revben » Sun Sep 06, 2020 2:12 am

I GOT it, everyone! What a relief. Thanks so much FJCC for getting me thinking about the PDF link. Here's the solution that worked:

First of all, I realized that I'd moved the PDF file I originally linked to into a different folder. So, I put it back where it was when I tried to insert it in the first place.
Then, when I reopened the document and it prompted me to "update all links?", I pressed YES. Upon the document loading, all of the code from the link was gone and things are back to how they should be.

So much appreciation!
Apache Open Office 4.1.7

mac OSX Mojave 10.14.6
revben
 
Posts: 5
Joined: Sun Sep 06, 2020 12:08 am

Re: Accidentally wrecked document with "read only?" code

Postby Bill » Sun Sep 06, 2020 2:26 am

In a test case, dragging a PDF file into Writer inserted the PDF code in a protected section. That's why you can't delete the code. In my case, with the PDF file in its original location, I renamed the PDF file then updated the links to delete the contents of the section, then removed the section.
AOO 4.1.7 on Manjaro Cinnamon
Bill
Volunteer
 
Posts: 7921
Joined: Sat Nov 24, 2007 6:48 am

Re: [Solved] Accidentally wrecked document with "read only"

Postby revben » Sun Sep 06, 2020 5:00 am

Nice - Yes, I'll try that with any future issues. I appreciate it!
Apache Open Office 4.1.7

mac OSX Mojave 10.14.6
revben
 
Posts: 5
Joined: Sun Sep 06, 2020 12:08 am


Return to Writer

Who is online

Users browsing this forum: No registered users and 20 guests