Labels don't print blanks lines

Discuss the word processor

Labels don't print blanks lines

Postby lutronjim » Thu Dec 19, 2019 5:45 am

Not sure if this is correct forum

I spent a couple of hours in win10 4.1.7 trying to keep a second address line from printing in labels using the 'insert section method' - several searches showed the same method but none would work. I guess a lot of posts are from older version maybe. I think it would be a lot of help for all if versions were mentioned in post.

Took a few hour off and then did another search - found a diffident method and it works - jest is below:

In the example above "ADDRESS2" might sometimes be empty; in that case we want to to avoid inserting a blank line in the output. To accomplish this feat, the paragraph containing db.Sheet1.ADDRESS2 should be conditionally hidden if the ADDRESS2 data field is empty for a particular label:
View->Data Sources if needed.
View->Hidden paragraphs checked
View->Non-printing characters checked
View->Field Names checked
Click immediately before or after "db.Sheet1.ADDRESS2" to prepare to insert. Be careful to not select the db reference itself or you'll end up replacing it.
Then: Insert->Fields->Other (a "Fields" dialog opens)
Click the Functions tab, then Hidden Paragraph
Enter an expression in the "Condition" box like this:
Drag the "ADDRESS2" column header from the Data Sources area to the "Condition" field in the Fields dialog (View->Data Sources to display Data Sources). Then insert an exclamation point in front of the resulting database reference. You should end up with something like this:
![db.Sheet1.ADDRESS2]
Click Insert once only, then Close
You should see Hidden Paragraph inserted into the label (visible only with View->Field Names).
OpenOffice 4.1.3 on Windows 10 home
lutronjim
 
Posts: 1
Joined: Wed Dec 21, 2016 1:13 am

Re: labels don't print blanks lines

Postby Villeroy » Thu Dec 19, 2019 7:43 am

Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 27760
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Labels don't print blanks lines

Postby DiGro » Thu Dec 19, 2019 2:30 pm

____________
DiGro

AOO 4.1.7 on Windows 10. Scanned with ZIGGO Safe Online (F-Secure)
User avatar
DiGro
 
Posts: 93
Joined: Mon Oct 08, 2007 1:31 am
Location: Hoorn NH, The Netherlands


Return to Writer

Who is online

Users browsing this forum: No registered users and 3 guests