Page 1 of 1

[Solved] Decimal formatting in Writer table

PostPosted: Tue Nov 19, 2019 7:13 pm
by LaRuminator
Hey, all, think this is an easy question, but troubleshooting it myself has gotten time-consuming, so here we are.

I need to stop a table in Writer from auto-formatting numerals and adding a zero below a decimal point (e.g. .5 becomes 0.5 and I don't want the zero). Where should I go to change this cell formatting to never include a zero before a decimal, and also to never round decimals up or down to the nearest whole number?

I'm a recent convert to OpenOffice from Word for Mac, following Apple's sunsetting of support for older versions of MS Office. For years I've used a Word doc template for invoicing clients. Opening and editing these invoice docs in OpenOffice has generally been fine so far, except that the formatting from the Word version of these tables hasn't carried over to OpenOffice 100%. Appreciate your assistance, folks.

Re: Decimal formatting in Writer table

PostPosted: Tue Nov 19, 2019 9:00 pm
by FJCC
You can select the cells you want to affect then right click and either remove the selection from Number Recognition or select Number Format and set that to whatever you want. If you are not doing calculations with the numbers, the easiest thing may be to turn off Number Recognition.

Re: Decimal formatting in Writer table

PostPosted: Tue Nov 19, 2019 9:54 pm
by LaRuminator
Fantastic. Both of those options do what I need, which is to make the numerals look good and consistent on the page, rather than calculate figures. Thank you!

Yeah, I'd consider this topic closed at this point. Appreciate how