[Issue] Keyboard volume keys do not work when OOo is open

Discuss setup / installation issues - Add a spell checker, Language pack?

[Issue] Keyboard volume keys do not work when OOo is open

Postby Sandoz » Sun Feb 01, 2009 9:56 pm

Using OOo 3.0.1 under Vista Hm Prm 32b SP1.

My keyboard has volume down, up, and mute buttons. When any OpenOffice app is the active window, these buttons do not work. (keyboard also has hotkeys for launching Internet, Mail, and Search applications, which do work)

If the window minimized or otherwise not the active window, the volume buttons work fine. Any suggestions?
Last edited by Hagar Delest on Fri Dec 25, 2009 12:54 pm, edited 1 time in total.
Reason: Tagged the thread as issue (link to a bug report).
OOo 3.0.X on MS Windows Vista
Sandoz
 
Posts: 4
Joined: Sun Feb 01, 2009 3:42 am

Re: Keyboard volume keys do not work when OOo is open

Postby Sandoz » Tue Feb 03, 2009 9:47 am

Can anyone confirm? Keyboard is a Rosewill RK-7310. Using built-in Windows keyboard drivers.

The problem even occurs if it's just the OpenOffice help window that is active! The volume keys work perfectly in every other app, except for OOo... :?:
OOo 3.0.X on MS Windows Vista
Sandoz
 
Posts: 4
Joined: Sun Feb 01, 2009 3:42 am

Re: Keyboard volume keys do not work when OOo is open

Postby Sardtok » Thu Mar 05, 2009 7:55 pm

Same thing happens to me in OO 3.0.1 in XP on my Dell laptop.
The buttons aren't part of the keyboard, but a small panel in front of the trackpad.
Function shortcuts on the keyboard itself, like brightness up/down and wlan adapter on/off still works. Only the volume controls get locked.

EDIT: Keyboard function keys related to volume (Fn+Pg Up/Dn and Fn+End for mute) also fail.
OOo 3.1.0 on Ms Windows XP and OOo 3.2.0 (DEV300m52) on andLinux
Sardtok
 
Posts: 4
Joined: Fri Oct 31, 2008 11:41 am

Re: Keyboard volume keys do not work when OOo is open

Postby Sandoz » Wed Mar 11, 2009 1:34 am

It seems OOo is locking any keyboard shortcuts relating to volume control, which does not make sense since these buttons have no functions within OOo. I didn't think it would bother me that much, but I realized the only times I'm using OOo are when I need to do work for school - working on papers and presentations for hours on end is when I listen to music the most! :(

I guess I can just remind myself to click the Windows volume icon to adjust, but it's just so much easier to do on keyboard when your hands are already all over the keys...
OOo 3.0.X on MS Windows Vista
Sandoz
 
Posts: 4
Joined: Sun Feb 01, 2009 3:42 am

Re: Keyboard volume keys do not work when OOo is open

Postby LeonResEvil2 » Tue Apr 14, 2009 1:37 am

I have had the same problem mentioned here. (I made an account just to see into this problem and try to get it resolved.) Using the Fn+Up, Fn+Down, and Fn+F8 (mute) keys on my Acer Extensa 5420 laptop, I cannot adjust the volume for any program while an OOo file is open. Taking the focus away from OOo (by minimizing, clicking the Start bar, or switching to another program) seems to solve the problem. I think the problem causing this may also be causing the sound issues in Impress that other people have reported.
LeonResEvil2
 
Posts: 1
Joined: Tue Apr 14, 2009 12:37 am

Re: Keyboard volume keys do not work when OOo is open

Postby bmtphoenix » Sat Apr 18, 2009 1:17 am

Yep, same here, using Vista with a Logitech G15 keyboard. There's also another thread here: http://www.oooforum.org/forum/viewtopic.phtml?p=322590#322590, though they don't have an answer yet either.
OOo 3.0.X on MS Windows Vista
bmtphoenix
 
Posts: 1
Joined: Sat Apr 18, 2009 1:15 am

Re: Keyboard volume keys do not work when OOo is open

Postby Sandoz » Thu Apr 23, 2009 7:52 am

Darn... nearly three months later - I was hoping this would be sorted out (or at least officially addressed/confirmed) by now!

I'm glad to see I'm not the only one, though. Back when I started this thread, I thought it was only me due to the lack of responses and lack of previous posts on the topic, but it looks like the problem does in fact exist across users.

Here's to hoping things will be fixed in an update! I'll be keeping an eye out for any solutions in the meantime.
OOo 3.0.X on MS Windows Vista
Sandoz
 
Posts: 4
Joined: Sun Feb 01, 2009 3:42 am

Re: Keyboard volume keys do not work when OOo is open

Postby Hagar Delest » Thu Apr 23, 2009 8:56 am

Then you should file a bug report and give the url of that thread to show that you're not alone: [Tutorial] Reporting bugs or suggestions.
LibreOffice 7.0.3 on Xubuntu 20.10 and LibreOffice 7.0 (portable) on Windows 10.
User avatar
Hagar Delest
Moderator
 
Posts: 29613
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Keyboard volume keys do not work when OOo is open

Postby rockNme2349 » Thu Dec 03, 2009 7:21 pm

I have found a temporary workaround for this problem using autohotkey.

Here is the code for the script:
Code: Select all   Expand viewCollapse view
#NoEnv  ; Recommended for performance and compatibility with future AutoHotkey releases.
SendMode Input  ; Recommended for new scripts due to its superior speed and reliability.
SetTitleMatchMode, 2 ;Text can be anywhere in the title name

#IfWinActive OpenOffice.org

Volume_Up::
WinGetActiveTitle, current
WinActivate ahk_class Shell_TrayWnd
Send {Volume_Up}
WinActivate %current%
return

Volume_Down::
WinGetActiveTitle, current
WinActivate ahk_class Shell_TrayWnd
Send {Volume_Down}
WinActivate %current%
return

Volume_Mute::
WinGetActiveTitle, current
WinActivate ahk_class Shell_TrayWnd
Send {Volume_Mute}
WinActivate %current%
return


Basically if open office is active, and you press the volume keys, it will bring the taskbar to the foreground, send the volume key to the taskbar, and then reactivate the previous window. This has worked for me.

I uploaded a compiled version with the source code here: http://www.mediafire.com/?wm25nwz4wkn. If you aren't interested in how it works all you have to do is download that file, extract it and run the exe. It will sit in the taskbar and then you can use your volume keys normally. If you understandably don't want to run an random exe, you can download autohotkey from the link above, and just paste the code above into a new .ahk file and run that.
OpenOffice 3.1
Windows 7
rockNme2349
 
Posts: 1
Joined: Thu Dec 03, 2009 7:11 pm

Re: Keyboard volume keys do not work when OOo is open

Postby Zak » Sat Dec 05, 2009 11:00 am

I have the exact issue on a Dell Latitude 5500.
Whenever OpenOffice is the active window, the volume buttons on the laptop do not work anymore... This is really annoying.
I don't see why OO would need to intercept those buttons...
OpenOffice 3.1.1 (Build 9420) on Windows XP SP3
Zak
 
Posts: 1
Joined: Sat Dec 05, 2009 10:48 am

Re: Keyboard volume keys do not work when OOo is open

Postby KamehamehaX » Thu Dec 24, 2009 6:36 pm

I just want to put in my lot with the rest of you. I am running on a Sony VGN-FW139/E Vaio laptop with Openoffice.org version 3.1. I am currently running Windows 7 Home Premium, but had the same problem when I was running Vista.

It is really obnoxious to not have volume or media buttons when I am working on a document. As someone said before me, that is the time I listen to the most music! As a writer, you can imagine why this would be bothersome. Also, it doesn't seem like anyone has mentioned this specifically, so for clarity's sake, I will. It's not just my volume buttons that do not function when OOo is the active window. My Vaio is equpped with a full complement of special media buttons that, on top of allowing volume control, also allow me to fast-forward, rewind, skip tracks, play/pause, etc. right from my keyboard. None of those work either.
Openoffice.org 3.1
Windows 7 Home Premium
KamehamehaX
 
Posts: 3
Joined: Thu Dec 24, 2009 6:30 pm

Re: Keyboard volume keys do not work when OOo is open

Postby RoryOF » Thu Dec 24, 2009 7:03 pm

I, on the other hand, prefer to devote my little brain power to actually writing and see no need for volume keys in OpenOffice. If I had to listen to music while writing, I'd put a CD on the ghetto blaster. I admit I'm old fashioned - I see the computer as a tool (an invaluable tool), not as an entertainment machine. But a Happy Christmas anyway!
Apache OpenOffice 4.1.9 on Xubuntu 20.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 32364
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Keyboard volume keys do not work when OOo is open

Postby Bill » Thu Dec 24, 2009 10:11 pm

This bug is still present in OOo 3.2 RC1. It has at least 30 votes spread over at least 5 bug reports.

Issue 99520
Issue 98795
Issue 100769
Issue 101739
Issue 103155
Bill
Volunteer
 
Posts: 8161
Joined: Sat Nov 24, 2007 6:48 am

Re: Keyboard volume keys do not work when OOo is open

Postby KamehamehaX » Tue Dec 29, 2009 12:16 am

RoryOF wrote:I, on the other hand, prefer to devote my little brain power to actually writing and see no need for volume keys in OpenOffice. If I had to listen to music while writing, I'd put a CD on the ghetto blaster. I admit I'm old fashioned - I see the computer as a tool (an invaluable tool), not as an entertainment machine. But a Happy Christmas anyway!


RoryOF, I understand your point, but your comments are singularly unhelpful.

Think, briefly, if you will, about the context of your message, rather than the message itself. By posting this message, you were admitting, essentially, that you had nothing better to do than find a problem that other people have, and MAKE SURE they knew your opinion on the subject, however unhelpful that opinion may be. That your thoughts, in their glory, were sprayed far and wide out into the internet was your primary goal, and if that be the case, you have succeeded.

Please... If you must comment on a troubleshooting forum, make sure your post is helpful.
Openoffice.org 3.1
Windows 7 Home Premium
KamehamehaX
 
Posts: 3
Joined: Thu Dec 24, 2009 6:30 pm

Re: [Issue] Keyboard volume keys do not work when OOo is open

Postby RoryOF » Tue Dec 29, 2009 12:32 am

Look at my record - 1550+ posts on this forum, with quite a reasonable success rate. If you want me to put it bluntly, I suggest it is folly to run high usage applications, such as sound or video players, on a computer that is being used (as many are) for important work such as essays, theses, databases or spreadsheets. Every week there are a number of appeals for help because someone's file "of utmost importance" has got corrupted. It is my belief that most of thse corruptions are due to the overloading of the machine by such high usage applications. I have not had a file corruption in four years of StarOffice/OpenOffice use; I am a heavy computer user doing text composition and layout, and graphic design. Make up your own mind about why.
Apache OpenOffice 4.1.9 on Xubuntu 20.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 32364
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Issue] Keyboard volume keys do not work when OOo is open

Postby KamehamehaX » Tue Dec 29, 2009 1:05 am

@RoryOF:

First, I want you to know that I appreciate you clarifying your intention with the last post.

Second, if you had one off-topic post for every marginally useful one, as is the case here, then your 1500+ posts is, mathematically, half as impressive. If, rather, you have two off-topic/useless posts for each marginally useful one, then your post count is reduced to 500 useful, on-topic posts in your history. By factoring in your success rate to the remaining 500 posts in this scenario, your amount of useful posts is even less than that. I appreciate your desire to help, and I cannot attest for how often you have actually helped someone on this board. I would hope it was often, honestly, because sometimes people need it. The fact is, though, that both of your statements have been singularly unhelpful in solving the issue at hand which is, "Keyboard volume keys do not work when OOo is open."

Third, you make a valid conversation point about people pushing their computers too hard by using them as media players when they are trying to do important work/hold important data on them, but that is not the title of this thread. GO MAKE A NEW ONE to discuss that. I don't want to hear someone's opinion about how to use my computer on a forum thread. I want them to fix the problem that the thread is discussing.

Don't be offended, just be mindful of the reason that the troubleshooting forum was created for. Be helpful to the problem discussed in the thread.

Now, back to topic...
Openoffice.org 3.1
Windows 7 Home Premium
KamehamehaX
 
Posts: 3
Joined: Thu Dec 24, 2009 6:30 pm

Re: [Issue] Keyboard volume keys do not work when OOo is ope

Postby oggologgo » Mon May 13, 2013 5:37 pm

This bug is still there. It's quite annoying. I'm using windows 7 and open office 3.4.1.

RoryOF wrote:Look at my record - 1550+ posts on this forum, with quite a reasonable success rate. If you want me to put it bluntly, I suggest it is folly to run high usage applications, such as sound or video players, on a computer that is being used (as many are) for important work such as essays, theses, databases or spreadsheets. Every week there are a number of appeals for help because someone's file "of utmost importance" has got corrupted. It is my belief that most of thse corruptions are due to the overloading of the machine by such high usage applications. I have not had a file corruption in four years of StarOffice/OpenOffice use; I am a heavy computer user doing text composition and layout, and graphic design. Make up your own mind about why.


Nobody cares about what you like to use your computer for. It has no relevance AT ALL in this context.

There is a bug in open office, causing volume keys to not work, while open office has focus, on some computers. This is a bug. I have never seen another program cause this. Keep your moronic ideals about how to use a computer to yourself. They have nothing to do with this.

You talk like you haven't kept up with time, since the 90s. Sound and video players are not "high usage applications". They have nothing to do with any files being corrupted. I have music running, streaming TV, playing videos, downloading files, torrents, etc.... Loads of things running at the same time, and guess what, I never experience any corrupted files.

You clearly have no clue about computers, and no clue about what you are talking about. (I realize this is an old topic. But I was googling the problem and found it, and this stupidity annoyed me. Deal with it)
OpenOffice 3.1.1 on Windows XP
oggologgo
 
Posts: 5
Joined: Sat Nov 07, 2009 4:00 pm

Re: [Issue] Keyboard volume keys do not work when OOo is ope

Postby RoryOF » Mon May 13, 2013 5:48 pm

For your information I have used a computer daily for the past 35 years, and occasionally in the fifteen years before that. I have built computers from scratch (including designing, etching and populating the circuit boards), I have fine tuned operating systems and written applications in a number of languages. You are as entitled to your opinion as I am entitled to mine.

When you lose you important work, read my posting again and reconsider your stance.
Apache OpenOffice 4.1.9 on Xubuntu 20.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 32364
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Issue] Keyboard volume keys do not work when OOo is ope

Postby vorshlumpf » Sun Jan 05, 2014 8:27 pm

I've been tolerating this issue for years now, on 6 different machines and 4 OSs (all Windows). At first I just assumed such a significant bug (i.e., hijacking of keyboard keys) would be reported and fixed quickly. After dealing with it yet again this morning, I decided to finally look into whether or not it was reported and what was going on. I'm quite surprised to see that, in the 1799 days since this was reported, that there hasn't been any acknowledgement of this problem here or on Bugzilla. Well, for what it's worth, add me to the list of people that find this quite annoying.

- Niilo
OpenOffice 3.4.1
WinXP & Win8
vorshlumpf
 
Posts: 3
Joined: Fri Feb 22, 2013 11:14 pm

Re: [Issue] Keyboard volume keys do not work when OOo is ope

Postby hannoman » Fri Feb 26, 2016 8:11 pm

Still having this problem on Windows 7 Professional / OpenOffice 4.1.1 while trying to use custom bound keys for volume modification on my Logitech G500s mouse.
Windows 7 Professional / OpenOffice 4.1.1 (as of 02-2016)
hannoman
 
Posts: 1
Joined: Fri Feb 26, 2016 8:08 pm

Re: [Issue] Keyboard volume keys do not work when OOo is ope

Postby Jethrain » Fri Mar 04, 2016 5:08 pm

Interestingly, after all this time, it seems as though the program *is* capturing those keystrokes...
In Impress, if the full screen preview is open, Next Track and Previous Track correspond to next/previous slide, and Play/Pause hides or shows the slides.

...Not that it makes it any less annoying that this is a bug that's been present for nigh-on ten years now, if not longer (there's no good reason for the program to take over global shortcuts, especially in contexts where they're not used for anything meaningful) -- but interesting that *something's* done with it.
OpenOffice 4.1.0 on Win7
Jethrain
 
Posts: 2
Joined: Fri Mar 04, 2016 5:01 pm

Re: [Issue] Keyboard volume keys do not work when OOo is ope

Postby RoryOF » Fri Mar 04, 2016 9:02 pm

Using HP SK2501 keyboard on Xubuntu 15.10 (non HP desktop Motherboard) the keyboard volume keys work.
Apache OpenOffice 4.1.9 on Xubuntu 20.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 32364
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Issue] Keyboard volume keys do not work when OOo is ope

Postby Jethrain » Sat Mar 05, 2016 1:01 am

Yeah, now that I think about it, the Ubuntu version of Libreoffice is unaffected by this (I dual boot and on the Linux partition it works as expected) - but every version of Windows I've used since XP has had this issue. I think the two different operating systems handle their media key inputs in slightly different ways.
OpenOffice 4.1.0 on Win7
Jethrain
 
Posts: 2
Joined: Fri Mar 04, 2016 5:01 pm

Re: Keyboard volume keys do not work when OOo is open

Postby grumpywarlock88 » Thu Dec 17, 2020 6:54 am

RoryOF wrote:I, on the other hand, prefer to devote my little brain power to actually writing and see no need for volume keys in OpenOffice. If I had to listen to music while writing, I'd put a CD on the ghetto blaster. I admit I'm old fashioned - I see the computer as a tool (an invaluable tool), not as an entertainment machine. But a Happy Christmas anyway!


RoryOF, it is something of amusement and irritation to read your comments and replies. I just had to give my two cents. First off, the others are right. Your opinion has zero relevance to the issue at hand. You can talk all you want about how you've built and fixed computers, and worked with them for 35 years. It seems like you've missed what computers are actually designed for. Computer companies have always strived to cater to a large variety of needs. Businesses are a large one, sure. Entertainment is a huge one all around. Computers built for gaming, for creative arts using design software, video editing, the list goes on. Now obviously what computer you have can also tell you its limits. Videos and music are minor resource hogs for just about every standard computer build. Your opinions here are flawed and yes, it would seem as if you were still stuck in the 90's. Most file corruptions happen as a result of errors or crashes in the programs, which may or may not have been from overloading, or faults within the program itself. I've lost very little in terms of corrupted files. And when I have, I know exactly, or within a small range of what caused it. Just about every time, it was related to an issue from the program itself. Anything from a file being exported or rendered wrong, errors in the program code that cause malfunctions and even crashing, or even an overload in the system which freezes everything or crashes the computer. There is a difference between writing and listening to music, verses rendering a video project while writing, watching a video, and browsing the internet. I'm not a well experienced, advanced tech guy, but I still know plenty enough to get to, or narrow down, the root of the problem and see how I can fix it. It's amusing reading you state your opinion that computers are only tools, and that people's issues are from using the computer for things that you think a computer wasn't meant for. I would have expected better of you. You sure are entitled to your opinion, just as I am. Though it would be wise to not carelessly throw it where it has no place.

Lastly, and I wanted to add this, music is something that has been of great benefit to writers such as myself. It helps us focus, even help set a mood for our content. For some of us, it is essential for our focus. Us running music in the background actually has very little impact on our system. For someone who'd have seen the progression of computers over the years, you should be well aware of this. Games are high impact. Design software is high impact. Always has, always will be. And unless you are a business needing to run only specific office programs, your computer will highly likely be built for your basic entertainment and productivity need, the default of your standard prebuilt computers. I've never in my life heard of someone who has corrupted files, or overloaded their computer, while writing an essay and listening to music or videos from a properly functioning computer, software and all.
OpenOffice 4.1.8 on Win10
grumpywarlock88
 
Posts: 2
Joined: Thu Dec 17, 2020 5:40 am

Re: [Issue] Keyboard volume keys do not work when OOo is ope

Postby RoryOF » Thu Dec 17, 2020 1:08 pm

You are, of course, entitled to your opinion, as I am to mine, so I have approved your post.

For others: note that the quote is from a posting in a thread of 2009.
Apache OpenOffice 4.1.9 on Xubuntu 20.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 32364
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Issue] Keyboard volume keys do not work when OOo is ope

Postby grumpywarlock88 » Thu Dec 17, 2020 1:33 pm

RoryOF wrote:You are, of course, entitled to your opinion, as I am to mine, so I have approved your post.

For others: note that the quote is from a posting in a thread of 2009.


I suppose I did overlook the fact that you are a moderator. Can't help but wonder why, based on your attitude on this topic. Of course I haven't seen any other posts you've made. Opinion or not, you still haven't taken anything I've said seriously. Now I came here looking for a solution to the same problem being discussed (back in 2009, still an issue in 2020). I think it's fairly ignorant to offer no help on the matter, instead chose to criticize others for wanting help. I would expect you as a moderator to actually offer some sort of help on the subject if you are going to post, not give counter productive opinions that disregard and put down the actual problem here.
OpenOffice 4.1.8 on Win10
grumpywarlock88
 
Posts: 2
Joined: Thu Dec 17, 2020 5:40 am

Re: [Issue] Keyboard volume keys do not work when OOo is ope

Postby robleyd » Thu Dec 17, 2020 1:45 pm

The problem has apparently been reported as a bug - https://bz.apache.org/ooo/show_bug.cgi?id=99520 - but it would appear the priority given to resolving it may not be as some hope.

As this is a forum supported for users, by users, we unfortunately aren't able to assist with unresolved bugs, other than to suggest that you add your vote on the bug report. However, given the time the bug has remained un-resolved, your next option might be to try LibreOffice and see if that works as you expect.
Cheers
David
Apache OpenOffice 420m2(Build:9821) - Slackware 14.2 - 64 bit
LibreOffice 6.4.6.2 (SlackBuild for 6.4.6 by Eric Hameleers) - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
robleyd
Moderator
 
Posts: 3843
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: [Issue] Keyboard volume keys do not work when OOo is ope

Postby RoryOF » Thu Dec 17, 2020 2:09 pm

I did actually say in course of the thread
Using HP SK2501 keyboard on Xubuntu 15.10 (non HP desktop Motherboard) the keyboard volume keys work


and I can also say that a Compaq SK2700 keyboard has keys that control speaker volume within OpenOffice, running on Xubuntu 20.04.1. These are practical workarounds .
Apache OpenOffice 4.1.9 on Xubuntu 20.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 32364
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland


Return to Install, Setup and Troubleshooting

Who is online

Users browsing this forum: No registered users and 9 guests