[Solved] Date format in reports changes when generated

Getting your data onto paper - or the web - Discussing the reports features of Base

[Solved] Date format in reports changes when generated

Postby dargosch » Wed Sep 03, 2008 4:22 pm

Hi,

I have a query which fetches a couple of columns containing date in ISO 8601 standard notation (YYYY-MM-DD). Also, I need to have some indication as to when the report is extracted, so I put a dynamic date field in the report footer.

Ok, everything looks fine in the editing mode. But, when I generate the report, all the dates are in DD/MM/YY format. Howcome????
And, more importantly.. how do I make my report layout editing "stick"?

/Fredrik
Last edited by dargosch on Thu Sep 04, 2008 10:55 am, edited 1 time in total.
--
"Life is like a trumpet - if you don't put anything into it, you don't get anything out of it."
OOo 3.0.X on Mac OSx Leopard
User avatar
dargosch
 
Posts: 48
Joined: Wed Jun 11, 2008 1:28 pm

Re: Date format in reports.. Why does it change when generated?

Postby dargosch » Thu Sep 04, 2008 10:54 am

Hi,

I solved it myself. The locale settings was wrong, so no matter how much I changed the date format specification, the locale seemed to be taking over. Changing the locale made it all very beautiful. :-)
--
"Life is like a trumpet - if you don't put anything into it, you don't get anything out of it."
OOo 3.0.X on Mac OSx Leopard
User avatar
dargosch
 
Posts: 48
Joined: Wed Jun 11, 2008 1:28 pm


Return to Reporting

Who is online

Users browsing this forum: No registered users and 1 guest