[Solved] Format negative numbers

Getting your data onto paper - or the web - Discussing the reports features of Base

[Solved] Format negative numbers

Postby hausmeister » Tue Sep 30, 2008 9:58 am

Hello,
I have a problem to format numbers in the report which can be negative or positiv.
If I select the buttom for negative numbers are red. Then all numbers in the field get the minus sign in front and the numbers are black if they are before positiv. The negative get a double minus sign and are red.
I use the Openoffice version 3.0 with the OS Windows XP and Windows Vista home .
The sunreportbuilder is installed.

:(
Best regards
Bernd

New Version of SRB ( 1.0.5) installed
but with Openoffice Version3.o RC3 it don't work only with the Beta2 relase
Last edited by hausmeister on Sat Oct 04, 2008 2:49 pm, edited 2 times in total.
OOo 3.0.X on MS Windows Vista + MS Windows XP
hausmeister
 
Posts: 1
Joined: Tue Sep 30, 2008 9:37 am

Re: Format negative numbers

Postby Villeroy » Tue Sep 30, 2008 5:55 pm

I do not use v3 nor SRB which appears to me as the crudest banana-ware ever. But as far as I understand, the report is an ordinary Writer document with formatted fields and/or form controls. Get a copy of your report. In 2.4 I can drag the report a little bit aside and get prompted for the name of the copied object.
You can edit the report in edit mode, call the "Form Navigator" by the 5th button of toolbar "Design Mode", then browse the offending numeric fields and apply adequate formatting manually. In case of Writer fields rather than form fields, you should be able to set their properties in the Writer's fields dialog [Ctrl+F2].
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 27899
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany


Return to Reporting

Who is online

Users browsing this forum: MSN [Bot] and 1 guest