Page 1 of 1

[Solved] Invalid Cursor State

PostPosted: Tue Feb 07, 2017 6:52 pm
by jkloth
I'm using OpenOffice to connect to and maintain several MySQL databases using ODBC and system DSNs. This has always worked flawlessly, but recently I discovered I was unable to open certain tables within certain databases. When I try to open these tables I get an error message stating "Data could not be loaded. Invalid cursor state."

I tried to re-create the DSNs but that didn't do anything. I had been on an older version of OpenOffice and so I upgraded to the latest, which allowed me to get into the tables I couldn't before. Unfortunately, now I cannot get into a number of different tables (and more than before; the first time it was only 4 tables, now there's nearly a dozen). It also broke tables in databases that previously hadn't been experiencing any issues at all. Same error message as before.

The weird thing is, I can open the tables in design view and I can run queries against those tables, but I cannot open them to view the data. Also strange, is that my boss, who is still using the older version of OpenOffice that I had been using, can access the tables just fine. The only difference is that he's still on XP (he's stubborn that way :) ).

Anyone have any ideas what might be going on?

Re: Invalid Cursor State

PostPosted: Wed Feb 08, 2017 6:30 pm
by jkloth
Solved it. The MySQL driver version for the DSN was outdated. Updated to a newer version and now everything seems to be working again.