Page 1 of 1

[Solved] OpenOffice 4.1.1 Base fails to start w/ HSQL 2.3.4

PostPosted: Thu Jul 28, 2016 5:24 am
by misitu
"as it says on the label"
I have a mature database where OOO4.1.1 will start with drivers from 2.3.0 up to 2.3.3 inclusive.
Changing the driver to 2.3.4
Code: Select all   Expand viewCollapse view
C:\Users\Accounts\Desktop\Bookkeeping\UPGRADES>java -Xmx1800m -classpath driver\
hsqldb.jar org.hsqldb.server.Server
[Server@4517d9a3]: [Thread[main,5,main]]: checkRunning(false) entered
[Server@4517d9a3]: [Thread[main,5,main]]: checkRunning(false) exited
[Server@4517d9a3]: Startup sequence initiated from main() method
[Server@4517d9a3]: Loaded properties from [C:\Users\Accounts\Desktop\Bookkeeping
[Server@4517d9a3]: Initiating startup sequence...
[Server@4517d9a3]: Server socket opened successfully in 9 ms.
[Server@4517d9a3]: Database [index=0, id=0, db=file:database/ACCOUNT_BOOKS, alia
s=upgrades] opened successfully in 1704 ms.
[Server@4517d9a3]: Startup sequence completed in 1714 ms.
[Server@4517d9a3]: 2016-07-27 22:08:31.322 HSQLDB server 2.3.4 is online on port
[Server@4517d9a3]: To close normally, connect and execute SHUTDOWN SQL

leaves me hanging with the message
Code: Select all   Expand viewCollapse view
org.hsqldb.HsqlException: Client driver version greater than '' is requir
ed.  HSQLDB server version is '2.3.4'
        at org.hsqldb.error.Error.error(Unknown Source)
        at org.hsqldb.server.ServerConnection.init(Unknown Source)
        at Source)
        at Source)

I haven't a clue why it thinks the driver is less than, since drivers other than 2.3.4 work flawlessly.

I could post this on but other clients (sqltool, databasemanagerSwing, and sqlworkbench/J) connect fine. So I think it's an OOO problem.

I've tried playing with the OOO settings but don't have much of a clue as to what else might be useful here.

It's a client server setup. The server. bat and file are as follows

Code: Select all   Expand viewCollapse view
cd C:\Users\Accounts\Desktop\Bookkeeping\TEST\
java -Xmx1800m -classpath driver\hsqldb.jar org.hsqldb.server.Server

server.port 9003

My system is quite mature and I don't want to risk breaking it by going to 4.1.2 unless 4.1.2 is definitely a cure for this issue.

Re: OpenOffice 4.1.1 BASE fails to start with HSQL 2.3.4

PostPosted: Thu Jul 28, 2016 7:46 am
by Villeroy
Upgrade the hsqldb.jars on the client and server sides.

Re: OpenOffice 4.1.1 BASE fails to start with HSQL 2.3.4

PostPosted: Thu Jul 28, 2016 9:00 pm
by misitu

The server side hsqldb.jar is at 2.3.4
The sqlworkbench/J and databaseManagerSwing hsqldb.jar are both at 2.3.4

I don't have a clue as to how to tell the OpenOffice frontend to use 2.3.4 which I believe is in the right directory. Er, from the above evidence.

I might be wrong!!

Do you have some pointers to help me in debugging this issue?

OTOH, could it be OOO 4.1.1 that is the problem?


Re: OpenOffice 4.1.1 BASE fails to start with HSQL 2.3.4

PostPosted: Thu Jul 28, 2016 9:14 pm
by Sliderule
I suspect, that, with the result JAVA update, that probably was downloaded to your computer, you may not have told OpenOffice to use the new JAVA version. Since, the old JAVA version ( directory may have been deleted, you have to manually check it, that is, with the new directory ( probably in a directory like: C:\Program Files (x86)\Java\... ).

From the OpenOffice Menu, before opening your Base file ( *.odb ): Tools -> Options... -> OpenOffice -> Java

Confirm, both:
  1. Use a Java runtime environment has a check mark on the left
  2. The installed JAVA version is a 32 bit version , and, it is selected ( contains the black mark on the left )
For further information about installing the Java Version, see the Wiki link below:

Troubleshooting Open/LibreOffice and Java


Thanks to add [Solved] in your 1st post Subject (edit button top right) if this issue has been resolved.

Re: OpenOffice 4.1.1 BASE fails to start with HSQL 2.3.4

PostPosted: Thu Jul 28, 2016 10:19 pm
by misitu
Hi, Sliderule.
Use a Java runtime environment does have its tick box ticked.
The installed Java is a 32 bit version* and is selected.
* Location: C:\Program Files (x86)\Java\jre1.8.0_60 is the 32 bit program file area.

I don't think it is this BECAUSE I have the other 2 open office instances running perfectly well. I have 3 instances, LIVE TEST and UPGRADES. I use the last for testing the upgrade of hsqldb. If I use the 2.3.0, 2.3.2, and 2.3.3 drivers then OOO base works fine. When I change the UPGRADE instance drivers to 2.3.4 then the message in the OP is generated and no connection is created.

There is something funny in OOO 4.1.1 that the hsqldb 2.3.4 driver cannot recognise.

But thanks anyway.

I will probably try this on my spare machine. And any other tricks I can think of :( . But in the meantime anyone who might know how to tell OOO to read the 2.3.4 drivers is welcome to tell me how to do this. It is very frustrating.

If I can advance no other way, I will have to download 4.1.2 and create a separate instance of OOO just to see if it kills this misdemeanour

Re: OpenOffice 4.1.1 BASE fails to start with HSQL 2.3.4

PostPosted: Fri Sep 09, 2016 12:44 am
by misitu

I created a separate instance of the folders, server, clients, etc., in order to verify performance with HSQL 2.3.4 and this also cleaned up my mental map.

All is working fine and I can upgrade and test the upgrades away from the live system.

For the avoidance of doubt, I now have 3 instances of the database including AOO, sqltool (databaseManagerSwing), and sqlWorkbench/J in LIVE, TEST, and UPGRADES.
UPGRADES is to be able to review changes to foundation software and TEST is to be able to make and verify changes to a copy of the production data.

Cheers, best regards

Please see also ... 82#p395882