[Issue] SQL Fetch Next

dBase, Calc, CSV, MS ACCESS, MySQL, PostgrSQL, OTHER

[Issue] SQL Fetch Next

Postby RAJ » Tue Dec 21, 2010 10:27 pm

Hello,
I have been using openoffice for some while now and am slowly converting a lot of people over to it, so much better than... well you know.
I have downloaded 3.3 to my laptop to test it out at home and work, and have met a strange problem I cannot see mentioned here yet.
At work I connect to an xfodbc database and it works perfectly with 3.2 but with 3.3 it finds the database fine and lists all the tables but when I click on a table I get the error..
SQL Status:HY106
Error Code: -1

[TOD][ODBC Driver]UNFETTYP Unknown fetch type

I have checked with the xfODBC help and it informs me..
(xfodbc) currently only SQL_FETCH_NEXT is supported, modify your program to use only SQL_FETCH_NEXT.

Presumedly 3.2 used this, as it works, can 3.3 also do this, perhaps its just a blip in the coding, or is there an alteration adjustment to enable this.

I hope this is the place to ask this question and apologise if its not, perhaps I could be pointed in the right direction with this question.
Very Many Thanks
Roger
Last edited by Hagar Delest on Sun Nov 27, 2011 11:09 pm, edited 5 times in total.
Reason: tagged [Issue] (link to a bug report).
RAJames
ooo 3.2 and 3.3 windows xp and vista
RAJ
 
Posts: 7
Joined: Tue Dec 21, 2010 10:05 pm

Re: SQL Fetch Next

Postby Villeroy » Tue Dec 21, 2010 10:56 pm

Can you find some option under menu:Edit>Database? If not, there may be some connection parameter you can add to the connection string <free pseudo string>"odbc:xfODBC:MyDatabase?fetch=sql_fetch_next&charset=UTF8"</free pseudo string>. Valid options should be documented by the vendor of the driver.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 27731
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: SQL Fetch Next

Postby RAJ » Sun Jan 23, 2011 9:37 pm

Hello,
Many thanks for reply, but not quite sure if I explained the problem correctly.
We have a unix business system at work which windows can connect to with an xfodbc driver supplied by the system vendors, I have set all this up with data management and connection through windows and it works perfectly well with ooo 3.2 so really no problem there. But with the 3.3 (10) I have installed on my laptop it will connect okay to the database
and when I click on the tables icon it shows all the tables correctly, but when I then click on one of the tables to view it, I get the errors mentioned in my first post, If it is something I can ammend, how and where do I do it?
As I say it works okay in 3.2 so no real problem, but the main Parts database on the work database has well over the 64000 lines that is the sheet limit on 3.2 and as I have to download it to a spreadsheet to then create a portable DBF Base to enable our "on the road" people to have a copy of it saved to their laptops, the larger spreadsheet limit on 3.3 is ideal for this purpose.

Once again very many thanks for your help
Roger
RAJames
ooo 3.2 and 3.3 windows xp and vista
RAJ
 
Posts: 7
Joined: Tue Dec 21, 2010 10:05 pm

Re: SQL Fetch Next

Postby r4zoli » Sun Jan 23, 2011 9:52 pm

Nearly similar problem with ODBC and Firebird DBMS, at least the same error code, and similarly works in OOo 3.2 and Gives HY016 Fetch type out of range, with OOo 3.3.
See http://qa.openoffice.org/issues/show_bug.cgi?id=116523
AOO 4.0 and LibO 4 on Win 8
Hungarian forum co-admin
User avatar
r4zoli
Volunteer
 
Posts: 2882
Joined: Mon Nov 19, 2007 8:23 pm
Location: Budapest, Hungary

Re: SQL Fetch Next

Postby RAJ » Wed Feb 23, 2011 9:10 am

Hi Again,
I am still having this problem, I have the latest ooo 3.3 and the latest java.
Fetches perfectly in ooo 3.2 and Microsoft Access, but 3.3 gives this error, I have fully uninstalled ooo3.3 and reinstalled latest version. I am sure there is an easy solution to this problem, but I cant work it out !!

Roger
RAJames
ooo 3.2 and 3.3 windows xp and vista
RAJ
 
Posts: 7
Joined: Tue Dec 21, 2010 10:05 pm

Re: SQL Fetch Next

Postby r4zoli » Wed Feb 23, 2011 11:07 am

It is a bug in OOo 3.3 with fetch with ODBC, as you can see from issue, and will be solved in OOo 3.4.
Until use older version, which has other bugs, or use OOo 3.3 with other connection type, such as JDBC.
AOO 4.0 and LibO 4 on Win 8
Hungarian forum co-admin
User avatar
r4zoli
Volunteer
 
Posts: 2882
Joined: Mon Nov 19, 2007 8:23 pm
Location: Budapest, Hungary

Re: SQL Fetch Next

Postby RAJ » Wed Feb 23, 2011 2:10 pm

Very many thanks for your fast reply, I shall await 3.4, which hopefully wont be to long away.

Roger
RAJames
ooo 3.2 and 3.3 windows xp and vista
RAJ
 
Posts: 7
Joined: Tue Dec 21, 2010 10:05 pm

Re: SQL Fetch Next

Postby RAJ » Sun Nov 27, 2011 2:40 pm

Hello Again,
I have now downloaded libreoffice 3.4 but the problem is still there, exactly the same message, is it still being fixed, I am quite happy to wait if this is so.

Roger
RAJames
ooo 3.2 and 3.3 windows xp and vista
RAJ
 
Posts: 7
Joined: Tue Dec 21, 2010 10:05 pm

Re: SQL Fetch Next

Postby r4zoli » Sun Nov 27, 2011 3:49 pm

If your problem not fixed in LibO 3.4 it is worth to submit a bug.
AOO 4.0 and LibO 4 on Win 8
Hungarian forum co-admin
User avatar
r4zoli
Volunteer
 
Posts: 2882
Joined: Mon Nov 19, 2007 8:23 pm
Location: Budapest, Hungary

Re: [Issue] SQL Fetch Next

Postby smw-p » Mon Feb 13, 2012 11:50 pm

Error-Message after try to open table content (data)

Hello, I have The same problem changing OOBase 3.2 to 3.3 (or 3.4). The problem exist in LibreOffice V3.3/3.4 too.

We test it on a WIN-XP System (SP3) togehter with ODBC-Driver Acu-XDBC 8.1.3 from MicroFocus (Database = Vision4).

Because our database works very well in connection with the other reference application MS-Access 2003/2007/2010 or with OOBase 3.2 too (or earlier), I am
quit shure, that the problem is generated by OOBase 3.3 and 3.4 themselves.

Effects: After connecting the Database using the ODBC driver the tables list is shown correctly (see tables list).
But klicking on the table symbol, I get - instead of the data of this table - an error message:
-> "data could not be loaded, [TOD][ODBC Driver]UNFETTYP] unknown fetch type"

I have tested a lot of various possibilities, but without success. I think it's a bug and should resolved urgend!

Answers? Many thanks! ->> How can I submit this bug to the developers board?

Peter
Attachments
Tables-List.jpg
Table List is shown correctly
Table-Error.jpg
Error message HY106, OOBase 3.3 / 3.4
Open Office 3.2 / 3.3 / 3.4
Windows XP SP3
smw-p
 
Posts: 1
Joined: Mon Feb 13, 2012 7:03 pm

Re: [Issue] SQL Fetch Next

Postby r4zoli » Tue Feb 14, 2012 9:06 am

smw-p wrote:->> How can I submit this bug to the developers board?Peter

You find the way, when added your comments to 118014 bug.
AOO 4.0 and LibO 4 on Win 8
Hungarian forum co-admin
User avatar
r4zoli
Volunteer
 
Posts: 2882
Joined: Mon Nov 19, 2007 8:23 pm
Location: Budapest, Hungary


Return to External Data Sources

Who is online

Users browsing this forum: No registered users and 1 guest