Page 1 of 1

Can't get Sqlite3 driver

PostPosted: Mon Nov 25, 2019 9:09 pm
by pizzipie
Following is the site used, commands issued, and results in my failed attempt to get the ODBC driver for Sqlite3 for use in LibreOffice Base. I don't have a clue as to where to go to fix this. I looked all over for other sites to download the driver but all trails led to this one.

Thanks in advance for any help,

R

SITE: https://thejeshgn.com/2018/08/23/using- ... l-UnixODBC

COMMAND: ./configure && make ( as per instructions in SITE)
rick@rick-Latitude-E6510:~/Desktop/sqlite-driver/sqliteodbc-0.9996$ ./configure && make

RESULT:
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
.
.
.
checking for sqlite3_table_column_metadata in -lsqlite3... no
checking for sqlite3_profile in -lsqlite3... no
checking for sqlite3_strnicmp in -lsqlite3... no
checking for sqlite3_close_v2 in -lsqlite3... no
checking for SQLite4 header and library... no
configure: WARNING: SQLite4 header file and source not found
configure: error: No usable SQLite header/library on this system
rick@rick-Latitude-E6510:~/Desktop/sqlite-driver/sqliteodbc-0.9996$

COMMAND: make install ( as per instructions in SITE)
rick@rick-Latitude-E6510:~/Desktop/sqlite-driver/sqliteodbc-0.9996$ make install

RESULT:
make: *** No rule to make target 'install'. Stop.
rick@rick-Latitude-E6510:~/Desktop/sqlite-driver/sqliteodbc-0.9996$

Re: Can't get Sqlite3 driver

PostPosted: Tue Nov 26, 2019 7:24 am
by robleyd
Did you also install the development files as mentioned in the link?

Your problem is not really within the scope of this forum.

Re: Can't get Sqlite3 driver

PostPosted: Wed Nov 27, 2019 8:34 am
by pizzipie
Thanks for the reply. Yes, I did this: sudo apt-get install sqlite3 libsqlite3-dev. before the above.
Your problem is not really within the scope of this forum.

Where should it be?

Re: Can't get Sqlite3 driver

PostPosted: Wed Nov 27, 2019 9:04 am
by Hagar Delest
This is more a system issue first.
Once it is fixed, then you'll be able to get it to work with AOO/LO.

Try the Ubuntu forum. Do you still use 14.04? Sounds rather outdated now.

Re: Can't get Sqlite3 driver

PostPosted: Wed Nov 27, 2019 5:38 pm
by pizzipie
Thanks,
I'll try Ubuntu Forum.

I now use as below.