[Solved] Hyperlink font issue in ToC

Writing a book, Automating Document Production - Discuss your special needs here

[Solved] Hyperlink font issue in ToC

Postby LadyThorne » Sat Jan 25, 2020 3:50 am

I have my TOC set up, running fine, finally got the links to work allowing me to click on the TOC chapter and link straight to the chapter, got the TOC generating 95% correctly. The problem is that I need the links to be in TImes New Roman and they're generating in Courier which looks odd cause everything else is TNR. I've gone into the TOC and everything SAYS it should print TNR, but it still insists on Courier. Is there anything I can do (or some small tidbit I've overlooked) short of manually changing the font of the TOC chapter heading by chapter heading after the document is complete?
Last edited by LadyThorne on Sat Jan 25, 2020 8:28 pm, edited 1 time in total.
Open Office 4.1.4 on Windows 10 pro
LadyThorne
 
Posts: 19
Joined: Sun Sep 16, 2012 4:15 pm

Re: Hyperlink font issue

Postby RoryOF » Sat Jan 25, 2020 8:20 am

The Heading styles which specify the entries for the ToC in the text are substituted by other styles, usually Content 1 ... 10 in the ToC. Right click on ToC, Choose Edit and look at the Styles tab; you will there see which Paragraph styles to edit - probably Content 1 and Content 2. Note what you have done so you can undo it if it doesn''t suit.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.4 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 30374
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Hyperlink font issue

Postby LadyThorne » Sat Jan 25, 2020 9:44 am

as you can see in the picture, I have. That's the problem. You can see the TOC in the background using Courier, level 1 uses contents 1, and contents 1 is set up to use Times New Roman 12, yet the TOC still generates as Courier New 12.
Open Office 4.1.4 on Windows 10 pro
LadyThorne
 
Posts: 19
Joined: Sun Sep 16, 2012 4:15 pm

Re: Hyperlink font issue

Postby Zizi64 » Sat Jan 25, 2020 11:30 am

as you can see in the picture, I have.


I can not see any pictures in your posts.

Note: the file size limit is 128 KiB in this forum. You must optipmize (crop t and decrease the color depth and/or the resolution) the pictures before you UPLOAD them here.
Use the "Upload attachment" TAB of this forum. The Copy/Paste or dragging the picture will not work on this Forum.
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.0; AOO4.1.6
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 8757
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Hyperlink font issue

Postby Bill » Sat Jan 25, 2020 11:49 am

Change the font setting in the Internet Link character style from Courier New to Times New Roman.
AOO 4.1.7 and LO 6.3.2.2 on Manjaro KDE
Bill
Volunteer
 
Posts: 7573
Joined: Sat Nov 24, 2007 6:48 am

Re: Hyperlink font issue

Postby LadyThorne » Sat Jan 25, 2020 6:17 pm

and where would I find that? How do I get to it? I've tried googling "How to change the font of hyperlinks" but that only gets me information on changing the color.
Last edited by LadyThorne on Sat Jan 25, 2020 8:22 pm, edited 1 time in total.
Open Office 4.1.4 on Windows 10 pro
LadyThorne
 
Posts: 19
Joined: Sun Sep 16, 2012 4:15 pm

Re: Hyperlink font issue

Postby Zizi64 » Sat Jan 25, 2020 6:24 pm

and where would I find that? How do I get to it?


The styles are available on the Style and Formatting menu item (or on the Sidebar). Choose the relevant style type:
Paragraph Style, Character Style, Page Style...etc...
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.0; AOO4.1.6
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 8757
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Hyperlink font issue

Postby Villeroy » Sat Jan 25, 2020 6:33 pm

There is one predefined character style "Internet Links" for hyperlinks. Right-click>Edit... and all hyperlinks in this document will get your changes. Using styles is the fundamental concept of this office suite.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 27709
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Hyperlink font issue

Postby Bill » Sat Jan 25, 2020 6:57 pm

LadyThorne wrote:and where would I find that? How do I get to it?

In OpenOffice Writer press F11 to open the Styles and Formatting window. Click the second icon (Character Styles) at the top of the window. Right-click "Internet Links" and select "Modify".
AOO 4.1.7 and LO 6.3.2.2 on Manjaro KDE
Bill
Volunteer
 
Posts: 7573
Joined: Sat Nov 24, 2007 6:48 am

Re: Hyperlink font issue

Postby LadyThorne » Sat Jan 25, 2020 8:26 pm

Villeroy wrote:There is one predefined character style "Internet Links" for hyperlinks. Right-click>Edit... and all hyperlinks in this document will get your changes. Using styles is the fundamental concept of this office suite.


Yes, and unfortunately there are a number of ways to change anything and if you don't catch them ALL it's like you did nothing. That is the flaw of this office suite. there is no need to get snarky just because I overlooked the ONE thing that would fix this when I went through the obvious options first. I searched for my question, all that would pop was how to change the COLOR not the FONT, so it's a failing of the help system not the user.
Open Office 4.1.4 on Windows 10 pro
LadyThorne
 
Posts: 19
Joined: Sun Sep 16, 2012 4:15 pm

Re: Hyperlink font issue [Solved]

Postby RoryOF » Sat Jan 25, 2020 8:36 pm

I have just tested on an existing hyperlinked ToC; I changed Content 1 font using Edit button on Right click : Edit Index/Table and it immediately changed the edited ToC lines to the new font, in selected size and style.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.4 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 30374
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Hyperlink font issue [Solved]

Postby LadyThorne » Sat Jan 25, 2020 8:49 pm

RoryOF wrote:I have just tested on an existing hyperlinked ToC; I changed Content 1 font using Edit button on Right click : Edit Index/Table and it immediately changed the edited ToC lines to the new font, in selected size and style.

Great, it worked for you. It should have worked for me. My image proves that's what I did and still didn't work. I had to change the internet style in formating and styles to get it to work. Which I finally did.
Open Office 4.1.4 on Windows 10 pro
LadyThorne
 
Posts: 19
Joined: Sun Sep 16, 2012 4:15 pm

Re: Hyperlink font issue [Solved]

Postby Bill » Sat Jan 25, 2020 9:53 pm

LadyThorne wrote:
RoryOF wrote:I have just tested on an existing hyperlinked ToC; I changed Content 1 font using Edit button on Right click : Edit Index/Table and it immediately changed the edited ToC lines to the new font, in selected size and style.

Great, it worked for you. It should have worked for me. My image proves that's what I did and still didn't work. I had to change the internet style in formating and styles to get it to work. Which I finally did.

It didn't work for you because the Internet Link character style in your sample document has been modified to apply the Courier New font. The Courier New setting overrides the setting in the paragraph style. It worked for RoryOF because the default Internet Link character style does not have a font setting that will override the font setting in the paragraph style.
AOO 4.1.7 and LO 6.3.2.2 on Manjaro KDE
Bill
Volunteer
 
Posts: 7573
Joined: Sat Nov 24, 2007 6:48 am

Re: [Solved] Hyperlink font issue in ToC

Postby Bill » Sun Jan 26, 2020 12:47 am

There's something strange about the Internet Link character style in the sample document. The Font tab on the character style dialog shows "Courier New" as the font. Clicking the "Standard" button on the Font tab should revert all settings on the Font tab to the default settings and change the font displayed to the document's default font but it doesn't . "Courier New" should be shown on the Organizer tab under "Contains" but it isn't. This is an indication that "Courier New" has somehow become the default font setting for the Internet Link character style. How this has happened and how to correct it is unknown to me. No specific font has become the default font for the Internet Link character style on any other document I have tested.

Edit: I've found the source of the Courier New font setting and the strange behavior of the Internet Link character style in the sample document. The Internet Link character style in the sample document is linked with another character style "Source Text" which contains the Courier New setting. In new documents, the Internet Link character style is linked with "None". Changing the "Linked with" setting in the sample document from "Source Text" to "None" does fix the problem in AOO.
AOO 4.1.7 and LO 6.3.2.2 on Manjaro KDE
Bill
Volunteer
 
Posts: 7573
Joined: Sat Nov 24, 2007 6:48 am


Return to Advanced Uses

Who is online

Users browsing this forum: No registered users and 1 guest