[Solved] Template not working for Win 7 right click>new

Using them, Making them , Finding them

[Solved] Template not working for Win 7 right click>new

Postby bluepicture » Wed May 26, 2010 4:10 am

Hello,

I made a new default template using this method as outlined in the help guide:

"First, open either an existing OpenOffice.org template and modify it, or open a new document and edit it as necessary to create the desired template.
You can define a document template for each OpenOffice.org module. The following describes how to proceed for text documents.
1.Save the document by choosing File - Templates - Save and saving the document in the My Templates category.
2.Choose File - Templates - Organise.
3.Double-click My Templates in the list on the left. You will see the user-defined templates in the user directory specified under Tools - Options - OpenOffice.org - Paths. Select the template you have just saved and open the context menu or open the sub-menu of the Commands button.
4.Choose Set As Default Template. The next time you open a new text document, the new document will be based on the new default template."

So now when I open OOW and go to File>New>Text Document, my new default template opens beautifully.

However, problem occurs when I right click>New>OpenDocument Text, my lovely new default template is does not appear. It makes me cry :cry: :cry: :cry: Instead, an ugly template takes its place. It is so ugly that I would like to kill it with fire.

I have found a work around for WinXP which is outlined here:

http://qa.openoffice.org/issues/show_bug.cgi?id=40233

tl;dr:

"The template used by the OS when choosing "New document" from the desktops
context menu is a static file. Though the wish to have this synchronized with the default template used inside
office is valid this is not really an important issue.

Workaround:

Replace the OS template

C:\Documents and Settings\username\Templates\soffice.odt with the one you
want to be used."

Unfortunately that doesn't work for win7 because there is no such folder as 'documents and settings' in win 7. There is a dummy one but only as backward compatibility for other programs that used the "My Documents" folder structure.

I know the equivalent of C:\Documents and Settings\username\My documents in XP is:

C:\Users\username\Documents

in vista.

BUT I tried to go to this folder in Win7 and I can find no such file as 'soffice.odt'.

Alls I can find is a folder called:

Logfile.odt

But changing the settings to this does NOT change the template which loads when I right click.

Halp please!
Last edited by bluepicture on Thu May 27, 2010 2:58 am, edited 1 time in total.
openoffice.org 3.2.0 on windows 7
bluepicture
 
Posts: 4
Joined: Mon May 10, 2010 2:23 am

Re: Default Template not working for Windows 7 right click>n

Postby RoryOF » Wed May 26, 2010 6:34 am

I cannot answer the detail of your query, as I have little experience with templates and none with Win 7, but templates should have extension .ott
Apache OpenOffice 4.1.7 on Xubuntu 18.04.4 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 30435
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Default Template not working for Windows 7 right click>n

Postby Hagar Delest » Wed May 26, 2010 12:37 pm

See bottom of that post (corner case 2).

Thanks to add '[Solved]' at beginning of your first post title (edit button) if your issue has been fixed.
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28681
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [solved] Template not working for Win 7 right click>new

Postby bluepicture » Thu May 27, 2010 2:59 am

perfect! thank you :)
openoffice.org 3.2.0 on windows 7
bluepicture
 
Posts: 4
Joined: Mon May 10, 2010 2:23 am


Return to Templates

Who is online

Users browsing this forum: No registered users and 1 guest