Template formatting only shows up on the first page

Using them, Making them , Finding them

Template formatting only shows up on the first page

Postby pleasehelp » Tue May 04, 2010 8:38 pm

I am using Open Office Writer version 3 on a Windows Vista OS. I read a lot about template creation from the Open Office Writer help menu, but I am stuck!
I am trying to create a template that numbers each line of the document (line numbers), has vertical lines on either side of the margins, and numbers each page. I got the first page to work, but when I get to page 2, the frame that I created with the line numbers and the vertical lines do not appear. The vertical lines used to appear on page 2 until I added page numbers. Now I cannot get those vertical lines or the line numbers frame to appear on page 2. I tried saving the document as a template, but it still has the same problem of lost formatting on page 2. I don't know how to tell the document to add the same elements (vertical lines and line numbers frame) from page 1 on each page.
In order to create the "template," I copied elements from a different template to create this one. On the other template, the line numbering and vertical lines do continue on each page. Unfortunately, that template also includes a header field that I cannot remove. I don't know where the other template came from because it was found somewhere by a friend of my client. So I am creating a new one without a header field, but somewhere in there I did not do something right.
I've gone to Format->Styles & Formatting, right clicked on the style and selected modify, then modified the "Paragraph style: Frame content," but I don't know what to change. There does not seem to be an option in that screen to allow me to continue the frame and lines on each page.
I'm sorry if I didn't explain this very well. My client prefers Open Office Writer over MS Word, but I am not familiar enough with Open Office to fully understand what the problem is with my "template".
Thanks.
Open Office version 3, windows vista OS
pleasehelp
 
Posts: 2
Joined: Tue May 04, 2010 8:04 pm

Re: Template formatting in writer only shows up on the first

Postby acknak » Tue May 04, 2010 8:44 pm

Writer has no way to designate content that should appear on every page, so you can insert the numbering frame on the first page, but it won't automatically appear on any other page; you'd have to copy/paste it to each new page.

The workaround for that is to make such items part of a header or footer, which does appear on new pages automatically. That's probably why the other template had the header, and you will need a header in your document if you want the numbering to appear on new pages. The header can be blank/invisible, but it has to be there to provide a place for the numbering frame.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Template formatting in writer only shows up on the first

Postby pleasehelp » Tue May 04, 2010 9:03 pm

acknak wrote:The workaround for that is to make such items part of a header or footer, which does appear on new pages automatically.

Can I make the line numbering and lines part of the page number footer? A header would ruin the top margins. If not I guess I'll just keep messing around with it.
Thanks.
Open Office version 3, windows vista OS
pleasehelp
 
Posts: 2
Joined: Tue May 04, 2010 8:04 pm

Re: Template formatting in writer only shows up on the first

Postby JohnV » Tue May 04, 2010 9:12 pm

A header would ruin the top margins.
Just decrease the top margin by the size of the header and gap to normal text.

BTW, when you do Insert > Frame make sure Follow Text Flow is not checked.
JohnV
Volunteer
 
Posts: 1585
Joined: Mon Oct 08, 2007 1:32 am
Location: Kentucky, USA


Return to Templates

Who is online

Users browsing this forum: No registered users and 3 guests