StoreAsURL overwrites (or documentation error)?

The Application Programming Interface and the OASIS Open Document Format

StoreAsURL overwrites (or documentation error)?

Postby ptoye » Wed Jan 23, 2013 5:36 pm

I'm using StoreAsURL to save a new document (generated from a template, so untitled). I use an empty array for the IArguments parameter, and according to the documentation in http://www.openoffice.org/api/docs/comm ... iptor.html the default for the Overwrite property is FALSE, implying that it should give an error if the document's already there. But it doesn't - it just overwrites.

Anyone else seen this? It doesn't seem to be in Bugzilla.
Peter
OO 4.1.1 on MS Windows 7 64-bit
ptoye
 
Posts: 225
Joined: Mon Apr 21, 2008 11:07 am
Location: Reading, England

Re: StoreAsURL overwrites (or documentation error)?

Postby Charlie Young » Wed Jan 23, 2013 5:56 pm

I see the same thing. It does give an error if "Overwrite" is explicitly set to False, so whether this is a bug in the API or just a bug in the documentation is unclear.
Apache OpenOffice 4.1.1
Windows XP
User avatar
Charlie Young
Volunteer
 
Posts: 1559
Joined: Fri May 14, 2010 1:07 am

Re: StoreAsURL overwrites (or documentation error)?

Postby ptoye » Wed Jan 23, 2013 8:06 pm

Thanks Charlie for the confirmation and extra research.

I'll post a bug.

[Later} Bug no 121665 submitted https://issues.apache.org/ooo/show_bug.cgi?id=121665. Some interesting discussion, which seems to have stalled, with OO.

[25 July 2013] Still nothing useful from the bug system. Presumably no-one's interested.
Peter
OO 4.1.1 on MS Windows 7 64-bit
ptoye
 
Posts: 225
Joined: Mon Apr 21, 2008 11:07 am
Location: Reading, England


Return to UNO API and ODF

Who is online

Users browsing this forum: No registered users and 3 guests