Page 1 of 1

[Solved] Getting started with NetBeans and the OOo SDK

PostPosted: Thu Jan 06, 2011 12:19 am
by Tim Grantham
I've installed NetBeans 6.8, OpenOffice 3.2, and the OpenOffice SDK 3.2.1.

I'm able to create a new OO SDK client application project. But the first time I build and run it in the IDE, it says it's running, but I have to manually kill it. On all subsequent runs, it appears to run briefly and then exits. At no time does it report an error. Adding the code from the OO SDK developer guide tutorials results in no change in behavior at all. Running the app from a command line in the dist directory fails with class not found exceptions.

The sample projects provided with NetBeans build and run just fine.

So anyone got any ideas?

Thanks,
Tim.

Re: Getting started with NetBeans and the OO SDK

PostPosted: Thu Jan 06, 2011 12:21 am
by Tim Grantham
I should add that I'm using the NetBeans OpenOffice API 2.0.6 plug-in.

Re: Getting started with NetBeans and the OOo SDK

PostPosted: Fri Jan 07, 2011 2:17 am
by Tim Grantham
Solved ... no thanks to Sun/Oracle, which, due to its lack of specific information, caused me to waste most of two days trying to get it to work.

What Sun/Oracle doesn't tell anyone is that even though OpenOffice and the OpenOffice SDK are both available for 64-bit Linux, the Windows versions are 32-bit only. In addition, they don't tell you that, to create Windows OO apps with the SDK, you have to use the 32-bit version of the Java Development Kit, not the 64-bit version of the JDK.

Neither NetBeans IDE nor the JRE provided any error messages to indicate what the problem was. It was doubly confusing because the com.sun.star.lib.loader Loader class compiled and ran just fine with the 64-bit JDK; it was the app class that wouldn't run (thought it did compile without errors).

Now I suppose more experienced programmers might know all this, but why would Sun/Oracle want to annoy new programmers with this kind of carelessness? Don't they WANT to attract more developers?

:crazy:

Tim.