Page 1 of 1

[Solved] Can't Edit Document Macro Libraries or Modules

PostPosted: Fri Feb 19, 2021 7:29 pm
by cantorkenOO
I want to create a macro for a particular spreadsheet document. To learn how, I tried duplicating the example shown in AOO First Steps. I get as far as selecting the document “Standard” library and selecting “New” to create a module; the module is created, BUT AOO stops working and tells me an unexpected error has occurred. It appears that the Basic Editor opened and then the error occurred; if an error code was generated, it disappeared from the screen too fast to be recorded. When I recover and re-open the document, the module has been created in the “Standard” library, but trying to “Edit” it results in AOO blowing up again. I have had limited luck in creating a macro and storing it in the “My Macros” library, but I cannot edit any modules I try to save in documents. I have verified the integrity of the downloaded .exe setup file, I have downloaded a JRE, and I've tried hard re-boots of my system (Win 10 v20H2), all to no avail. Any suggestions?

Re: Can't Edit Document Macro Libraries or Modules

PostPosted: Fri Feb 19, 2021 9:20 pm
I have this problem on my HP Windows laptop and I have never found a permanent cure. There have been Windows updates that fixed it but then it comes back after a subsequent update. If I run in Safe Mode, the problem is fixed. I have tried turning off various drivers but I have not found a solution.
I suggest you try running in Safe Mode to confirm that also fixes your problem.
What kind of computer do you have?

Re: Can't Edit Document Macro Libraries or Modules

PostPosted: Sun Feb 21, 2021 10:00 pm
by cantorkenOO
FJCC -- Thank you very much for your reply. As it happens, I too have an HP laptop. Rather than try to run it in Safe Mode as you suggested, I've tried running AOO on a different machine also running Windows 10 with AOO updated to 4.1.9. I was successful in creating a new module in the document library and the Basic Editor appears to be ready for use as advertised in AOO online documentation. I resisted using Safe Mode because instructions mentioned something called BitLocker, and, quite frankly, that scared me off. At any rate, there does appear to be something in the HP setup which leads to the Basic Editor problem, but, thanks to you, I do have work-around solution. Thanks again.