Page 1 of 1

OpenOffice 4.1.3 is not working in docker (opnjdk11)

PostPosted: Fri Oct 04, 2019 2:09 pm
by milank
I have spring-boot application which uses openoffice service.

I have set up dockerfile for this application to start through docker.

In which I have used openjdk:11 image. On top of that I have installed openoffice.

When I am starting openoffice I am getting below error:
Code: Select all   Expand viewCollapse view
javaldx: Could not find a Java Runtime Environment!
/opt/openoffice4/program/soffice.bin: error while loading shared libraries: libXext.so.6: cannot open shared object file: No such file or directory

Is openoffice supported with JDK11?
If yes, then how to set JDK/JRE for openoffice in docker?


versions :
# java --version
openjdk 11.0.4 2019-07-16
OpenJDK Runtime Environment 18.9 (build 11.0.4+11)
OpenJDK 64-Bit Server VM 18.9 (build 11.0.4+11, mixed mode)

# uname -a
Linux 18aac3d4e7e9 3.10.0-229.el7.x86_64 #1 SMP Fri Mar 6 11:36:42 UTC 2015 x86_64 GNU/Linux

Installed from : http://sourceforge.net/projects/openoff ... -US.tar.gz

Re: OpenOffice 4.1.3 is not working in docker (opnjdk11)

PostPosted: Fri Oct 04, 2019 3:53 pm
by Villeroy
Cross posting: https://stackoverflow.com/questions/582 ... -supported

4.1.3 is years old. Possibly it is older than Java 11.

Re: OpenOffice 4.1.3 is not working in docker (opnjdk11)

PostPosted: Fri Oct 04, 2019 4:29 pm
by milank
I have checked with 4.1.6 also.
Getting same issue.

Re: OpenOffice 4.1.3 is not working in docker (opnjdk11)

PostPosted: Fri Oct 04, 2019 5:22 pm
by Villeroy

Re: OpenOffice 4.1.3 is not working in docker (opnjdk11)

PostPosted: Sat Oct 05, 2019 9:12 am
by milank
This is JDK8 and in application, it is working wotk JDK8 in docker.
Only issue is with starting OO 4.1.3 or 4.1.6 on top openjdk:11 image.

Let me know if you have any solution.

Re: OpenOffice 4.1.3 is not working in docker (opnjdk11)

PostPosted: Sat Oct 05, 2019 11:23 am
by Villeroy
What's wrong with Java 8?

System requirements AOO 4.1 wrote:Java
The Java Runtime Environment (JRE) 1.5.x, is the minimum version required to use the full functionality of Apache OpenOffice that need Java (see Java and Apache OpenOffice). However, we strongly recommend the last version of Oracle Java 1.6.x, patch level 45, or the latest Oracle Java 7, or - for Linux users - OpenJDK 6, build 27, or OpenJDK 7.


and guess what ... the one and only improvement in AOO 4.1.7 is
Adds support for AdoptOpenJDK as well as Oracle Java

https://cwiki.apache.org/confluence/dis ... ease+Notes

Re: OpenOffice 4.1.3 is not working in docker (opnjdk11)

PostPosted: Sun Oct 06, 2019 4:20 pm
by milank
After using OO 4.1.7, I think it is getting JRE/JDK.
but when below command executes in container (which I have provided through supervisor.conf file) getting error as below :
/opt/openoffice4/program/soffice "-accept=socket,host=0,port=8100;urp;StarOffice.ServiceManager" -norestore -nofirststartwizard -nologo -headless

output : no suitable windowing system found, exiting.

Any idea?

Re: OpenOffice 4.1.3 is not working in docker (opnjdk11)

PostPosted: Tue Jan 28, 2020 10:47 am
by kevin_caiji
i had use openoffice-v4.1.6 with openjdk8 and centos7, it's ok.
here is the dockerfile, pleaser see https://github.com/kevinsingapore/OpenOffice-Dockerfile