Installing AOO causes LibO to be installed & broken packages

Issues with installing under all Linux Distributions

Installing AOO causes LibO to be installed & broken packages

Postby ottadini » Tue Jul 30, 2013 3:47 am

I previously had LibreOffice installed on Ubuntu precise. In haste I removed it using Synaptic (meaning that I might have missed one or two items, like the python-uno bridge?), and then installed Apache OO4 from the DEBs (using dpkg). Once complete, I updated my system to discover that I had some broken packages... libreoffice-core, and libreoffice-java-common. It then appeared that the entire libreoffice suite had been installed! How is this possible?

AOO opens and seems to run without any problems, but my system is in a broken state.

Here are some details:
Code: Select all   Expand viewCollapse view
$ aptitude search '~i' | grep openoffice
u   openclipart-openoffice.org      - clip art for OpenOffice.org/LibreOffice ga
i   openoffice                      - Brand module for OpenOffice 4.0.0         
i   openoffice-base                 - Base module for Apache OpenOffice 4.0.0   
i   openoffice-brand-base           - Base brand module for OpenOffice 4.0.0   
i   openoffice-brand-calc           - Calc brand module for OpenOffice 4.0.0   
i   openoffice-brand-draw           - Draw brand module for OpenOffice 4.0.0   
i   openoffice-brand-en-gb          - Brand language module for OpenOffice 4.0.0
i   openoffice-brand-impress        - Impress brand module for OpenOffice 4.0.0
i   openoffice-brand-math           - Math brand module for OpenOffice 4.0.0   
i   openoffice-brand-writer         - Writer brand module for OpenOffice 4.0.0 
i   openoffice-calc                 - Calc module for Apache OpenOffice 4.0.0   
i   openoffice-core01               - Core module for Apache OpenOffice 4.0.0   
i   openoffice-core02               - Office core module for Apache OpenOffice 4
i   openoffice-core03               - Office core module for Apache OpenOffice 4
i   openoffice-core04               - Office core module for Apache OpenOffice 4
i   openoffice-core05               - Office core module for Apache OpenOffice 4
i   openoffice-core06               - Office core module for Apache OpenOffice 4
i   openoffice-core07               - Office core module for Apache OpenOffice 4
i   openoffice-debian-menus         - OpenOffice desktop integration           
i   openoffice-draw                 - Draw module for Apache OpenOffice 4.0.0   
i   openoffice-en-gb                - Language module for Apache OpenOffice 4.0.
i   openoffice-en-gb-base           - Base language module for Apache OpenOffice
i   openoffice-en-gb-calc           - Calc language module for Apache OpenOffice
i   openoffice-en-gb-draw           - Draw language module for Apache OpenOffice
i   openoffice-en-gb-help           - Language help module for Apache OpenOffice
i   openoffice-en-gb-impress        - Impress language module for Apache OpenOff
i   openoffice-en-gb-math           - Math language module for Apache OpenOffice
i   openoffice-en-gb-res            - Language resource module for Apache OpenOf
i   openoffice-en-gb-writer         - Writer language module for Apache OpenOffi
i   openoffice-gnome-integration    - Gnome integration module for Apache OpenOf
i   openoffice-graphicfilter        - Graphic filter module for Apache OpenOffic
i   openoffice-images               - Images module for Apache OpenOffice 4.0.0
i   openoffice-impress              - Impress module for Apache OpenOffice 4.0.0
i   openoffice-javafilter           - Java filter module for Apache OpenOffice 4
i   openoffice-math                 - Math module for Apache OpenOffice 4.0.0   
i   openoffice-ogltrans             - OpenGL slide transitions module for Apache
i   openoffice-onlineupdate         - Online update modul for Apache OpenOffice
i   openoffice-ooofonts             - Mailcap module for Apache OpenOffice 4.0.0
i   openoffice-ooolinguistic        - Linguistic module for Apache OpenOffice 4.
i   openoffice-pyuno                - Pyuno module for Apache OpenOffice 4.0.0 
i   openoffice-ure                  - UNO Runtime Environment for OpenOffice 4.0
i   openoffice-writer               - Writer module for Apache OpenOffice 4.0.0
i   openoffice-xsltfilter           - XSLT filter samples module for Apache Open
up  openoffice.org-pdfimport        - LibreOffice extension for importing PDF do



Code: Select all   Expand viewCollapse view
$ aptitude search '~i' | grep libreoffice
uB  libreoffice                     - office productivity suite                 
uB  libreoffice-base                - office productivity suite -- database     
uB  libreoffice-base-core           - office productivity suite -- shared librar
uB  libreoffice-calc                - office productivity suite -- spreadsheet 
Bp  libreoffice-core                - office productivity suite -- arch-dependen
uB  libreoffice-draw                - office productivity suite -- drawing     
uB  libreoffice-emailmerge          - office productivity suite -- email mail me
u   libreoffice-filter-mobiledev    - office productivity suite -- mobile device
uB  libreoffice-gnome               - office productivity suite -- GNOME integra
uB  libreoffice-gtk                 - office productivity suite -- GTK+ integrat
uB  libreoffice-impress             - office productivity suite -- presentation
B   libreoffice-java-common         - office productivity suite -- arch-independ
uB  libreoffice-math                - office productivity suite -- equation edit
up  libreoffice-pdfimport           - LibreOffice extension for importing PDF do
up  libreoffice-style-human         - office productivity suite -- Human symbol
uB  libreoffice-style-tango         - office productivity suite -- Tango symbol
uB  libreoffice-writer              - office productivity suite -- word processo
u   openclipart-libreoffice         - clip art for OpenOffice.org/LibreOffice ga


Code: Select all   Expand viewCollapse view
$ sudo apt-get purge libreoffice*
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libreoffice-l10n-el' for regex 'libreoffice*'
...
<<SNIP>>
...
Package libreoffice-wiki-publisher is not installed, so not removed
Package mozilla-libreoffice is not installed, so not removed
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
openclipart : Depends: openclipart-libreoffice (= 2.0-1ubuntu1) but it is not going to be installed
openclipart-openoffice.org : Depends: openclipart-libreoffice but it is not going to be installed
openoffice.org-pdfimport : Depends: libreoffice-pdfimport but it is not going to be installed
python-uno : Depends: libreoffice-core (= 1:3.5.7-0ubuntu4) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


Which suggests that I use apt-get install -f to solve the broken dependencies. However, running that seems to want to INSTALL libreoffice??

Code: Select all   Expand viewCollapse view
$ sudo apt-get install -f -s
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libreoffice-common
Suggested packages:
  libreoffice-style-hicontrast libreoffice-style-crystal libreoffice-style-oxygen
The following NEW packages will be installed:
  libreoffice-common
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
26 not fully installed or removed.
Inst libreoffice-common (1:3.5.7-0ubuntu4 Ubuntu:12.04/precise-updates [all])
Conf fonts-opensymbol (2:102.2+LibO3.5.7-0ubuntu4 Ubuntu:12.04/precise-updates [all])
Conf ure (3.5.7-0ubuntu4 Ubuntu:12.04/precise-updates [amd64])


Alright then, I'll try anything at this point:

Code: Select all   Expand viewCollapse view
$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libreoffice-common
Suggested packages:
  libreoffice-style-hicontrast libreoffice-style-crystal libreoffice-style-oxygen
The following NEW packages will be installed:
  libreoffice-common
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
26 not fully installed or removed.
Need to get 0 B/20.9 MB of archives.
After this operation, 52.7 MB of additional disk space will be used.
(Reading database ... 1126557 files and directories currently installed.)
Unpacking libreoffice-common (from .../libreoffice-common_1%3a3.5.7-0ubuntu4_all.deb) ...
dpkg: error processing /var/cache/apt/archives/libreoffice-common_1%3a3.5.7-0ubuntu4_all.deb (--unpack):
trying to overwrite '/usr/bin/soffice', which is also in package openoffice-debian-menus 4.0-9702
rmdir: failed to remove `/var/lib/libreoffice/share/prereg/': No such file or directory
rmdir: failed to remove `/var/lib/libreoffice/share/': Directory not empty
rmdir: failed to remove `/var/lib/libreoffice/program/': No such file or directory
rmdir: failed to remove `/var/lib/libreoffice': Directory not empty
rmdir: failed to remove `/var/lib/libreoffice': Directory not empty
Processing triggers for shared-mime-info ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Processing triggers for man-db ...
Processing triggers for gnome-icon-theme ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Errors were encountered while processing:
/var/cache/apt/archives/libreoffice-common_1%3a3.5.7-0ubuntu4_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Nope, broken.
What can I do?
ottadini
 
Posts: 12
Joined: Wed Jul 07, 2010 9:44 am

Re: Installing AOO causes LibO to be installed & broken pack

Postby RoryOF » Tue Jul 30, 2013 5:37 am

I'm not certain as to your best way to proceed. From experience, before I install OpenOffice (all versions), I remove libreoffice-core using Synaptic at then use it again to check that there are no libreoffice components left. Then I install OO using dpkg.

The problem of the silent substitution of LibreOffice for OpenOffice is currently undergoing consideration on the OpenOffice developers list; the ideal view is that one would wish users to have a definite choice not a silent substitution, but that is another day's work.

A little investigation throws up this fix (workaround?) for your problem
http://www.sudo-juice.com/ignore-broken-packages-ubuntu-aptitude/

Ubuntu 9.10 support ended 29 April 2011; should you decide to upgrade to a later Ubuntu derivative but have limited processing power, be aware that the Xubuntu 12.04/12.10 packages run AOO 4.00 (and all earlier versions) well. Remember that you can check appearance/behaviour using a Live CD/USB.

If upgrading across many Ubuntu versions it is probably best to save your data (two verified saves to be certain) and do a Format and fresh install before restoring your data.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31535
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Installing AOO causes LibO to be installed & broken pack

Postby ottadini » Tue Jul 30, 2013 7:23 am

Thanks for the response Rory, but I'm still without a solution. I have a few comments though...

RoryOF wrote:I'm not certain as to your best way to proceed. From experience, before I install OpenOffice (all versions), I remove libreoffice-core using Synaptic at then use it again to check that there are no libreoffice components left. Then I install OO using dpkg.

I've tried that, and it silently installed LibO :(

RoryOF wrote:The problem of the silent substitution of LibreOffice for OpenOffice

I don't know about substitution, as Openoffice is installed, but for some reason a bunch of LibreOffice files are as well. Where exactly can I find out more about this silent substitution?

RoryOF wrote:A little investigation throws up this fix (workaround?) for your problem

Thanks, I'd like to sort the problem out I think, as this is a multi-user machine, and I'm not keen to mess around with band-aids.

RoryOF wrote:Ubuntu 9.10 support ended 29 April 2011

I'm on Ubuntu Precise Pangolin, 12.04.2, not sure why you mention 9.10?
ottadini
 
Posts: 12
Joined: Wed Jul 07, 2010 9:44 am

Re: Installing AOO causes LibO to be installed & broken pack

Postby Hagar Delest » Tue Jul 30, 2013 7:50 am

In the past when LibO was still installed, I used to remove it through Synaptic too. Run it again and make sure that there is no LibO package left (use the filter).
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28996
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Installing AOO causes LibO to be installed & broken pack

Postby RoryOF » Tue Jul 30, 2013 8:11 am

After removing LibO as I outlined, I installed OpenOffice after downloading from
http://www.openoffice.org/download
using dpkg as outlined in Tutorial at
http://forum.openoffice.org/en/forum/viewtopic.php?f=74&t=68

I agree with your reluctance to use the workaround I pointed to. A better fix might be to repair the broken packages fully, irrespective of what they (re)install, then fully remove LibO and (re)install OpenOffice, perhaps as in the above tutorial. For fixing the packages I think you would be best on an Ubuntu forum, although the main Ubuntu user forum is currently offline (hopefully back soon).
I mentioned Ubuntu 9.10 as your Forum sig indicated you were using that
OpenOffice.org version 3.1.1-5ubuntu1.2, on Ubuntu 9.10


The silent substitution of LibO for an OpenOffice request happens in many Linux distros and has happened since the fork some years ago. OpenOffice dev group are endeavouring to find an amicable resolution to this. At present, to install OpenOffice on most linux distros it is necessary to make a separate download of the Apache OpenOffice files and install them using other than the inbuilt distro updater.

Whether one _needs_ to remove or adjust any preinstalled LibO depends on the exact distro. My standard procedure is to remove LibO as I outlined earlier, prior to installling OpenOffice. I do this as my machines are in constant use for text composition and I'm happy with the facilities and stability offered by OpenOffice; should new facilities be offered in any other reasonably compatible text editor I wished to try, I would install it to a spare machine rather than run in parallel on a production machine.

However, having learned to compose text using paper and pen, then typewriter, then various word processors, I know that the various facilities offered do not greatly improve composition, only the layout. For what I'm doing I get sufficient layout options.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31535
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Installing AOO causes LibO to be installed & broken pack

Postby ottadini » Tue Jul 30, 2013 8:23 am

I need to update that signature!!
ottadini
 
Posts: 12
Joined: Wed Jul 07, 2010 9:44 am

Re: Installing AOO causes LibO to be installed & broken pack

Postby ottadini » Thu Aug 01, 2013 9:33 am

Have just tried again, by completely uninstalling LO and AOO.
Purged everything from my system.
Made sure there were no PPAs for LO in sources.list and sources.list.d.
Restarted my system.
Checked using dpkg -l libreoffice* (and openoffice*) to make sure.
Code: Select all   Expand viewCollapse view
$ dpkg -l libreoffice*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                        Version                     Description
+++-===========================-===========================-======================================================================
un  libreoffice                 <none>                      (no description available)
un  libreoffice-base            <none>                      (no description available)
un  libreoffice-base-core       <none>                      (no description available)
un  libreoffice-bundled         <none>                      (no description available)
un  libreoffice-calc            <none>                      (no description available)
un  libreoffice-common          <none>                      (no description available)
un  libreoffice-core            <none>                      (no description available)
un  libreoffice-dev             <none>                      (no description available)
un  libreoffice-draw            <none>                      (no description available)
un  libreoffice-emailmerge      <none>                      (no description available)
un  libreoffice-evolution       <none>                      (no description available)
un  libreoffice-filter-binfilte <none>                      (no description available)
un  libreoffice-filter-mobilede <none>                      (no description available)
un  libreoffice-filter-so52     <none>                      (no description available)
un  libreoffice-gcj             <none>                      (no description available)
un  libreoffice-gnome           <none>                      (no description available)
un  libreoffice-gtk             <none>                      (no description available)
un  libreoffice-gtk-gnome       <none>                      (no description available)
un  libreoffice-help-3.5        <none>                      (no description available)
un  libreoffice-help-en-us      <none>                      (no description available)
un  libreoffice-impress         <none>                      (no description available)
un  libreoffice-java-common     <none>                      (no description available)
un  libreoffice-kab             <none>                      (no description available)
un  libreoffice-kde             <none>                      (no description available)
un  libreoffice-l10n-3.5        <none>                      (no description available)
un  libreoffice-l10n-en-us      <none>                      (no description available)
un  libreoffice-math            <none>                      (no description available)
un  libreoffice-officebean      <none>                      (no description available)
un  libreoffice-pdfimport       <none>                      (no description available)
un  libreoffice-script-provider <none>                      (no description available)
un  libreoffice-sdbc-postgresql <none>                      (no description available)
un  libreoffice-style           <none>                      (no description available)
un  libreoffice-style-andromeda <none>                      (no description available)
un  libreoffice-style-crystal   <none>                      (no description available)
un  libreoffice-style-default   <none>                      (no description available)
un  libreoffice-style-galaxy    <none>                      (no description available)
un  libreoffice-style-hicontras <none>                      (no description available)
un  libreoffice-style-human     <none>                      (no description available)
un  libreoffice-style-industria <none>                      (no description available)
un  libreoffice-style-oxygen    <none>                      (no description available)
un  libreoffice-style-tango     <none>                      (no description available)
un  libreoffice-writer          <none>                      (no description available)


Installed AOO 4 from debs using dpkg -i as per install guide.
Waited a bit....
After about 10 minutes apport tells me that there is a problem: Libreoffice has silently been installing itself! It threw an error because it was trying to overwrite /usr/bin/soffice.

Why?

Now dpkg -l libreoffice reports this:

Code: Select all   Expand viewCollapse view
$ dpkg -l libreoffice*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                        Version                     Description
+++-===========================-===========================-======================================================================
iU  libreoffice                 1:3.5.7-0ubuntu4            office productivity suite
iU  libreoffice-base            1:3.5.7-0ubuntu4            office productivity suite -- database
iU  libreoffice-base-core       1:3.5.7-0ubuntu4            office productivity suite -- shared library
un  libreoffice-bundled         <none>                      (no description available)
iU  libreoffice-calc            1:3.5.7-0ubuntu4            office productivity suite -- spreadsheet
in  libreoffice-common          <none>                      (no description available)
iU  libreoffice-core            1:3.5.7-0ubuntu4            office productivity suite -- arch-dependent files
un  libreoffice-dev             <none>                      (no description available)
iU  libreoffice-draw            1:3.5.7-0ubuntu4            office productivity suite -- drawing
iU  libreoffice-emailmerge      1:3.5.7-0ubuntu4            office productivity suite -- email mail merge
un  libreoffice-evolution       <none>                      (no description available)
un  libreoffice-filter-binfilte <none>                      (no description available)
iU  libreoffice-filter-mobilede 1:3.5.7-0ubuntu4            office productivity suite -- mobile devices filters
un  libreoffice-filter-so52     <none>                      (no description available)
un  libreoffice-gcj             <none>                      (no description available)
iU  libreoffice-gnome           1:3.5.7-0ubuntu4            office productivity suite -- GNOME integration
iU  libreoffice-gtk             1:3.5.7-0ubuntu4            office productivity suite -- GTK+ integration
un  libreoffice-gtk-gnome       <none>                      (no description available)
un  libreoffice-help-3.5        <none>                      (no description available)
un  libreoffice-help-en-us      <none>                      (no description available)
iU  libreoffice-impress         1:3.5.7-0ubuntu4            office productivity suite -- presentation
iU  libreoffice-java-common     1:3.5.7-0ubuntu4            office productivity suite -- arch-independent Java support files
un  libreoffice-kab             <none>                      (no description available)
un  libreoffice-kde             <none>                      (no description available)
un  libreoffice-l10n-3.5        <none>                      (no description available)
un  libreoffice-l10n-en-us      <none>                      (no description available)
iU  libreoffice-math            1:3.5.7-0ubuntu4            office productivity suite -- equation editor
un  libreoffice-officebean      <none>                      (no description available)
iU  libreoffice-pdfimport       1.0.5+LibO3.5.7-0ubuntu4    LibreOffice extension for importing PDF documents
un  libreoffice-script-provider <none>                      (no description available)
un  libreoffice-sdbc-postgresql <none>                      (no description available)
un  libreoffice-style           <none>                      (no description available)
un  libreoffice-style-andromeda <none>                      (no description available)
un  libreoffice-style-crystal   <none>                      (no description available)
un  libreoffice-style-default   <none>                      (no description available)
un  libreoffice-style-galaxy    <none>                      (no description available)
un  libreoffice-style-hicontras <none>                      (no description available)
iU  libreoffice-style-human     1:3.5.7-0ubuntu4            office productivity suite -- Human symbol style
un  libreoffice-style-industria <none>                      (no description available)
un  libreoffice-style-oxygen    <none>                      (no description available)
iU  libreoffice-style-tango     1:3.5.7-0ubuntu4            office productivity suite -- Tango symbol style
iU  libreoffice-writer          1:3.5.7-0ubuntu4            office productivity suite -- word processor


What's going on?

For completeness, here's openoffice:
Code: Select all   Expand viewCollapse view
$ dpkg -l openoffice*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                        Version                     Description
+++-===========================-===========================-======================================================================
ii  openoffice                  4.0.0-3                     Brand module for OpenOffice 4.0.0
ii  openoffice-base             4.0.0-3                     Base module for Apache OpenOffice 4.0.0
ii  openoffice-brand-base       4.0.0-3                     Base brand module for OpenOffice 4.0.0
ii  openoffice-brand-calc       4.0.0-3                     Calc brand module for OpenOffice 4.0.0
ii  openoffice-brand-draw       4.0.0-3                     Draw brand module for OpenOffice 4.0.0
ii  openoffice-brand-en-gb      4.0.0-3                     Brand language module for OpenOffice 4.0.0
ii  openoffice-brand-impress    4.0.0-3                     Impress brand module for OpenOffice 4.0.0
ii  openoffice-brand-math       4.0.0-3                     Math brand module for OpenOffice 4.0.0
ii  openoffice-brand-writer     4.0.0-3                     Writer brand module for OpenOffice 4.0.0
ii  openoffice-calc             4.0.0-3                     Calc module for Apache OpenOffice 4.0.0
ii  openoffice-core01           4.0.0-3                     Core module for Apache OpenOffice 4.0.0
ii  openoffice-core02           4.0.0-3                     Office core module for Apache OpenOffice 4.0.0
ii  openoffice-core03           4.0.0-3                     Office core module for Apache OpenOffice 4.0.0
ii  openoffice-core04           4.0.0-3                     Office core module for Apache OpenOffice 4.0.0
ii  openoffice-core05           4.0.0-3                     Office core module for Apache OpenOffice 4.0.0
ii  openoffice-core06           4.0.0-3                     Office core module for Apache OpenOffice 4.0.0
ii  openoffice-core07           4.0.0-3                     Office core module for Apache OpenOffice 4.0.0
ii  openoffice-debian-menus     4.0-9702                    OpenOffice desktop integration
un  openoffice-desktop-integrat <none>                      (no description available)
ii  openoffice-draw             4.0.0-3                     Draw module for Apache OpenOffice 4.0.0
ii  openoffice-en-gb            4.0.0-3                     Language module for Apache OpenOffice 4.0.0, language en_GB
ii  openoffice-en-gb-base       4.0.0-3                     Base language module for Apache OpenOffice 4.0.0, language en_GB
ii  openoffice-en-gb-calc       4.0.0-3                     Calc language module for Apache OpenOffice 4.0.0, language en_GB
ii  openoffice-en-gb-draw       4.0.0-3                     Draw language module for Apache OpenOffice , language en_GB
ii  openoffice-en-gb-help       4.0.0-3                     Language help module for Apache OpenOffice 4.0.0, language en_GB
ii  openoffice-en-gb-impress    4.0.0-3                     Impress language module for Apache OpenOffice 4.0.0, language en_GB
ii  openoffice-en-gb-math       4.0.0-3                     Math language module for Apache OpenOffice 4.0.0, language en_GB
ii  openoffice-en-gb-res        4.0.0-3                     Language resource module for Apache OpenOffice 4.0.0, language en_GB
ii  openoffice-en-gb-writer     4.0.0-3                     Writer language module for Apache OpenOffice 4.0.0, language en_GB
ii  openoffice-gnome-integratio 4.0.0-3                     Gnome integration module for Apache OpenOffice 4.0.0
ii  openoffice-graphicfilter    4.0.0-3                     Graphic filter module for Apache OpenOffice 4.0.0
ii  openoffice-images           4.0.0-3                     Images module for Apache OpenOffice 4.0.0
ii  openoffice-impress          4.0.0-3                     Impress module for Apache OpenOffice 4.0.0
ii  openoffice-javafilter       4.0.0-3                     Java filter module for Apache OpenOffice 4.0.0
ii  openoffice-math             4.0.0-3                     Math module for Apache OpenOffice 4.0.0
ii  openoffice-ogltrans         4.0.0-3                     OpenGL slide transitions module for Apache OpenOffice 4.0.0
ii  openoffice-onlineupdate     4.0.0-3                     Online update modul for Apache OpenOffice 4.0.0
ii  openoffice-ooofonts         4.0.0-3                     Mailcap module for Apache OpenOffice 4.0.0
ii  openoffice-ooolinguistic    4.0.0-3                     Linguistic module for Apache OpenOffice 4.0.0
ii  openoffice-pyuno            4.0.0-3                     Pyuno module for Apache OpenOffice 4.0.0
ii  openoffice-ure              4.0.0-3                     UNO Runtime Environment for OpenOffice 4.0.0
ii  openoffice-writer           4.0.0-3                     Writer module for Apache OpenOffice 4.0.0
ii  openoffice-xsltfilter       4.0.0-3                     XSLT filter samples module for Apache OpenOffice 4.0.0
un  openoffice.org              <none>                      (no description available)
un  openoffice.org-base         <none>                      (no description available)
un  openoffice.org-bundled      <none>                      (no description available)
un  openoffice.org-common       <none>                      (no description available)
un  openoffice.org-core         <none>                      (no description available)
un  openoffice.org-debian-menus <none>                      (no description available)
un  openoffice.org-hunspell     <none>                      (no description available)
un  openoffice.org-hyphenation  <none>                      (no description available)
un  openoffice.org-hyphenation- <none>                      (no description available)
un  openoffice.org-hyphenation- <none>                      (no description available)
un  openoffice.org-hyphenation- <none>                      (no description available)
un  openoffice.org-hyphenation- <none>                      (no description available)
un  openoffice.org-hyphenation- <none>                      (no description available)
un  openoffice.org-hyphenation- <none>                      (no description available)
un  openoffice.org-hyphenation- <none>                      (no description available)
un  openoffice.org-hyphenation- <none>                      (no description available)
un  openoffice.org-hyphenation- <none>                      (no description available)
un  openoffice.org-hyphenation- <none>                      (no description available)
un  openoffice.org-hyphenation- <none>                      (no description available)
un  openoffice.org-hyphenation- <none>                      (no description available)
un  openoffice.org-hyphenation- <none>                      (no description available)
un  openoffice.org-hyphenation- <none>                      (no description available)
un  openoffice.org-hyphenation- <none>                      (no description available)
un  openoffice.org-hyphenation- <none>                      (no description available)
iU  openoffice.org-pdfimport    1:3.3.0-7ubuntu7            LibreOffice extension for importing PDF documents
un  openoffice.org-spellcheck-e <none>                      (no description available)
un  openoffice.org-thesaurus-en <none>                      (no description available)
un  openoffice.org-thesaurus-it <none>                      (no description available)
un  openoffice.org-unbundled    <none>                      (no description available)
un  openoffice.org-updatedicts  <none>                      (no description available)
un  openoffice.org-ure          <none>                      (no description available)
un  openoffice.org-writer       <none>                      (no description available)
un  openoffice.org2-thesaurus   <none>                      (no description available)
un  openoffice.org3             <none>                      (no description available)
un  openoffice.org3-base        <none>                      (no description available)
un  openoffice.org3-calc        <none>                      (no description available)
un  openoffice.org3-dict-en     <none>                      (no description available)
un  openoffice.org3-dict-es     <none>                      (no description available)
un  openoffice.org3-dict-fr     <none>                      (no description available)
un  openoffice.org3-draw        <none>                      (no description available)
un  openoffice.org3-en-gb       <none>                      (no description available)
un  openoffice.org3-impress     <none>                      (no description available)
un  openoffice.org3-math        <none>                      (no description available)
un  openoffice.org3-writer      <none>                      (no description available)
un  openofficeorg-desktop-integ <none>                      (no description available)


What is going on?

Rory, what did you mean by
RoryOF wrote:The silent substitution of LibO for an OpenOffice request happens in many Linux distros
?
ottadini
 
Posts: 12
Joined: Wed Jul 07, 2010 9:44 am

Re: Installing AOO causes LibO to be installed & broken pack

Postby RoryOF » Thu Aug 01, 2013 9:47 am

In haste as I'm on my way to an important meeting:

Uninstall LibreOffice as you did before.

Then download the package from ww.openoffice.org/download/other.html and install using the tutorial at
http://forum.openoffice.org/en/forum/viewtopic.php?f=74&t=68

You should end up with a genuine Apache OpenOffice.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31535
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Installing AOO causes LibO to be installed & broken pack

Postby ottadini » Thu Aug 01, 2013 9:57 am

RoryOF wrote:Uninstall LibreOffice as you did before.

Then download the package from ww.openoffice.org/download/other.html and install using the tutorial at
http://forum.openoffice.org/en/forum/viewtopic.php?f=74&t=68

You should end up with a genuine Apache OpenOffice.


That is precisely what I did. I did end up with a genuine AOO, but after 10 minutes, LibO mysteriously installed itself as well (in addition to AOO). I did nothing in the meantime apart from open AOO and check that it ran. Actually I do recall a brief error message appeared when I first started AOO asking about a thesaurus or language pack, but I hit 'Cancel' and AOO closed itself down.

Now on my system I have a complete install of AOO (that seems to work), a broken / half-unpacked / half-installed LibO, and a broken package mamagement system that refuses to do anything else apart from tell me I have broken packages.
ottadini
 
Posts: 12
Joined: Wed Jul 07, 2010 9:44 am

Re: Installing AOO causes LibO to be installed & broken pack

Postby Hagar Delest » Thu Aug 01, 2013 4:36 pm

If you run sudo apt-get install -f, you get the same as the beginning?

At worst, perhaps installing LibO first without the desktop-integration and then installing AOO would work. Not very elegant, especially if you don't want to have LibO installed at all.

I can't see how LibO would install itself. I've always installed AOO from the official debs and I've never seen that. Have you noticed some Ubuntu update? Perhaps there is a meta package that includes LibO and that it re-installed it silently. Do you check the updates when prompted?
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28996
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Installing AOO causes LibO to be installed & broken pack

Postby RoryOF » Thu Aug 01, 2013 4:44 pm

I'm puzzled; I have immediately to hand six computers all running various forms of Ubuntu and OpenOffice; They are all regularly updated with current Ubuntu updates (when prompted). None have ever reinstalled LibreOffice except on verison upgrades of Ubuntu.

The only thing I can think of is some form of automatic restore. In your repository info is there a line including
repository stable main ?

If so, that may be the cause of the problem.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31535
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Installing AOO causes LibO to be installed & broken pack

Postby ottadini » Fri Aug 02, 2013 2:14 am

Hagar Delest wrote:Have you noticed some Ubuntu update? Perhaps there is a meta package that includes LibO and that it re-installed it silently. Do you check the updates when prompted?

There might be something in that, though I have no idea what it would have been. I've just checked my Synaptic history, and there is only this:
Code: Select all   Expand viewCollapse view
Upgraded the following packages:
google-chrome-stable (28.0.1500.71-r209842) to 28.0.1500.95-r213514
liblcms2-2 (2.2+git20110628-2ubuntu3) to 2.2+git20110628-2ubuntu3.1
r-base (3.0.1-5precise0) to 3.0.1-6precise0
r-base-core (3.0.1-5precise0) to 3.0.1-6precise0
r-base-dev (3.0.1-5precise0) to 3.0.1-6precise0
r-base-html (3.0.1-5precise0) to 3.0.1-6precise0
r-doc-html (3.0.1-5precise0) to 3.0.1-6precise0
r-recommended (3.0.1-5precise0) to 3.0.1-6precise0

Nothing related to LibO or AOO.

RoryOF wrote:The only thing I can think of is some form of automatic restore. In your repository info is there a line including
repository stable main ?

I can't see anything there.

Is there any chance that aptitude has a "hold" or something on LibreOffice that causes it to be kept?
ottadini
 
Posts: 12
Joined: Wed Jul 07, 2010 9:44 am

Re: Installing AOO causes LibO to be installed & broken pack

Postby ottadini » Fri Aug 02, 2013 4:02 am

I think it may have been Aptitude, if it has install-recommends as a configuration option, then it just goes for it... installs recommended packages without asking you again. I hope that I've fixed it now, but will leave it for a day or so (or at least until the next automatic update by the system).

Thanks for the help Rory and Hagar.
ottadini
 
Posts: 12
Joined: Wed Jul 07, 2010 9:44 am

Re: Installing AOO causes LibO to be installed & broken pack

Postby RoryOF » Fri Aug 02, 2013 4:09 am

A quick research (means: not necessarily thorough) gives this
Using aptitude

you can hold a package using

sudo aptitude hold package_name

and remove the hold with

sudo aptitude unhold package_name


The full details are at
http://askubuntu.com/questions/18654/how-to-prevent-updating-of-a-specific-package
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31535
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Installing AOO causes LibO to be installed & broken pack

Postby ottadini » Fri Aug 02, 2013 6:16 am

I was premature in my hope for a solution. It seems LibO has once again been installed under my nose.
I will try to hold it with aptitude or dpkg --set-selections.
ottadini
 
Posts: 12
Joined: Wed Jul 07, 2010 9:44 am

Re: Installing AOO causes LibO to be installed & broken pack

Postby ottadini » Mon Aug 12, 2013 7:15 am

Well I discovered that AOO has nothing to do with LibO installing itself (I guess at this point it is redundant for me to "I think", as I obviously have no idea what the hell is really happening).
I have purged AOO completely, and LibO along with it. Waited half a day as I was busy with something else, and came back to discover LibO installed again.

Giving up, reverting to LibO.
ottadini
 
Posts: 12
Joined: Wed Jul 07, 2010 9:44 am

Re: Installing AOO causes LibO to be installed & broken pack

Postby RGB » Tue Aug 13, 2013 6:07 pm

ottadini wrote:Well I discovered that AOO has nothing to do with LibO installing itself (I guess at this point it is redundant for me to "I think", as I obviously have no idea what the hell is really happening).
I have purged AOO completely, and LibO along with it. Waited half a day as I was busy with something else, and came back to discover LibO installed again.

Giving up, reverting to LibO.

IMO, one of the main points of using free software is the freedom of choice. If your Linux distro does not provide that freedom, maybe it's time to switch.
Just my 2¢.
There are two types of people: those who believe that there are two types of people and those who do not.

openSUSE Leap with KDE Plasma / LibreOffice
User avatar
RGB
 
Posts: 1455
Joined: Mon Oct 08, 2007 1:34 am

Re: Installing AOO causes LibO to be installed & broken pack

Postby Hagar Delest » Tue Aug 13, 2013 9:26 pm

It's strange because it used to work under Ubuntu.
You should try xubuntu, especially if you're not a fan of Unity or Gnome 3.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28996
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Installing AOO causes LibO to be installed & broken pack

Postby RoryOF » Tue Aug 13, 2013 9:40 pm

It works for me under both Xubuntu and Ubuntu. All my non Windows computers are running one or other of these, and LibO has never reappeared once uninstalled.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31535
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Installing AOO causes LibO to be installed & broken pack

Postby The_Letter_J » Sun Oct 06, 2013 11:31 pm

I'm running the nearly the same system as the OP, which is ubuntu 12.04.3 (updated from 12.04.2) that ships with Lo357.
It also has, in the official ubuntu repo, the optional OOo330 packages.

$ apt-get --simulate install openoffice.org
Inst openoffice.org (1:3.3.0-7ubuntu7 Ubuntu:12.04/precise [all])
Inst libreoffice (1:3.5.7-0ubuntu4 Ubuntu:12.04/precise-updates [amd64])
Inst libreoffice-base (1:3.5.7-0ubuntu4 Ubuntu:12.04/precise-updates [amd64])
Inst libreoffice-java-common (1:3.5.7-0ubuntu4 Ubuntu:12.04/precise-updates [all])
Inst libreoffice-filter-mobiledev (1:3.5.7-0ubuntu4 Ubuntu:12.04/precise-updates [all])
(and twenty more dependencies like icedtea/openjdk and libxml and so on)

Maybe this is the reason for the mysterious reappearance of Lo357 ...
when installing Aoo4xx via manual dpkg commands, presumably it still calls itself
by the 'openoffice.org' packagename under the hood? Maybe dpkg or apt-get
or ubuntuOne or ubuntuSoftwareCenter or somesuch, is picking up on the fact
that the 'openoffice.org' package is installed, and then checking with the upstream
ubuntu repo to make sure everything is okay, and noticing that the "libreoffice"
dependencies -- almost certainly a mistake by the OOo330 packager, or maybe
this is related to the Silent Substution stuff mentioned by Rory.

I have not tested what happens if I remove Lo357 , and install Aoo401 , since
I don't want to bust my package-management system. :-) So everything above
is pure hypothesis, with no empirical data to back it up. Sound probable?
LibreOffice 3.5.7 side-by-side with ApacheOpenOffice 4.0.1 on Ubuntu 12.04.3 with kernel 3.5.x
The_Letter_J
 
Posts: 11
Joined: Sun Oct 06, 2013 11:19 pm

Re: Installing AOO causes LibO to be installed & broken pack

Postby ottadini » Mon Oct 07, 2013 2:20 am

Certainly sounds plausible!
ottadini
 
Posts: 12
Joined: Wed Jul 07, 2010 9:44 am

Re: Installing AOO causes LibO to be installed & broken pack

Postby The_Letter_J » Mon Oct 07, 2013 3:32 am

Okay... so then we have two questions.

1. How do I solve my personal problem, which is to install Aoo401 on such a system?
I can always launch a virtual machine, and run openoffice inside a guest-OS, but that
seems like a waste of resources for sure.

2. How can the AOO folks and the Ubuntu (or maybe the Debian?) packagers get
this little difficulty ironed out? Actually, before we ask that question, I guess we need
to ask this one: how do we prove my hypothesis is correct, and that dpkg is getting
confused by the hand-installed Aoo4 dotdeb, then further confused by the ubuntu
repo telling it that quote openoffice.org unquote depends upon libreoffice357 ?
Last edited by The_Letter_J on Mon Oct 07, 2013 7:49 am, edited 1 time in total.
LibreOffice 3.5.7 side-by-side with ApacheOpenOffice 4.0.1 on Ubuntu 12.04.3 with kernel 3.5.x
The_Letter_J
 
Posts: 11
Joined: Sun Oct 06, 2013 11:19 pm

Re: Installing AOO causes LibO to be installed & broken pack

Postby RoryOF » Mon Oct 07, 2013 6:31 am

Why use a virtual machine? Why not use OpenOffice native to your OS?
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31535
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Installing AOO causes LibO to be installed & broken pack

Postby The_Letter_J » Mon Oct 07, 2013 7:49 am

@RoryOF, the reason I may have to use a VM environment is because, you told me to. :-)
Here is my question in full, over here, with inline quotes from a moderator you may recognize.
viewtopic.php?f=16&t=64846
LibreOffice 3.5.7 side-by-side with ApacheOpenOffice 4.0.1 on Ubuntu 12.04.3 with kernel 3.5.x
The_Letter_J
 
Posts: 11
Joined: Sun Oct 06, 2013 11:19 pm

Re: Installing AOO causes LibO to be installed & broken pack

Postby RoryOF » Mon Oct 07, 2013 7:57 am

_I_ have never told anyone to use a Virtual Machine. I have never used one in my life so would not recommend such a course. I have sufficient spare computer boxes to be able to dedicate an old box to a specific OS when needed.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31535
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Installing AOO causes LibO to be installed & broken pack

Postby The_Letter_J » Mon Oct 07, 2013 8:25 am

That's true, my comment was intended to be humorous. What you told me (indirectly) was never to try installing LibreOffice side-by-side with ApacheOpenOffice. I'm trying to do performance-testing, so either I need them side-by-side and not conflicting with each other (best option prima facie... but apparently a sticky wicket on my distro flavor), or I need them installed on bootable partitions (painful to run the tests), or I need to stick them in virtual machines (and accept that my performance-figures are going to be both relative and relatively approximate only). I could use more than one machine, but I'd rather compare apples-to-apples on identical hardware.
LibreOffice 3.5.7 side-by-side with ApacheOpenOffice 4.0.1 on Ubuntu 12.04.3 with kernel 3.5.x
The_Letter_J
 
Posts: 11
Joined: Sun Oct 06, 2013 11:19 pm

Re: Installing AOO causes LibO to be installed & broken pack

Postby The_Letter_J » Mon Oct 07, 2013 8:28 am

So, on the question of the mysterious reappearing-packages... do you have an opinion on whether it is plausible that the old "openoffice.org" packagename in the ubuntu repos from the OOo330 era is causing interference with the Aoo401 installations? How do we find out for sure?
LibreOffice 3.5.7 side-by-side with ApacheOpenOffice 4.0.1 on Ubuntu 12.04.3 with kernel 3.5.x
The_Letter_J
 
Posts: 11
Joined: Sun Oct 06, 2013 11:19 pm

Re: Installing AOO causes LibO to be installed & broken pack

Postby RoryOF » Mon Oct 07, 2013 9:16 am

I can't say why LibO reappears on your machine. Once removed from my *ubuntu installs it doesn't reappear. I normally upgrade my distros by the incremental upgrades; I know that many on the Forum prefer to do a complete install for a major OS upgrade.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31535
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Installing AOO causes LibO to be installed & broken pack

Postby The_Letter_J » Mon Oct 07, 2013 9:42 am

Well, it is an unknown whether LiO would try and re-appear on *my* machine, or not. I have not yet tried to install Aoo4.

I am not the OP, although I have a similar software setup -- ubuntu 12.04.3 LTS which ships by default with Libre 3.5.7 , and has some (hypothetically broken) optional OpenOffice.org 3.3.0 stuff in the repo.

Prior to installing Aoo4 side-by-side with Libre 3.5.7 , I came over here to figure out how to download Aoo4, since I did not see it in the usual ubuntu repos... and found out that Aoo4 is not provided via repo at all. (Is this right? If so, how do we get security updates for Aoo4? Is there a built-in Aoo-specific auto-downloader, or are we just supposed to manually download newer versions ourselves from time to time?)

However, as I learned, Aoo4 can be downloaded manually, and installed thataway... but most of the instructions on doing that explicitly say to remove Libre first thing, which is contrary to what I'm trying to accomplish (test feature #1 in Libre, then test feature #1 in Aoo, test sample-file #2 in Libre, test sample-file #2 in Aoo, and so on). When I got to the forums, and did a bit of searching, I found one or two folks using Aoo successfully... but plenty having trouble with Ubuntu 12.04 -- which is what I'm planning on using. That is, planning on using *if* somebody can give me some assurance that I will not be breaking my packaging system, like the OP.

You have some Ubuntu installations. Are you running 12.04 LTS anywhere, and were you successfully able to install Aoo there, and if so, what version exactly? Do you have Aoo4 running side-by-side with Aoo3 anywhere?
LibreOffice 3.5.7 side-by-side with ApacheOpenOffice 4.0.1 on Ubuntu 12.04.3 with kernel 3.5.x
The_Letter_J
 
Posts: 11
Joined: Sun Oct 06, 2013 11:19 pm

Re: Installing AOO causes LibO to be installed & broken pack

Postby RoryOF » Mon Oct 07, 2013 12:07 pm

I certainly ran Ubuntu 12.04 using Gnome desktop, but have moved to Xubuntu 13.04 on most machines (I prefer the desktop). I am aware that one can run the installations of AOO and LibO side by side, (I saw it somewhere on the Forum) but have never done so. On all machines I'm using AOO 4.0.1, which is quite stable for me, but I only use Writer (heavily), Calc (very lightly and trivially) and Impress (heavily but infrequently - I may have a 60 min presentation to prepare in the next few months and may need to revise some existing presentations).

My installation of AOO on 12.04 was probably 3.4.0. later upgraded to 3.4.1, using the method in the tutorial, having first removed libreoffice-core using Synaptic. I can't remember the exact AOO version numbers, as I have progressed through Release Candidates.

I've just been editing a file of 46K words (book text, no illustrations, 20 Sections, some endnotes), 128 hours editing/writing, 1220 saves (I instinctively type Ctrl S whenever I pause), and no crashes.

I have another file in edit of 950K words, 15 sections, plain text. Again, no crashes.

If you are in doubt about the parallel installation, I'd suggest installing several copies of the OS on your HD, each to its own partition and each containing a unique test candidate suite. You can then choose between such partitions at startup using Grub, and be certain that there is no concealed interaction between suites.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31535
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Next

Return to Linux

Who is online

Users browsing this forum: No registered users and 3 guests