Page 1 of 1

Temp files written to /tmp folder cause disk space problems

PostPosted: Thu Mar 21, 2013 9:30 am
by alexisperrier
We are running OpenOffice 3.2 in headless mode on Ubuntu 10 Lucid

OO writes all of it's temporary files to the /tmp folder.
We are running out of disk space, so I'd like to change the temp directory.

What's the way to set the temp folder?
Thanks for your help

Re: Temp files written to /tmp folder cause disk space probl

PostPosted: Thu Mar 21, 2013 9:33 am
by Hagar Delest
Hi and welcome to the forum!

I guess that even in headless mode there is some user profile somewhere, see if that helps: [Tutorial] The User Profile.
NB: what about fixing your disk space issue? It may lead to problems with other applications too.

Please add '[Solved]' at the beginning of your first post title (edit button) if your issue has been fixed.

Re: Temp files written to /tmp folder cause disk space probl

PostPosted: Thu Mar 21, 2013 9:35 am
by RoryOF
Try /Tools /Options /OpenOffice.org : Paths where there is a setting for tmp files. You may need to restart OpenOffice completely (including Quickstarter) for this to take.

I agree with Hagar; more disk space would be good.

Re: Temp files written to /tmp folder cause disk space probl

PostPosted: Fri Nov 13, 2015 5:57 pm
by Potapuff
Have a same problem with LibreOffice 3.5 on Debian. On file convertation to html (with unoconv) got temporary file bigger then 65Gb.

Re: Temp files written to /tmp folder cause disk space probl

PostPosted: Fri Nov 13, 2015 10:09 pm
by RoryOF
The temporary file path should be set according to the path in /Tools /Options /OpenOffice /Paths : Temporary files. If this is changed I suspect OpenOffice should be restarted so that it picks up the change. Other than that I can make no suggestion.

A 65GB file, whether HTML or any other OO format seems extreme. Is it originating from one specific conversion, or is it a cumulative file originating from many conversions?