[Solved] OO_2.3.1 installation on Solaris 10

Issues with installing under all Linux Distributions

[Solved] OO_2.3.1 installation on Solaris 10

Postby dllund » Tue Feb 26, 2008 6:11 pm

Welcome beginner. Please answer all of the questions below which may provide information necessary to answer your question.
-----------------------------------------------------------------------------------------------------------
Which version of OpenOffice.org are you using? 2.3.1
What Operating System (version) are you using? Solaris 10
What is your question or comment? What is the correct procedure for installing OO 2.3.1 on a Solaris 10 system? I get the following when attempting to install:
---------------------------------------------------------------------------------------------------------
# pwd
/disk/Help/Apps/OpenOffice_2.3.1
# ./setup
Using /usr/bin/java
java version "1.5.0_07"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_07-b03)
Java HotSpot(TM) Client VM (build 1.5.0_07-b03, mixed mode, sharing)

Running installer
/usr/bin/java -DHOME=/ -jar JavaSetup.jar
System locale: en
Root privileges
OS: SunOS
Mode: installation
Java Accessibility Bridge for GNOME loaded.

Exception in thread "main" java.awt.HeadlessException:
No X11 DISPLAY variable was set, but this program performed an operation which requires it.
at java.awt.GraphicsEnvironment.checkHeadless(GraphicsEnvironment.java:159)
at java.awt.Window.<init>(Window.java:317)
at java.awt.Frame.<init>(Frame.java:419)
at java.awt.Frame.<init>(Frame.java:384)
at javax.swing.SwingUtilities$SharedOwnerFrame.<init>(SwingUtilities.java:1666)
at javax.swing.SwingUtilities.getSharedOwnerFrame(SwingUtilities.java:1743)
at javax.swing.JDialog.<init>(JDialog.java:212)
at javax.swing.JDialog.<init>(JDialog.java:163)
at javax.swing.JDialog.<init>(JDialog.java:123)
at org.openoffice.setup.SetupFrame.<init>(SetupFrame.java:117)
at org.openoffice.setup.Main.main(Main.java:62)
---------------------------------------------------------------------------------------------------------------
The system has the following X11 packages are installed:

$ pkginfo | grep -i x11
system SUNWarrf X11 Arabic required fonts
system SUNWi13rf X11 ISO8859-13 required fonts
system SUNWi15cs X11 ISO8859-15 Codeset Support
system SUNWi15rf X11 ISO8859-15 required fonts
system SUNWi1cs X11 ISO8859-1 Codeset Support
system SUNWi2rf X11 ISO8859-2 required fonts
system SUNWi4rf X11 ISO8859-4 required fonts
system SUNWi5rf X11 ISO8859-5 required fonts
system SUNWi7rf X11 ISO8859-7 required fonts
system SUNWi8rf X11 ISO8859-8 required fonts
system SUNWi9rf X11 ISO8859-9 required fonts
system SUNWkoi8f X11 KOI8-R fonts
system SUNWxorg-compatlinks X11 Compatibility Links
system SUNWxorg-headers X.Org Foundation X11 client header

Am I missing an X11 package?
What DISPLAY variable should be set?
What is the correct procedure for installation on Solaris?

Thank you.
Dennis
Last edited by dllund on Tue Feb 26, 2008 6:27 pm, edited 2 times in total.
dllund
 
Posts: 2
Joined: Tue Feb 26, 2008 5:37 pm

Re: OO_2.3.1 installation on Solaris 10

Postby dllund » Tue Feb 26, 2008 6:23 pm

I figured it out. The root user DISPLAY was not set. I set the DISPLAY to the local machine and the install completed.
dllund
 
Posts: 2
Joined: Tue Feb 26, 2008 5:37 pm


Return to Linux

Who is online

Users browsing this forum: No registered users and 5 guests