Page 1 of 1

[Solved] Fontwork Gallery empty - Mandriva

PostPosted: Mon Feb 25, 2008 6:32 am
by gman
I'm cross posting this on the OO forum and the Mandriva Forum.

In OO 2.3.1 and 2.3.99 in Mandriva the Fontwork Gallery was empty. You can open Fontwork Gallery but there are no galleries. Any idea what would cause this?

Re: Fontwork Gallery empty - Mandriva

PostPosted: Mon Feb 25, 2008 3:15 pm
by acknak
I haven't heard any other reports of this, so my guess is that it's a problem in Mandriva's build or installation processes. Are you sure you have all the correct packages installed? OOo usually comes as a fairly large number of packages, and it may run even if some are not installed--it's easy to miss one.

You can check whether it's a Mandriva issue by installing and testing the packages from OO.org.

Re: Fontwork Gallery empty - Mandriva

PostPosted: Sat Jan 16, 2010 11:33 pm
by superwhamadyne
I run 32 bit Mandriva Linux on a generic laptop. I don't think I tried Fontwork Gallery under the previous Mandrivas, but the help files were there. However, under Mandriva 10.0, OOo Help doesn't come up and Fontwork Gallery is empty. I downloaded and reinstalled OOo 3.1.1 from Openoffice.org and it still does not have the Fontwork Gallery or the Help files. Perhaps there is a config file issue?

A friend of mine runs the latest Ubuntu (Debian based). His OO has the help files and the Fontwork Gallery.

I am going to attempt an OO download install as user instead of root to see if that helps.

Superwhamadyne

Re: Fontwork Gallery empty - Mandriva

PostPosted: Sat Jan 16, 2010 11:42 pm
by superwhamadyne
Well, installing as user didn't work either. My Open Office Help still says "Help file not installed", and my Fontwork Gallery is still empty.

Superwhamadyne

Re: Fontwork Gallery empty - Mandriva

PostPosted: Sun Jan 17, 2010 12:25 am
by superwhamadyne
My /home/user/.ooo3/gallery/ folder is not empty, and my options-paths are identified correctly. My file permissions to this directory and subdirectory are set correctly. My latest install was from OOO310_m19_native_packed-1_en-US.9420. JRE06 is installed. I guess I am at an impasse.
Superwhamadyne

Re: Fontwork Gallery empty - Mandriva

PostPosted: Sun Jan 17, 2010 1:16 am
by Hagar Delest
Try to reset your OOo user profile but don't transfer your personal data during the welcome process (if you had 2.x before), configuration files from the former version might corrupt the new profile.

Thanks to add '[Solved]' at beginning of your first post title (edit button) if your issue has been fixed.

Re: Fontwork Gallery empty - Mandriva

PostPosted: Sun Jan 17, 2010 2:13 am
by superwhamadyne
Thanks Hagar!

I have discovered that making a backup copy of my .ooox directory, deleting the existing .ooox directory and starting OO and letting it rewrite the config files covers a multitude of sins. Then you can copy what you want from the .ooox backup.

HOWEVER!
The solution to the Fontwork issue with Mandriva can be solved as follows:
!!! You will need to set up your Mandriva account first (email address & password) !!!
!!! Shut down Open Office too !!!
go to http://doc4.mandriva.org/bin/view/d4
CLICK on Applications --> Office --> o
arrow down past the various language help files
download the various gallery files and add ons to your Downloads directory
After downloading the files:
Use your Home browser to open the Downloads directory and allow it to install the various .urpmi files.
I had to reboot to activate the files. Now Open Office has a functioning Fontwork Gallery!!! PTL
BUT !!! for some reason neither the US nor British English Help .urpmi files would install.

Superwhamadyne

Re: [Solved] Fontwork Gallery empty - Mandriva

PostPosted: Wed Mar 19, 2014 8:11 pm
by jomanolo
:alarm: Hey Guys there is a another easy way:

In this blog below, them describe a another way to solve this issue. I do that, i think that a easy way.

http://esijmjg.blogspot.com.br/2014/02/galeria-do-fontwork-vazia-ou-em-branco.html

The blog is in portuguese language, but has a google translate tool.

Works well with me. Thanks :super: