[Solved] Dictionary prefs not saving to newly created .odt?

Issues with installing under all versions of MS Windows

[Solved] Dictionary prefs not saving to newly created .odt?

Postby shadowchaser » Fri Mar 26, 2021 3:31 am

Hello, all! Back again for a bit of fun; you're all so nice, I came back twice. :mrgreen:
Operating status is Win 8.1 Office 4.1.5, same as the last time.

Everything's been running swimmingly, but I've noticed that newly created .odt files A: use English (USA) for their dictionary, and liberation serif for their font, and B: even with the options changed to arial and UK in the settings of both openoffice & libreoffice, nothing changes. This is an incredibly minor issue rather then a pain, but I'm curious if anyone happens to know why this might be the case? I'm assuming that in the (kinky, as some might say!) os what is windows, it has a registry entry somehwere I can tweak. I've tried editing the defaults in both folders, to no luck.

Don't sweat if there's no solution. Thanks, as ever, for being superlative.

Solution: As in a prior question, I have both OpenOffice and LibreOffice installed. I had changed the soffice.odt file several times over with no effect, though I could create new docs from within openoffice that used it, just fine.
This made me realise that what was probably going on is that the Windows shell was creating odts from LibreOffice; I used Everything, found LibreOffice's soffice.odt, copied over my standard soffice.odt... Hey presto, all is working as intended. Hope the answer helps somebody else down the line.
Last edited by shadowchaser on Fri Mar 26, 2021 9:44 pm, edited 1 time in total.
OpenOffice 4.1.5 on Windows 8.1
User avatar
shadowchaser
 
Posts: 8
Joined: Wed Feb 10, 2021 1:40 am

Re: Dictionary/Font prefs not saving to newly created .odt?

Postby robleyd » Fri Mar 26, 2021 3:55 am

How are you creating new files - via File | New from within OpenOffice, or via right click in Windows?
Cheers
David
Apache OpenOffice 420m2(Build:9821) - Slackware 14.2 - 64 bit
LibreOffice 6.4.6.2 (SlackBuild for 6.4.6 by Eric Hameleers) - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
robleyd
Moderator
 
Posts: 3892
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: Dictionary/Font prefs not saving to newly created .odt?

Postby Hagar Delest » Fri Mar 26, 2021 10:18 am

See last post of this one: [Tutorial] Creating a new default template.

Please add [Solved] at the beginning of the title in your first post (top of the topic) with the *EDIT button if your issue has been fixed.
LibreOffice 7.0.5 on Xubuntu 21.04 and 7.0.5 portable on Windows 10
User avatar
Hagar Delest
Moderator
 
Posts: 29690
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Dictionary prefs not saving to newly created .o

Postby shadowchaser » Fri Mar 26, 2021 9:47 pm

Thanks robleyd, Hagar!

Problem solved by musing over your answers, but for the sake of clarity in case future users are here...

How are you creating new files - via File | New from within OpenOffice, or via right click in Windows?: Via context-click; it was hitting on that the documents created internally from within OpenOffice were working as planned that hit me on the solution.

See last post of this one: [Tutorial] Creating a new default template.: This was the stuff! Specifically, your very last post here helped me figure out why replacing/saving over OpenOffice's soffice.odt file wasn't working; Windows is using LibreOffice's soffice.odt as the gold standard. Replaced that, and all is well!

Again, many thanks to the both of you. That should be all, thanks!
OpenOffice 4.1.5 on Windows 8.1
User avatar
shadowchaser
 
Posts: 8
Joined: Wed Feb 10, 2021 1:40 am


Return to MS Windows

Who is online

Users browsing this forum: No registered users and 10 guests