Page 1 of 1

[Solved] Strange number of backups on WIN10 machine

PostPosted: Sat Aug 31, 2019 6:43 am
by gkick
Before yesterday I have never backed up anything in Base. Today I check where todays backup is and I find literally 100s of backups spanning over a period of 2 month in the user directory ?
Prior to splitting the db to BE HSQL 2.5 office crashed 3 or 4 times a day but this does not add up to hundreds of backups. Funny enough I also found several backups of my flightgear project which I never backed up because I use Github. But flightgear like office tends to crash frequently.
For now as I am in play learn mode the dbs consume hardly any space, but once the dbs grow that will eat up a fair bit of disk space.
Is this a bug, can other windows user do a search for 'backup' on their machines to check if there is an accumulation as well.
Maybe its just my laptop,but I am puzzled, anything I can check in the script file?

Re: Strange number of backups on WIN10 machine

PostPosted: Sat Aug 31, 2019 12:24 pm
by Villeroy
From time to time I delete those backups to trash bin. This stops when your database is finished and you start using it without adding queries, forms and reports. Are those gaming files really database documents? Can you open them with a zip tool. If not, they are something else with the same .odb name extension. All office documents are zipped XML.

Re: Strange number of backups on WIN10 machine

PostPosted: Sat Aug 31, 2019 4:48 pm
by UnklDonald418
I have adopted the habit of checking the directory shown at Tools>Options>Paths>Backups whenever I experience a crash in OO especially when it involves an open Base document. It appears that the crashes often occur in a loop that creates backup files.
After a recent crash I found 5144 empty .odb files. I recall some cases where there were many more than that.
As Villeroy advised, just delete them.

Re: Strange number of backups on WIN10 machine

PostPosted: Sat Aug 31, 2019 9:29 pm
by gkick
Thank you both for your replies. A Villeroy, Flightgear uses a combination of xml and nasal as programming languages, but no I can not open the files, sometimes there is no extension shown, sometimes with base backups as well the filesize shows up as 0 and based on UnclDonalds post I ll add it to the category of house keeping. Just as a matter of curiousity does this happen on Ubuntu or Macs as well?