Page 1 of 1

AOO 4.0 new MySQL native driver 1.2.0 version

PostPosted: Tue Jul 23, 2013 8:08 pm
by r4zoli
The changes in AOO 4.0 caused that the new MySQL SDBC driver needs for AOO 4.0, version.

(STLport library is removed in 4.0.0 With this change, C++ extension built for previous versions don't work anymore
in Windows, MacOS and Linux 32 bit (this affects only 32 bit arch., Linux 64 bit is not affected).

Thanks to Ariel, the new sdbc driver 1.2.0 available, you can download it from: http://code.google.com/a/apache-extras. ... loads/list

Re: AOO 4.0 new MySQL native driver 1.2.0 version

PostPosted: Thu Jul 25, 2013 9:25 pm
by Greengiant224
r4zoli posted:
Thanks to Ariel, the new sdbc driver 1.2.0 available, you can download it from: http://code.google.com/a/apache-extras. ... loads/list


Firefox is reporting that this link is 'untrustworthy'.

aoo-my-sdbc.apache-extras.org.codespot.com uses an invalid security certificate.

The certificate is only valid for the following names:
*.googlecode.com , *.code.google.com , *.codespot.com , *.googlesource.com , *.u.googlecode.com , googlecode.com , googlesource.com

(Error code: ssl_error_bad_cert_domain)


This site is trying to identify itself with invalid information.

Is there an alternative 'clean' download site available?

 Edit: Solved, Just found the link that works, for all operating systems

http://extensions.openoffice.org/en/node/5644#releases 


Greengiant224 was :crazy:, now :bravo:

Re: AOO 4.0 new MySQL native driver 1.2.0 version

PostPosted: Fri Nov 08, 2013 11:15 pm
by hpb1963
Hi,

I have just installed Openoffice 4.01 and the driver 1.2.0 unfortunately the connection forces the input of a database password, as I don't use a database password during development I of course
introduced via phpmyadmin a new user with password, result the connection fails.

Now I wonder what can be done to get this to work.

I tried to connect using ODBC, that works fine, except after I made the first table with base, the table does not show up anymore after closing and then opening base again.

For local development I use Wamp.

I would appreciate any pointer in the wright direction.

Regards

Re: AOO 4.0 new MySQL native driver 1.2.0 version

PostPosted: Tue Jul 01, 2014 11:15 pm
by Steve R.
I recently upgraded to Ubuntu 14.04 which also updated LibreOffice to version 4.2.4.2. The Base native connection to MYSQL failed. Evidently there is a bug.

libreoffice Mysql connector fails over network

See this Ask LibreOffice post. What is wrong with my native mysql connection?. Currently there is NO answer.

Additional MYSQL extensions are located here: https://code.google.com/a/apache-extras ... /Downloads
The previous version 1.1.0 works with OfficeLibre version 4.2.4.2. However, the current version (1.2.0) does not work with LibreOffice.
This version appears to require that OpenOffice 4.X be installed. So, I assume that if you have OpenOffice that you are "safe".

Another work around is located here MySQL Connector for OpenOffice.org 1.0.1