[Solved] Can't add photos to database

Discuss the database features

[Solved] Can't add photos to database

Postby 63 Spartan » Sat Mar 20, 2021 12:51 pm

I've created a database in OpenOffice 4.1.9 which includes a photo. When I enter photos into the database I get so far and then I get a message saying:

SQL Status: S1000
Error code: 40
S1000 General error java.lang.NullPointerException in statement [UPDATE "Members" SET "Photo" = ? WHERE "ID" = ?]

How can I correct this problem. At the present time the database is only about 1.3 MB.

Thanks in advance.
Last edited by 63 Spartan on Sun Mar 21, 2021 8:20 pm, edited 1 time in total.
OpenOffice 4.1.9 Windows 10
63 Spartan
Posts: 1
Joined: Sat Mar 20, 2021 12:42 pm

Re: Can't add photos to database

Postby floris v » Sat Mar 20, 2021 1:03 pm

You can try the suggestion in https://ask.libreoffice.org/en/question ... e-code-40/ - basically you don't include the pictures in the embedded database at all, or you keep them in a split database file.
AOO 4.1.6 op Linux Mint
If your problem has been solved or your question has been answered, please edit the first post in this thread and add [Solved] to the title bar.
Nederlandstalig forum
User avatar
floris v
Posts: 4252
Joined: Wed Nov 28, 2007 1:21 pm
Location: Netherlands

Re: Can't add photos to database

Postby UnklDonald418 » Sat Mar 20, 2021 5:14 pm

If your problem has been solved, please edit this topic's initial post and add "[Solved]" to the beginning of the subject line
Apache OpenOffice 4.1.8 & LibreOffice - Windows 10 Professional
Posts: 1397
Joined: Wed Jun 24, 2015 12:56 am
Location: Colorado, USA

Return to Base

Who is online

Users browsing this forum: No registered users and 2 guests