AOO 4.1.9 does not recognize the JRE

Discuss the database features

AOO 4.1.9 does not recognize the JRE

Postby bhainke@gmail.com » Sat Mar 06, 2021 11:43 pm

 Edit: Split from [Solved] JRE Errors since that topic is solved, and any new questions require new topics.
"Has this problem solved?" Yes, Tron marked it solved about ten years ago. Look at the bottom of their first post. 
Has this problem solved? I have read on many forums that Windows 10 64-bit, and AOO 32-bit require JRE 32-bit. I HAVE 32-BIT installed (I am 1000% sure of it), but AOO 4.9.1 does not recognize the JRE. I go to options/Java and try to add ANY java version but it says "the folder does not contain a Java Runtime Environment. Also, the error persists whether I have Microsoft Visual C++ 2010 x86 installed or not.
OpenOffice 4.1 on Windows 10
bhainke@gmail.com
 
Posts: 3
Joined: Sat Mar 06, 2021 11:37 pm

JRE not found; I'm giving up

Postby bhainke@gmail.com » Sat Mar 06, 2021 11:49 pm

 Edit: Split from Another one with "JRE not found" and nothing works
Locked because this is a duplicate of Topic 104699 
Yeah, I have a similar problem with Base. I have AOO4.1.9, WIN10 64-bit, JRE8 32-bit. and it doesn't work. restarting doesn't work. nothing works. all the forums say to install the 32-bit version. I think Apache has made it clear that we need the 32-bit version of Java from Oracle. I'm giving up and paying Microsoft for a subscription... very frustrated.
OpenOffice 4.1 on Windows 10
bhainke@gmail.com
 
Posts: 3
Joined: Sat Mar 06, 2021 11:37 pm

Re: [Solved] JRE Errors

Postby UnklDonald418 » Sun Mar 07, 2021 1:21 am

If you have the 32bit Java installed
Select Tools>Options>OpenOffice>Java to open the Java options dialog
Click the Add button
In the popup dialog navigate to the directory where Java was installed, the default location for Windows is C:/Program Files(x86)/Java
You should see at least one folder named something like jre1.8.0_281 If you don't find that folder then you either don't have 32bit Java properly installed or you installed it somewhere else.
select that folder and click OK
The jre1.8.0_xxx folder should now be in the list of JRE already installed.
select the option button at the left of the line with the most recent version of Java (281 if you are up to date)
Click OK to close the Java options dialog.
If your problem has been solved, please edit this topic's initial post and add "[Solved]" to the beginning of the subject line
Apache OpenOffice 4.1.8 & LibreOffice 6.4.7.2 - Windows 10 Professional
UnklDonald418
Volunteer
 
Posts: 1396
Joined: Wed Jun 24, 2015 12:56 am
Location: Colorado, USA

Re: Another one with "JRE not found" and nothing works

Postby John_Ha » Sun Mar 07, 2021 1:59 am

bhainke@gmail.com wrote:I have a similar problem with Base. I have AOO4.1.9, WIN10 64-bit, JRE8 32-bit. and it doesn't work.

Correct - Windows AOO needs 32-bit Java. This is my Tools > Options > OpenOffice > Java. Is yours the same? Try uninstalling and reinstalling Java.

Clipboard01.gif

LibreOffice uses 64-bit Java - you could try LO instead of AOO. In LO it is Tools > Options > LibreOffice > Advanced.
LO 6.4.4.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 8376
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: AOO 4.1.9 does not recognize the JRE

Postby bhainke@gmail.com » Sun Mar 07, 2021 6:16 am

Unfortunately, when clicking add and selecting C:/Program Files (x86)/Java/jre1.8.0_281 i get the following error "The folder does not contain a Java runtime environment. Please select a different folder." I have 32-bit Java installed; I downloaded jre-8u281-windows-i586 from https://java.com/en/download/manual.jsp by choosing the "Windows offline" link here https://javadl.oracle.com/webapps/downl ... 7658ca1605
Thanks
OpenOffice 4.1 on Windows 10
bhainke@gmail.com
 
Posts: 3
Joined: Sat Mar 06, 2021 11:37 pm

Re: AOO 4.1.9 does not recognize the JRE

Postby Zizi64 » Sun Mar 07, 2021 8:22 am

Your link points to the download page of the JDK (Java Development Kit). But the AOO needs the JRE (Java Runtime Environment). The JRE (of the Oracle) is not available today because the licence of the Java was changed in the year 2018.

I am using the LibreOffice without Java, because the developers decreased the java dependency of the LO to a minimal level.
The Java dependency of the Apache OpenOffice was not changed since 2018.
Tibor Kovacs, Hungary; LO6.1.6, 6.4.7 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-7.1.1;AOO4.1.9
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 9840
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: AOO 4.1.9 does not recognize the JRE

Postby Hagar Delest » Sun Mar 07, 2021 11:27 am

Topics merged. Please don't multipost.
LibreOffice 7.0.5 on Xubuntu 21.04 and 7.0.5 portable on Windows 10
User avatar
Hagar Delest
Moderator
 
Posts: 29748
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: AOO 4.1.9 does not recognize the JRE

Postby merlijn » Mon Mar 08, 2021 8:21 am

As an alternative to Oracle's Java you can download a JRE from AdoptOpenJDK, it's open source and free

https://adoptopenjdk.net/releases.html

choose operating system windows, architecture x86 and pick the JRE msi, it's size is 26MB.

After installing the JRE you can choose the JRE in AOO.
OpenOffice 4.1.6 on Windows 10 x64
merlijn
 
Posts: 29
Joined: Mon Jun 11, 2018 8:29 pm

Re: AOO 4.1.9 does not recognize the JRE

Postby UnklDonald418 » Wed Mar 10, 2021 5:40 am

Actually JRE is still available from Oracle at no charge for personal and development use.
https://www.java.com/en/download/manual.jsp
Select Windows Offline to download the installation wizard.
If your problem has been solved, please edit this topic's initial post and add "[Solved]" to the beginning of the subject line
Apache OpenOffice 4.1.8 & LibreOffice 6.4.7.2 - Windows 10 Professional
UnklDonald418
Volunteer
 
Posts: 1396
Joined: Wed Jun 24, 2015 12:56 am
Location: Colorado, USA

[ Solved ]Re: AOO 4.1.9 does not recognize the JRE

Postby Bruce114 » Sat May 01, 2021 9:00 pm

I have AOO 4.1.9 and guess what it no longer recognizes the JRE. I Updated everything the 32 and 64 bit JRE, Updated AOO 4.1.9, but cannot access my database. Keeps saying "does not contain a Java runtime environment". I tried using the https://adoptopenjdk.net/releases.html version and it is not recognized either. I have it installed on two different computers. Neither works.

I installed "Libreoffice", with some apprehension, and it uses the 64 bit version of the JRE. I was able to access my database with it.
Last edited by Bruce114 on Sun May 02, 2021 4:29 pm, edited 1 time in total.
Open Office 4.1 on Windows 7
Bruce114
 
Posts: 1
Joined: Sat May 01, 2021 8:47 pm

Re: AOO 4.1.9 does not recognize the JRE

Postby Greengiant224 » Sat May 01, 2021 11:33 pm

There has been some update to Java and AOO 4.1.9 (nor 4.1.6/4.1.7) does not recognise Java v1.8.xxx.

Try and find Java v1.7.xxx 32 bit and all should work.

Greengiant224

Win 7, AOO 4.1.6 Portable, LibreOffice 6.1.* & 7.0.1 (Java 1.7.81 & 1.8.0_281) utilising HSQL 1.8.10 & 2.4.*, MySQL, PostgreSQL, SQLite
+ Blood, Sweat and Tears (Application, Determination and Perseverance)
User avatar
Greengiant224
 
Posts: 277
Joined: Wed Jun 09, 2010 3:50 pm
Location: All Over The World

Re: AOO 4.1.9 does not recognize the JRE

Postby FJCC » Sat May 01, 2021 11:42 pm

I use 1.8_281. I am currently using 4.1.10 (the RC2 version) but the same JRE worked with 4.1.9.
JRE.PNG
JRE.PNG (8.5 KiB) Viewed 2036 times
Windows 10 and Linux Mint, since 2017
If your question is answered, please go to your first post, select the Edit button, and add [Solved] to the beginning of the title.
FJCC
Moderator
 
Posts: 8114
Joined: Sat Nov 08, 2008 8:08 pm
Location: Colorado, USA

Re: AOO 4.1.9 does not recognize the JRE

Postby Villeroy » Sun May 02, 2021 3:03 pm

There used to be a glitch with AOO's Java dialog. To select a Java installation, you had to select the radio button in the list, the round circle left of "Oracle" in FJCC's screenshot. Selecting the list entry without activating the radio button did not activate the Java version.

This is just another issue which had been fixed in LibreOffice where the selected Java entry just works even when the radio button remains unselected.
Attachments
Bildschirmfoto vom 2021-05-02 14-59-56.png
Selected Java in LO6
Bildschirmfoto vom 2021-05-02 14-59-56.png (10.25 KiB) Viewed 1983 times
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04 with LibreOffice 6.0, latest OpenOffice and LibreOffice
User avatar
Villeroy
Volunteer
 
Posts: 29711
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany


Return to Base

Who is online

Users browsing this forum: No registered users and 7 guests