Strange behavior when editing formulas

Discuss the formula editor

Strange behavior when editing formulas

Postby 22878 » Thu Jul 16, 2020 4:13 am

If I double click on a formula to edit it, while the edit window is open, the document window scrolls up and down. It will scroll up a little then back down then back up etc. When I close the formula editor and look at the undo history. There are lots of object style changes. If I click crtl + z to undo them, the formula changes shape as if the size and/or shape had been changed a lot of times. Any idea why it does this? It does it every time I edit a formula.
OpenOffice 4.1.5 on Windows 10
22878
 
Posts: 20
Joined: Tue Jul 07, 2020 1:02 am

Re: Strange behavior when editing formulas

Postby Zizi64 » Thu Jul 16, 2020 5:50 am

If I double click on a formula to edit it, while the edit window is open, the document window scrolls up and down.

It seems a problem related to the keyboard, or to the mouse or to the touchpad.

Please try it with a portable version of the LibreOffice. If the problem is same, then it is a hardware (or driver) problem.
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.5;AOO4.1.7
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 9590
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Strange behavior when editing formulas

Postby 22878 » Thu Jul 16, 2020 6:16 am

Zizi64 wrote:
If I double click on a formula to edit it, while the edit window is open, the document window scrolls up and down.

It seems a problem related to the keyboard, or to the mouse or to the touchpad.

Please try it with a portable version of the LibreOffice. If the problem is same, then it is a hardware (or driver) problem.


I'm using a wireless mouse and keyboard. If I click to open the formula editor then turn off the power of my keyboard and mouse it continues to scroll. Does that not indicate that it's not that causing it?
OpenOffice 4.1.5 on Windows 10
22878
 
Posts: 20
Joined: Tue Jul 07, 2020 1:02 am

Re: Strange behavior when editing formulas

Postby Zizi64 » Thu Jul 16, 2020 6:23 am

try it with an another (usb) keyboard and mouse.
and try the LibreOffice.
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.5;AOO4.1.7
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 9590
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Strange behavior when editing formulas

Postby 22878 » Thu Jul 16, 2020 7:59 am

Zizi64 wrote:try it with an another (usb) keyboard and mouse.
and try the LibreOffice.


I tried it on my laptop and it doesn't do it. Is there anyway to fix this? My mouse and keyboard don't cause issues like this with any other program.
OpenOffice 4.1.5 on Windows 10
22878
 
Posts: 20
Joined: Tue Jul 07, 2020 1:02 am

Re: Strange behavior when editing formulas

Postby Zizi64 » Thu Jul 16, 2020 10:26 am

Is there anyway to fix this?


I do not know it. It is your PC. You must try the LibreOffice on your PC.

And you can try a wired keyboard and mouse.
And you can try to reset the user profile of the AOO.
Or you can try to fully (clean) reinstall the AOO.
Or you can reinstall the drivers.
Or you can reinstall the Windows.


I never experienced such problem with AOO nor LO. But I never used any wireless keyboard and mouse.
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.5;AOO4.1.7
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 9590
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Strange behavior when editing formulas

Postby Lupp » Thu Jul 16, 2020 11:49 am

BTW: I'm using a wireless keyboard/mouse couple for years now, and never experienced something like the described behavior - neither with AOO nor with LibO.

Also: This should only occur in Writer - and can not occur if Math is used independently. (Can it?)
On Windows 10: LibreOffice 7.0 and older versions, PortableOpenOffice 4.1.7 and older, StarOffice 5.2
---
Lupp from München
User avatar
Lupp
Volunteer
 
Posts: 2929
Joined: Sat May 31, 2014 7:05 pm
Location: München, Germany

Re: Strange behavior when editing formulas

Postby 22878 » Thu Jul 16, 2020 8:26 pm

Lupp wrote:BTW: I'm using a wireless keyboard/mouse couple for years now, and never experienced something like the described behavior - neither with AOO nor with LibO.

Also: This should only occur in Writer - and can not occur if Math is used independently. (Can it?)


It only happens in Writer and not in Math. If I use the formula editor in Writer where it opens at the bottom of the window, that's when it happens.
OpenOffice 4.1.5 on Windows 10
22878
 
Posts: 20
Joined: Tue Jul 07, 2020 1:02 am

Re: Strange behavior when editing formulas

Postby Zizi64 » Fri Jul 17, 2020 6:23 am

It only happens in Writer and not in Math. If I use the formula editor in Writer

The formula editor _is_ the Math application - called from the Writer application.
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.5;AOO4.1.7
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 9590
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Strange behavior when editing formulas

Postby 22878 » Fri Jul 17, 2020 6:37 am

Zizi64 wrote:
It only happens in Writer and not in Math. If I use the formula editor in Writer

The formula editor _is_ the Math application - called from the Writer application.


Well, it only happens when called in Writer and not when I just have the Math window open outside of Writer. Also, it seems like it only happens in the web layout view, which is what I normally use. In the print layout it doesn't seem to do it.
OpenOffice 4.1.5 on Windows 10
22878
 
Posts: 20
Joined: Tue Jul 07, 2020 1:02 am

Re: Strange behavior when editing formulas

Postby Zizi64 » Fri Jul 17, 2020 6:50 am

Have you tried the LibreOffice? If that is works fine, then the problem is in the AOO or in the settings of the AOO.
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.5;AOO4.1.7
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 9590
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Strange behavior when editing formulas

Postby keme » Sat Jul 18, 2020 1:43 pm

Is there a docked toolbar which is context sensitive, so it is enabled/disabled by your actions? This will often make the content pane jump up and down a bit. I can't find any situation where this would happen in Math, whether standalone or called from other application.

Could also be some rendering issue in the web view. Not sure how size/placement/wrap is handled to adjust for web page rendering. Do you see any major reflowing of the document content outside the formula while you work with it?
User avatar
keme
Volunteer
 
Posts: 3383
Joined: Wed Nov 28, 2007 10:27 am
Location: Egersund, Norway


Return to Math

Who is online

Users browsing this forum: No registered users and 2 guests