How to make a text "tm" symbol a superscript?

Discuss the drawing application

How to make a text "tm" symbol a superscript?

Postby david7365 » Fri Feb 08, 2019 2:54 pm

I'm drawing a simple text logo: NSR™ . Note the "tm" symbol at the right end, almost correctly positioned in this forum as a superscript.

When I use OO > Draw > Text to enter this string, it positions the "tm" symbol slightly above the baseline, vertically. If I now select the "tm" symbol and click OO > Draw > Format > Character... > Position > Superscript, the "tm" symbol doesn't move! It stays slightly above the baseline, vertically.

But I want the "tm" symbol to be in the usual place: at the top right of the logo.

I've tried changing all sorts of internal parameters and can only get the symbol to move up to about half the character height. I want to position it in the usual superscript position, at the top of the characters.

I've searched the Web, and no one has reported this as a problem. What am I misunderstanding? :?:
david7365
 
Posts: 28
Joined: Thu Mar 22, 2012 8:59 pm

Re: How to make a text "tm" symbol a superscript?

Postby John_Ha » Fri Feb 08, 2019 2:58 pm

Please upload a small file showing the problem so that it can be analysed.
LO 6.3.5.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 7706
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: How to make a text "tm" symbol a superscript?

Postby keme » Fri Feb 08, 2019 3:21 pm

The TM character is sized differently depending on which font face you use. I find that it generally appears too large. In Tahoma and Verdana it is visibly less than half heigth, but others that I have tried have too large TM glyphs for my liking. Superscripting a glyph which is already a superscript is rarely a good idea.

Workaround: Try to type TM with letters and format that as superscript. If it does not come out right, try to adjust the default settings. I find that size between 30%-40% and displacement 50%-60% give satisfactory results.
Note that this is only a visual workaround. If you need the document to contain the TM character itself, you can insert that as an object property for your text box.
User avatar
keme
Volunteer
 
Posts: 3343
Joined: Wed Nov 28, 2007 10:27 am
Location: Egersund, Norway


Return to Draw

Who is online

Users browsing this forum: No registered users and 3 guests