[Solved+Issue] Data missing when copy & paste selected data

Discuss the drawing application

[Solved+Issue] Data missing when copy & paste selected data

Postby LJL_Houben » Mon Nov 16, 2020 10:33 am

Hello All

Maybe I do something wrong, but when I select some/all data from a drawing and I copy it to be used within an other program, then items are missing. Is this a setting? How to solve this?
See image below, left is 'MS paint' right is 'LibreOffice'. I have this with multiple locations, images, the location what is missing and it is regardless of the programm I use to paste to.
Thanks in advance for a solution

Grtz

Ludo

Untitled2.jpg



PS: Why is the image limit so low?
Last edited by Hagar Delest on Thu Dec 10, 2020 5:13 pm, edited 1 time in total.
Reason: tagged solved.
Win10 / LibreOffice 7.0.3.1
LJL_Houben
 
Posts: 8
Joined: Mon Nov 16, 2020 10:17 am

Re: Data missing when copy & paste selected data

Postby Zizi64 » Mon Nov 16, 2020 11:02 am

PS: Why is the image limit so low?


Do you mean the file size limit of this forum?

You can optimize the images with a third party image magager software (like the free IrfanView) before you upload them here.
- Decrease the color depth: 256, 128 or sometimes even 64 colors enough for the screenshots.
- Decrease the resolution
- Crop the irrelevant part of the image
- Use a lossless compression (PNG) with a high compression ratio.
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.5;AOO4.1.7
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 9704
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Data missing when copy & paste selected data

Postby Zizi64 » Mon Nov 16, 2020 11:07 am

What line width value are you using for the line that is invisible in the Paint?
Have you selected the whole line before you copiet it?
Have you tried to export the image into some image format, instead of copy-paste into the Paint?

Can you upload an .odg type sample file here?
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.5;AOO4.1.7
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 9704
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Data missing when copy & paste selected data

Postby LJL_Houben » Mon Nov 16, 2020 7:35 pm

Hi ZiZi64

I selected all lines in the supplied image. All lines (arrows) are the same line-type (smalest). As I already mentioned it is 'random'. In other drawings I copied e.g. a rectangle and the bottom part of the rectangle is not copied to the clipboard but the rest is. For my 'feeling' it is always the 'most right' and 'most bottom' lines that are missing. I did not try to export the image into other formats (yet).
Win10 / LibreOffice 7.0.3.1
LJL_Houben
 
Posts: 8
Joined: Mon Nov 16, 2020 10:17 am

Re: Data missing when copy & paste selected data

Postby Bidouille » Fri Nov 27, 2020 12:43 pm

Twice:
Zizi64 wrote:Can you upload an .odg type sample file here?
User avatar
Bidouille
Volunteer
 
Posts: 407
Joined: Mon Nov 19, 2007 10:58 am
Location: France

Re: Data missing when copy & paste selected data

Postby keme » Sat Nov 28, 2020 2:53 pm

I have seen this before in a couple of versions of the suite, when converting from vector to pixelmap format. I can't reproduce the problem now, using either LibreOffice version 6.4.4 or 7.0.3, nor with OpenOffice Draw versions 4.1.5 and 4.1.8.

I suggest upgrading to one of the current LO versions (6.4.7 or 7.0.3). Can't promise that it will solve the issue, but worth a try.

Also, if some of your lines are on a locked layer, they will not be selected, so not copied, and then can not be pasted. Probably not the issue in this case, but impossible to say for sure until we see that uploaded odg file...
User avatar
keme
Volunteer
 
Posts: 3400
Joined: Wed Nov 28, 2007 10:27 am
Location: Egersund, Norway

Re: Data missing when copy & paste selected data

Postby LJL_Houben » Sat Nov 28, 2020 2:58 pm

Bidouille wrote:Twice:
Zizi64 wrote:Can you upload an .odg type sample file here?


I will post next week the file as it is a file from work.
With kind regards

Ludo
Win10 / LibreOffice 7.0.3.1
LJL_Houben
 
Posts: 8
Joined: Mon Nov 16, 2020 10:17 am

Re: Data missing when copy & paste selected data

Postby LJL_Houben » Sat Nov 28, 2020 3:01 pm

keme wrote:I have seen this before in a couple of versions of the suite, when converting from vector to pixelmap format. I can't reproduce the problem now, using either LibreOffice version 6.4.4 or 7.0.3, nor with OpenOffice Draw versions 4.1.5 and 4.1.8.

I suggest upgrading to one of the current LO versions (6.4.7 or 7.0.3). Can't promise that it will solve the issue, but worth a try.

Also, if some of your lines are on a locked layer, they will not be selected, so not copied, and then can not be pasted. Probably not the issue in this case, but impossible to say for sure until we see that uploaded odg file...


It's definitly not an layer issue, but its a good suggestion. I will look which version which we use at work and upgrade it to the latest version. It somehow sees always to be the most 'right' or most 'bottom' line though :-)

Regards,

Ludo
Last edited by LJL_Houben on Thu Dec 10, 2020 12:34 pm, edited 1 time in total.
Win10 / LibreOffice 7.0.3.1
LJL_Houben
 
Posts: 8
Joined: Mon Nov 16, 2020 10:17 am

Re: Data missing when copy & paste selected data

Postby LJL_Houben » Thu Dec 10, 2020 11:52 am

Hi all

Sorry for the late reaction :oops: somehow busy at work...
I checked my version of LibreOffice, it was 6.4.6 (LibreOffice_6.4.6_Win_x64.msi). Attached a sample file.
I'm now upgrading to the latest verion (LibreOffice_7.0.3_Win_x64.msi) and will re-test this.

Regards

Ludo
Attachments
MissingLine-Example.odg
Example file for the missing line issue
(10.88 KiB) Downloaded 15 times
Win10 / LibreOffice 7.0.3.1
LJL_Houben
 
Posts: 8
Joined: Mon Nov 16, 2020 10:17 am

Re: Data missing when copy & paste selected data

Postby LJL_Houben » Thu Dec 10, 2020 12:34 pm

Just tested it with the latest version of LibreOffice, but unfortunally the issue is not solved. See attached a second example which was created with the latest version. I copied/pased it from my existing file to a new file within LibreOffice and all selected items were transferred as expected. However when copy & pasting all from the attached second example into MS Paint, then the line on the right side was missing complete. As it was also seen in the older version.
Attachments
MissingLine-Example2.odg
(14.05 KiB) Downloaded 20 times
Win10 / LibreOffice 7.0.3.1
LJL_Houben
 
Posts: 8
Joined: Mon Nov 16, 2020 10:17 am

Re: Data missing when copy & paste selected data

Postby Zizi64 » Thu Dec 10, 2020 2:57 pm

The line width is 0.00 mm. Use a higher thickness value or use an invisible helper object ouside of the older selected area. Select the helper objects together with the other objects. Then the whole "line width" will be located inside of the selected area.

I have used a visible helper object:

linewidth.png
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.5;AOO4.1.7
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 9704
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Data missing when copy & paste selected data

Postby LJL_Houben » Thu Dec 10, 2020 3:54 pm

I just tested it with all lines with a width of 1,0 pt, but no improvement.
I will test it again with the 'work around' with a 'invisible' helper, but I also am going to create a bug for it. I found several of the same issues described within StackOverflow from years ago. So it looks like a 'feature' that needs to be corrected.

Thanks for the help

Ludo
Win10 / LibreOffice 7.0.3.1
LJL_Houben
 
Posts: 8
Joined: Mon Nov 16, 2020 10:17 am

Re: Data missing when copy & paste selected data

Postby LJL_Houben » Thu Dec 10, 2020 4:17 pm

Found an older entry in the 'buglist'. I reopened this issue as the bug is either re-introduced and/or not completely solved for all platforms. Here is a link to the bug:
https://bugs.documentfoundation.org/sho ... ?id=107984

I will have to work with the 'workaround' mentioned by Zizi64 (This works, so thanks for the suggestion) and hope they will solve it soon :-)
Regards


Ludo
Win10 / LibreOffice 7.0.3.1
LJL_Houben
 
Posts: 8
Joined: Mon Nov 16, 2020 10:17 am

Re: [Solved+Issue] Data missing when copy & paste selected d

Postby keme » Sun Dec 13, 2020 4:39 am

Now I get it too, from all the versions I previously didn't.

Sorry about my comment that bug can't be reproduced. I was clearly doing something wrong to make it right. Can't reproduce that now. :shock:

IOW: Bug confirmed.
User avatar
keme
Volunteer
 
Posts: 3400
Joined: Wed Nov 28, 2007 10:27 am
Location: Egersund, Norway


Return to Draw

Who is online

Users browsing this forum: No registered users and 2 guests