Page 1 of 1

Draw: Quick Layer Visibility Erratic

PostPosted: Thu May 12, 2016 2:32 pm
by LeVraiNinjaneer
Hi there

I really like OpenOffice Draw and I keep trying to get better at using it to solve many of my graphical challenges.

I recently had a challenge where I needed to "design" a multi-level floorplan, and I found that the usage of Layers in OOD is suitable for this. I was lucky to discover by accident that layer visibility can be toggled by "Shift" + clicking on the layer on the layer tab at the bottom of the screen.

However, when one toggles the visibility of any layer, the tab at the bottom of the screen auto-adjusts so that the active layer (visible or not) will be on the right of the of the tab. This behaviour can be quite disorientating. I would propose that auto-adjusting of that tab does not happen at all.

(Please let me know if I chose the wrong board for this post)

Best regards

Re: Draw: Quick Layer Visibility Erratic

PostPosted: Thu May 12, 2016 3:23 pm
by B Marcelly
Hi,
You have to create an Issue describing your request for improvement. And perhaps it will be added in the future (if a developer is interested).
To create an issue : https://bz.apache.org/ooo/

Re: Draw: Quick Layer Visibility Erratic

PostPosted: Thu May 12, 2016 4:27 pm
by acknak
Sorry, I'm not sure I understand what you're doing/looking for.

I don't see any change in the tabs when I use Shift+click to toggle the visibility. There's no change in the order of the layer tabs, and no change in which tab is selected.

Re: Draw: Quick Layer Visibility Erratic

PostPosted: Thu May 12, 2016 4:51 pm
by LeVraiNinjaneer
Ah, OK. I suppose I could have been more clear.

This will only really come into play when you have enough layers that you can scroll through them.

Let say I have 10, all named as "Layer 1", "Layer 2", "Layer 3", but I can only see the "tabs" (Layers) at the bottom for only 5 of the ten at any given time because my screen is only so wide and there's the normal horizontal scroll bar to contend with for space. Let's also assume they are in order 1 to 10 from left to right.

So, now I have Layers 1, 2 and 9 visible. I'm working on level 9 (it is the active layer), and I decide that I no longer want Layer 1 and 2 visible, but I do want 3 and 10 visible.

Currently, Layers 1 to 5 are visible on the tab, but should I want to, I can scroll to see 6 to 10, or any view inbetween.

I shift-click Layer 1 to make it invisible. Now my tab view will auto-adjust to show the active Layer (Layer 9 in this case) on the right, therefore I'll see 5 to 9. Now I want to hide Layer 2, so I need to scroll to the left again until I see Layers 2 to 6. Shift-Click it and I'll jump back to seeing 5 to 9. Now I scroll one right to make 10 Visible. Again I'll be taken back to 5 to 9. I scroll one right to make 10 active (normal left-click). I now scroll to Layer 3, make it visible. Tabs auto-adjust to show 6 to 10.

Perhaps your version does not behave this way?

Re: Draw: Quick Layer Visibility Erratic

PostPosted: Thu May 12, 2016 6:07 pm
by acknak
I don't think I have any drawings with enough layers to see it ;-)

I'll have to play around, but I expect I'll find the same thing: the way OO Calc handles the tabs is quite awkward as well.

One thing that may help is to give the tabs more room. Between the tab area and the scrollbar is a divider. Click on it and drag to the right. With more room, the problem you're describing may not be quite so distracting.

Unfortunately, the layout is not preserved between sessions.

I think it's possible turn off the scrollbar(s) but I don't remember how, at the moment.