Page 1 of 1

[Solved] Math formula editor frezees after upgrading to 3.5

PostPosted: Wed Feb 15, 2012 2:59 pm
by silvandy
I upgraded today to release 3.5, from 3.4.5 on a windows 7 notebook. Since then Math formula editor is not working anymore.

Steps to reproduce:
1. open a writer document, new or existing
2. insert a Math formula object anywhere
3. The grey rectangle that should contain the equation on the page appears, and menus are transformed into those relevant to equation editor.
However, the subwindow that should appear on the screen below the document, in which you enter and edit the equation code, does NOT appear anymore, and nothing
(numbers, letters symbols, whatever) can be inserted in the equation, even using the special objects window. You can see the objects windows, but when you
click on any object (e.g. a sum or an integral symbol) nothing happens. It is the same with the Greek letter insertion window.

WHAT IS WORSE, after uninstalling 3.5 and reverting back to 3.4.5, the math equation editor REMAINS BROKEN!!! It behaves exactly as described.
If you work in a context where you write many math equations, this means that Libreoffice is COMPLETELY UNUSABLE.
Alas I had no choice but to revert to Openoffice 3.3.
Notice that:
- until this morning, with any version of Libreoffice, I never experienced this problem
- if you open a math equation editor directly, instead of one embedded in writer, it is unusable just the same.
- If I run Libreoffice portable 3.3 from an USB memory stick, the math equation editor works fine, so I think it is not a hardware problem of my PC.

Any hint to what has gone horribly wrong would be greatly appreciated.... thank you.

Re: Math formula editor frezees after upgrading to 3.5 - PLE

PostPosted: Wed Feb 15, 2012 3:07 pm
by Villeroy

Re: Math formula editor frezees after upgrading to 3.5 - PLE

PostPosted: Wed Feb 15, 2012 5:40 pm
by silvandy
Thanks for the hint.
I have now restored the user profile, and the formula editor is working again.
However, it remains to be seen why the upgrade from 3.4.5. to release 3.5 caused the corruption, and if there is some other less drastic way to awake the
formula editor other than completely resetting your profile.

For some users who use LO just as it is by default, this could be a non-issue, but if you (like me) have heavily customized your L.O. install, with modified
and optimized toolbars for each app, hotkeys, etc., starting from scratch means replicating a LOT of effort, with the fear of having to do it again soon.

After fiddling a bit, I concluded that the single file registrymodifications.xcu keeps track of all customization: if I delete only this file from the user
profile, all toolbars etc. revert to the default ones, and Formula editor is working, while all the rest of the profile "user" folder is unchanged.

So now the problem is: what is the bit of registrymodifications.xcu that blocks the formula editor? I opened the file with the Notepad, but it is actually
difficult to see through it if you're not used too. And it is quite big too.
So I am attaching my guilty registrymodifications.xcu in case anyone knows how to check it and give hints on the issue.

PS: I have posted this contents as a bug report as well, as you suggested.

Re: Math formula editor frezees after upgrading to 3.5 - PLE

PostPosted: Wed Feb 15, 2012 7:56 pm
by hanya
It seems your configuration has problem on WindowState value of window 30378.
Remove specific nodes from your file or remove 30378 element under /org.openoffice.Office.Views/Windows configuration by macro.

Re: Math formula editor frezees after upgrading to 3.5

PostPosted: Thu Feb 16, 2012 1:42 am
by silvandy
I am deeply grateful for your bothering to help. However I am probably too inept and your suggestions are not fully clear to me. I searched for the number 30378 in the registrymodifications.xcu file, found one and only instance of it. in the string <node oor:name="30378" oor:op="replace">
However, I am quite unsure about what precisely I should remove: you say "specific nodes", does it mean that I should remove what I reported here, or more??
To help clarify things, Iet me report here the text following that single reference to 30378 for some lines:
<node oor:name="30378" oor:op="replace"><node oor:name="UserData"></node><prop oor:name="Visible" oor:op="fuse"><value xsi:nil="true"/></prop><prop oor:name="WindowState" oor:op="fuse"><value xsi:nil="true"/></prop></node></item><item oor:path="/org.openoffice.Office.Views/Windows"><node oor:name="30379" oor:op="replace"><node oor:name="UserData"><prop oor:name="Data" oor:op="fuse" oor:type="xs:string"><value>V2,V,0</value></prop></node><prop oor:name="Visible" oor:op="fuse"><value xsi:nil="true"/></prop><prop oor:name="WindowState" oor:op="fuse"><value>1165,87,,;1;,,,;</value></prop></node></item>
If you could tell exactly what should I remove of this, or if the part to be removed is even bigger, It would be very kind of you.

Your other suggestion to work "by macro", but again I do not really know how to proceed.
Any hint would be most welcome. Thanks

Re: Math formula editor frezees after upgrading to 3.5

PostPosted: Thu Feb 16, 2012 7:30 am
by hanya
Start your office, execute the following macro to remove the configuration and then restart your office.
This macro removes window position of math equation editor on Writer document to make its position default.
Code: Select all   Expand viewCollapse view
Sub RemoveMathEquationWindowSettings
  p = CreateUnoStruct("")
  p.Name = "nodepath"
  p.Value = "/org.openoffice.Office.Views/Windows"
  cp = CreateUnoService("")
  ca = cp.createInstanceWithArguments(_
    "", Array(p))
  name = "30378"
  If ca.hasByName(name) Then
  End If
End Sub

Re: Math formula editor frezees after upgrading to 3.5 [Solv

PostPosted: Thu Feb 16, 2012 11:45 am
by silvandy
That was a great piece of help.... it worked perfectly.
Of course I am left wondering why on earth the upgrade to 3.5 could induce this....
Thanks again

Re: [Solved] Math formula editor frezees after upgrading to

PostPosted: Mon Feb 20, 2012 3:09 am
by ncookit
Same issue here.
Upgrade to 3.5 broke Math editor.
Downgrade to 3.4.5 did nothing.
Uninstalling/reinstalling did nothing.

Followed instructions to rename /user folder to /user.old so all user profile info was recreated and now it works again.

Seems very very odd for this to have happened. I doubt noob users would be able to follow these instructions.
I'm on a Macbook now, but luckily I have Windoze and Linux experience.

Love this software suite, I'm now in teacher's college and in a high school teaching math so the formula editor is something I use daily. Really really hope this can be fixed soon and a incremental release made available before more people discover this issue.

That being said, I'm happy that this post has helped guide me to patching this right away so I can use it again before the permanent fix is released.