How to stop "auto recovery"

Help with installation and general system troubleshooting questions concerning the office suite LibreOffice.

How to stop "auto recovery"

Postby orgopenoffice1 » Sat Aug 20, 2011 12:01 pm

A lot of the time when I open a file screens come up asking if OO can recover files either in use or used previously.
I have never needed this "recovery". It is really annoying and time wasting (you need to tell it to cancel several times), how can I turn this "feature" off permanently?
Portable OpenOffice 3.2 xp
orgopenoffice1
 
Posts: 4
Joined: Sat Aug 20, 2011 11:34 am

Re: How to stop "auto recovery"

Postby Zizi64 » Sat Aug 20, 2011 12:49 pm

Hi,

A lot of the time when I open a file screens come up asking if OO can recover files either in use or used previously.

It is not a good news... The fact (launching with recovery option) indicates: the previously used files was not saved safely, or maybe they are corrupted, etc...

Have you work on a pendrive (Have you save usually your documents to a pendrive)?
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.5;AOO4.1.7
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 9602
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: How to stop "auto recovery"

Postby TheGurkha » Sat Aug 20, 2011 1:18 pm

Make sure you have saved your work and closed OOo before you turn off the computer.
Ubuntu 14.10 Utopic Unicorn, LibreOffice Version: 4.3.3.2
Gurkha Welfare Trust
User avatar
TheGurkha
Volunteer
 
Posts: 6482
Joined: Thu Mar 13, 2008 12:13 pm
Location: North Wales, UK.

Re: How to stop "auto recovery"

Postby orgopenoffice1 » Sat Aug 20, 2011 2:54 pm

Thanks for the suggestions, but neither helps.

There is never an issue with corruption, the only time I can remember when a file was corrupted (today actually) the "auto recovery" didn't work.

I haven't bothered to investigate the exact cause that triggers the "recovery" but it seems to be sometimes opening up a new OO file while other(s) are open in the background, the fact that the background files have not been saved doesn't appear to effect it.
Often I don't want to save trial changes to a file so saving everything before opening a new file is not an option.

Similarly saving before turning off the computer is often not an option nor much of a problem. Most of the time it tries to recover files that are already open.

The real question is how can I turn it off for ever. I will never want it, and the only time a recovery would have been useful it didn't work.
The really annoying thing is that it asks if I want to cancel and when I say yes, instead of canceling it asks more questions.
Last edited by orgopenoffice1 on Sat Aug 20, 2011 3:02 pm, edited 1 time in total.
Portable OpenOffice 3.2 xp
orgopenoffice1
 
Posts: 4
Joined: Sat Aug 20, 2011 11:34 am

Re: How to stop "auto recovery"

Postby Zizi64 » Sat Aug 20, 2011 3:00 pm

I see in your signature:
Portable OpenOffice 3.2 xp


My only one idea:
Try the full installed version of OOo/LibreOffice
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.5;AOO4.1.7
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 9602
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: How to stop "auto recovery"

Postby orgopenoffice1 » Sat Aug 20, 2011 3:05 pm

Thanks but definately not an option, I use multiple computers and only use portable applications, often on pendrives. Fortunately today almost everything can be done with non installed portable apps - the best thing since sliced bread.
Portable OpenOffice 3.2 xp
orgopenoffice1
 
Posts: 4
Joined: Sat Aug 20, 2011 11:34 am

Re: How to stop "auto recovery"

Postby RoryOF » Sat Aug 20, 2011 4:56 pm

Normally, if OpenOffice has all open files closed and is then exited, there should be no file recovery. File recovery takes place if OOo is exited with a file still open.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31543
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: How to stop "auto recovery"

Postby Bill » Sat Aug 20, 2011 5:09 pm

Files should always be closed before turning off the computer. While Windows will close the open files when turning off the computer, it won't do the housekeeping within OOo to let OOo know that the file was properly closed, so OOo tries to recover the file the next time it is opened.
Bill
Volunteer
 
Posts: 7918
Joined: Sat Nov 24, 2007 6:48 am

Re: How to stop "auto recovery"

Postby TheGurkha » Sat Aug 20, 2011 5:27 pm

Let me be more specific - you don't need to Save if you dont want the changes, but you have to close OOo cleanly.
Ubuntu 14.10 Utopic Unicorn, LibreOffice Version: 4.3.3.2
Gurkha Welfare Trust
User avatar
TheGurkha
Volunteer
 
Posts: 6482
Joined: Thu Mar 13, 2008 12:13 pm
Location: North Wales, UK.

Re: How to stop "auto recovery"

Postby orgopenoffice1 » Sat Aug 20, 2011 5:29 pm

Thanks RoryOF.
I think you may have hit on the problem. perhaps OO assumes that files are opened from within OO.
I virtually never open files from within OO, I use Totalcommander (a much improved version of explorer) to open files or templates. This means that there may be more than one instance of OO running which shouldn't be a problem for a well behaved programme.

And thanks to TheGurkha but I usually am opening new OO files but need to keep others open, so the others are not closed, cleanly or otherwise.

It comes down to the same thing. I need a way to turn the "recovery" thingy off.

There are usually Options in programmes to allow control of functions.
Portable OpenOffice 3.2 xp
orgopenoffice1
 
Posts: 4
Joined: Sat Aug 20, 2011 11:34 am

Re: How to stop "auto recovery"

Postby Zizi64 » Sat Aug 20, 2011 5:58 pm

I need a way to turn the "recovery" thingy off.

I think: There is no way to turn it off. You need use the OOo "regularly" to eliminate the recovery function...

But: If you can modify the (open)source code of OOo, then you can build an own version... ;)


Maybe it is a bug(?) in the portable version, or you have not enough memory on your pendrive, or your pendrive is damaged... etc...
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.5;AOO4.1.7
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 9602
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: How to stop "auto recovery"

Postby RoryOF » Sat Aug 20, 2011 6:11 pm

Just close down any open files and Recovery won't trouble you. This is standard good computer practice. If you haven't altered them, they will just Close using / File / Close with no prompt. If you have altered them, then you get a Save changes? prompt.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31543
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: How to stop "auto recovery"

Postby Bill » Sat Aug 20, 2011 9:36 pm

The recovery function isn't optional. Just select File > Exit in any open OOo file before turning off the computer.
Bill
Volunteer
 
Posts: 7918
Joined: Sat Nov 24, 2007 6:48 am

Re: How to stop "auto recovery"

Postby wijit » Wed Jun 13, 2012 4:30 pm

There are 2 buttons in the file recovery dialogue - "start recovery" and "cancel" and the 1st button is always pressed for the 1st time. If the result is "recovery failed" then "close" is clicked before normal processes run. Next open of OOo the dialogue will show again with the same file name. OOo does not remember that the file has been recovered but not success. Do not click "start recovery" as the result will be the same. Just click the "cancel" button and "yes" to get rid of the dialogue next opening of OOo. I'd like to suggest that file name(s) in the file recovery dialogue should come with full path for a user to have a chance to evaluate possibility of the recovery and decide to click "cancel".
OpenOffice 3.2.0 on Ubuntu 10.04
wijit
 
Posts: 2
Joined: Fri Feb 10, 2012 10:43 am

Re: How to stop "auto recovery"

Postby LinnetDigital » Sat Nov 24, 2012 2:08 pm

modifying the launch parameters to 'libreoffice --norestore' works for me on Linux - not sure about launching from total commander on Windows. I would guess there is an option to specify a launch string for the application
LibreOffice 3.5.4.2 Mint 13
LinnetDigital
 
Posts: 1
Joined: Sat Nov 24, 2012 2:01 pm

Re: How to stop "auto recovery"

Postby tverbeek » Wed Mar 13, 2013 4:44 am

This thread is a classic example of condescending non-answers to technical questions. Sorry, people but OO's auto-recovery "feature" is buggy. Has been for version after version. It's a damned nuisance, and someone asked - like I would like to know - how to disable it. But instead you give a bunch of insulting lectures about how they're using the program wrong. Because you're so damn smart and everybody else is an idiot who doesn't know how to use a computer. Get over yourselves. We're not. I use the program properly. I save my work properly. I close the program and the OS properly. And I still get this useless prompt to recover every document I was working on last time. I'd like to know how to disable it. You know, like any comprtently designed piece of software would allow you to do. If you don't know the answer, STFU, and let the silence demonstrate that there is no solution. Assholes.
tverbeek
 
Posts: 5
Joined: Wed Mar 13, 2013 4:34 am

Re: How to stop "auto recovery"

Postby Hagar Delest » Wed Mar 13, 2013 11:49 am

tverbeek wrote:This thread is a classic example of condescending non-answers to technical questions. Sorry, people but OO's auto-recovery "feature" is buggy. Has been for version after version. It's a damned nuisance, and someone asked - like I would like to know - how to disable it. But instead you give a bunch of insulting lectures about how they're using the program wrong. Because you're so damn smart and everybody else is an idiot who doesn't know how to use a computer. Get over yourselves. We're not. I use the program properly. I save my work properly. I close the program and the OS properly. And I still get this useless prompt to recover every document I was working on last time. I'd like to know how to disable it. You know, like any comprtently designed piece of software would allow you to do. If you don't know the answer, STFU, and let the silence demonstrate that there is no solution. Assholes.

And you think you'll get help with this kind of rant?
Remember that we are users like you, no developers here.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28998
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: How to stop "auto recovery"

Postby RoryOF » Wed Mar 13, 2013 1:32 pm

A computer is, by its nature, a technical item. It is not our function to educate Users in the elementary use of their technology; we expect thay have a certain minimum knowledge, or are prepared to do some homework to acquire that.

If you still get "this useless prompt to recover every document I was working on last time", then _you_ need to fix your computer, or amend _your_ method of working so that this problem does not occur.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31543
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: How to stop "auto recovery"

Postby jeromyevans » Fri May 03, 2013 3:03 am

For the OP: try changing the "Save AutoRecovery information" option to off in the Tools>Options>Load/Save panel. If it stops auto-saving, it should stop auto-recovery (I haven't tried this). This is not present in all version.

OpenOffice has the following options for start-up that can SKIP the auto-recovery:
To use these you have to start OpenOffice from the command prompt, or add this options to the shortcut. It does not disable auto-recovery, only bypasses it:
-norestore - Suppress restart/restore after fatal error
-nolockcheck - Don't check for remote instances using a .lock file in the user folder (important if on a network/portable drives if file seems permanently locked)
Reference: http://wiki.openoffice.org/wiki/Framewo ... _Arguments

My experience with autorecovery is that problems occur when working on network drives, removable drives or when working across operating systems. It's great on a local disk with a single user in the case of a unplanned shutdown/crash. I have no experience with the portable version of OpenOffice.

OpenOffice saves the recovery information under your user profile that can be hand-edited to disable the recovery of specific documents. eg. if it's stuck in a recovery loop, or the file is too big to ever recover. Google details as it's advanced.
The settings for OpenOffice are hidden away in a file called registrymodifications.xcu. There is an option in here that controls how frequently it saves autorecovery information. Google details to find it's location (hidden under your user profile, location varies by version and OS).

Regards,
Jeromy Evans
LibreOffice LibreOffice 3.5.7.2 Ubuntu 12.10
jeromyevans
 
Posts: 1
Joined: Fri May 03, 2013 2:40 am

Re: How to stop "auto recovery"

Postby RoryOF » Fri May 03, 2013 8:45 am

jeromyevans wrote:My experience with autorecovery is that problems occur when working on network drives, removable drives or when working across operating systems. It's great on a local disk with a single user in the case of a unplanned shutdown/crash. I have no experience with the portable version of OpenOffice.


I have never had any difficulty with OpenOffice working on network drives, or indeed, locally; the major consideration seems to be a stable operating system adnd a stable network. The only instance of autorecovery I have had in my six years of intensive OpenOffice use was when a cleaner caused a network cable to disconnect while files were open.

Of course, European electricity is more stable than US electricity (less instances of brownouts in summer). Because of the file complexity of OpenOffice and the consequent slower saving of files, it is also worth adjusting the low power warning on laptops to about 5 -10% of battery life and honouring the low battery warning when it issues. It is not unusual for the low power threshold to be adjusted down lower in an attempt to squeeze`as much battery working time as possible out of the laptop. If this setting is too low (it is only a guide, not an absolute reading) it can reach the stage where it is very uncertain and not leave enough time for the User to close the file properly in time for it to finish writing before the power goes out.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31543
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: How to stop "auto recovery"

Postby hanheeze » Sun Aug 11, 2013 7:45 pm

Hey there,

I Know your problem. it occurs for instance on a terminal server session when you log-in for the second time with the same user=id. Somethoing in Jave is not realy ready for a terminal server session for years..........
All open files in other session are proposed for recovery and the worst thing is after recovery the session starts on the screen where you first started one of the offuice programs.

What you can do is the following :

go to the folder where the executable is,
make a link to your desktop.
Go to the properties of this link,
you see the first line with the call to the program.
extend this line with the text : -norestore

And in the standard options / advanced tab I have not activated "use java runtime environment"

both these changes works for me,
with much thanks to LinnetDigital just a few remarks backwards.
OOo 3.0.X on Ms Windows Other
hanheeze
 
Posts: 2
Joined: Sat Dec 06, 2008 2:57 pm

Re: How to stop "auto recovery"

Postby Zarteg » Tue Dec 24, 2013 12:27 am

tverbeek wrote:This thread is a classic example of condescending non-answers to technical questions. Sorry, people but OO's auto-recovery "feature" is buggy. Has been for version after version. It's a damned nuisance, and someone asked - like I would like to know - how to disable it. But instead you give a bunch of insulting lectures about how they're using the program wrong. Because you're so damn smart and everybody else is an idiot who doesn't know how to use a computer. Get over yourselves. We're not. I use the program properly. I save my work properly. I close the program and the OS properly. And I still get this useless prompt to recover every document I was working on last time. I'd like to know how to disable it. You know, like any comprtently designed piece of software would allow you to do. If you don't know the answer, STFU, and let the silence demonstrate that there is no solution. Assholes.


You are right, and frankly this type of commentary instead of "support" was why I moved to the "nix" world (Fedora my favourite), a decade ago.
I suggest you try it, the support for Fedora is incredible

Thanks to LinnetDigital - this worked for me.

Zarteg

Version: 4.1.4.2
Build ID: 4.1.4.2-1.fc19

Fedora Core 19
Zarteg
 
Posts: 2
Joined: Tue Dec 24, 2013 12:20 am

Re: How to stop "auto recovery"

Postby RoryOF » Tue Dec 24, 2013 1:15 am

If a computer consistently gives file recovery messages then there is some misconfiguration or instability of the operating system or the installed program, which should be fixed. We _cannot_ fix every malfunctioning computer - that is the computer user's own responsibility. Turning off autorecovery by the command line merely hides the problem. A major concern must be that if there is such a problem, even if concealed by disabling autorecovery, there may be more serious problems on that computer not yet discovered; I would not wish to undertake any serious work on such a machine.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31543
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: How to stop "auto recovery"

Postby Zarteg » Tue Dec 24, 2013 6:17 am

RoryOF wrote:If a computer consistently gives file recovery messages then there is some misconfiguration or instability of the operating system or the installed program, which should be fixed. We _cannot_ fix every malfunctioning computer - that is the computer user's own responsibility. Turning off autorecovery by the command line merely hides the problem. A major concern must be that if there is such a problem, even if concealed by disabling autorecovery, there may be more serious problems on that computer not yet discovered; I would not wish to undertake any serious work on such a machine.



Ya maybe, but before I fdisk format and reinstall (normal fix for Windows) find all the temp files *.lock files and delete them with OO closed.

Windows seems to accumulate a lot of those, and I delete them I no longer get the Recovery.
OpenOffice 4.1.4.2 on Fedora Core 19
Zarteg
 
Posts: 2
Joined: Tue Dec 24, 2013 12:20 am

Re: How to stop "auto recovery"

Postby RoryOF » Tue Dec 24, 2013 7:49 am

These are a sign of improper file closure, be it of the application or of the operating system. You are curing a symptom, not the real problem.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31543
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: How to stop "auto recovery"

Postby Bill » Wed Dec 25, 2013 12:59 am

Zarteg wrote:Ya maybe, but before I fdisk format and reinstall (normal fix for Windows) find all the temp files *.lock files and delete them with OO closed.

Windows seems to accumulate a lot of those, and I delete them I no longer get the Recovery.

Lock files shouldn't be accumulated. I open and close many documents with AOO every day. A search of my Documents library turned up one lock file for a document which was open at the time. When the document was closed, the lock file was gone within 2 seconds.
AOO 4.1.7 on Manjaro Cinnamon
Bill
Volunteer
 
Posts: 7918
Joined: Sat Nov 24, 2007 6:48 am

Re: How to stop "auto recovery"

Postby kingfisher » Wed May 28, 2014 8:53 am

In LibreOffice help ( Topic : parameters ) the parameter is --norestore ( note the double dash ). In my system I achieve that by editing file associations as administrator. I imagine a similar facility exists in Windows.
Apache OpenOffice 4.1.6 on PCLinuxOS
User avatar
kingfisher
Volunteer
 
Posts: 2120
Joined: Tue Nov 20, 2007 10:53 am

Re: How to stop "auto recovery"

Postby beck4rl » Sat Dec 06, 2014 4:12 am

tools>>Options>>>Load/Save>>General>> uncheck "save auto recovory information"

i found the answer b/c this video

https://www.youtube.com/watch?v=SnVP2VyrMCE
OpenOffice 4 on windows
beck4rl
 
Posts: 1
Joined: Sat Dec 06, 2014 4:06 am

Re: How to stop "auto recovery"

Postby CodeBanger » Wed Jan 25, 2017 6:38 pm

I was using OpenOffice on Ubuntu 16. I was angry because Autorecovery in openoffice would continually lose a part of work even if it was manually saved. I had trouble with Ubuntu continually freezing up so for New Years I got an extra disk and started afresh with Debian Jessie which had Libreoffice. The freezing issue was solved but libroffice just lost almost 1 month of work in various text documents and speadsheets that were open when a shutdown was issued. I'm sorry to say but I think I like the old system of bakup files. I don't believe there is any possible way of recovering the lost documents, I searched the bakup directory, undelete is impossible because the actual files are overwritten. I removed libreoffice and will go with Kingsoft. The bullets and numbering is a little quirky but I'm just not taking another chance with openoffice or libreoffice. That was a ton of work.
OpenOffice 4.1.3 on Ubuntu 16
CodeBanger
 
Posts: 1
Joined: Wed Jan 25, 2017 6:20 pm

Re: How to stop "auto recovery"

Postby Villeroy » Wed Jan 25, 2017 7:05 pm

Ubuntu 16 comes with LibreOffice 5.1 preinstalled. Of course, your Linux disto comes with backup software too. Ubuntu's "Deja Dup" is set up within one minute.
If you save you work in the native ODF format, you have a chance to restore your documents.
OpenOffice is almost dead. No development since many years. Runs well on Ubuntu 14, unusable on Ubuntu 16.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 28664
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Next

Return to LibreOffice

Who is online

Users browsing this forum: No registered users and 1 guest