[Solved] Document Converter Wizard gives error

Help with installation and general system troubleshooting questions concerning the office suite LibreOffice.

[Solved] Document Converter Wizard gives error

Postby Baasha » Fri Mar 13, 2020 10:01 pm

I am using LO 6.4 on Ubuntu 19.10
When I try to open the Document Converter Wizard the macro fails at line 159 (oLibContainer.LoadLibrary(LibName)) and I get the error message
Basic Runtime Error
An Exception Occured
Type: com.sun.star.container.NoSuchElementException

Can anyone give me some directions on how to fix this problem? Thx
Last edited by Baasha on Sat Mar 14, 2020 9:30 pm, edited 1 time in total.
Baasha
 
Posts: 56
Joined: Fri Apr 11, 2008 9:32 pm

Re: Document Converter Wizard gives error

Postby Villeroy » Fri Mar 13, 2020 10:16 pm

The whole macro library does not contain any line with "oLibContainer.LoadLibrary(LibName)". How did you install LO 6.4 on your Linux computer? Why don't you use the one which is shipped with your Linux distribution?
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 28664
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Document Converter Wizard gives error

Postby Baasha » Sat Mar 14, 2020 12:34 am

Screenshot from 2020-03-13 15-31-27.png
I am using the version of LO that came with my distribution of Ubuntu. I just checked in the Ubuntu Software library and also used Synaptic to fix any broken programs. I have included a screen shot of the error page I get which shows it stopping at line 159 oLibContainer.LoadLibrary(LibName). I had to limit the size of the screenshot due to forum limitations so I hope you can read it.
Baasha
 
Posts: 56
Joined: Fri Apr 11, 2008 9:32 pm

Re: Document Converter Wizard gives error

Postby Villeroy » Sat Mar 14, 2020 1:22 am

Works for me with LO 6.0, 6.4 and AOO 4.1. ImportWizard.Main.Main loads library "Tools" and calls Tools.ModuleControls.LoadDialog with Libname="ImportWizard" and DialogName="ImportDialog". Sub LoadDialog successfully loads ImportDialog of dialog library ImportWizard.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 28664
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Document Converter Wizard gives error

Postby Baasha » Sat Mar 14, 2020 9:29 pm

Thx for your reply Villeroy. After uninstalling and reinstalling, the problem, whatever it was, has disappeared.
Baasha
 
Posts: 56
Joined: Fri Apr 11, 2008 9:32 pm


Return to LibreOffice

Who is online

Users browsing this forum: No registered users and 2 guests