[Solved] Pasting images transform into forms fills

Discuss the presentation application

[Solved] Pasting images transform into forms fills

Postby jza » Tue Oct 13, 2015 2:09 pm

I want to insert an image into a presentation slide when I copy-paste it from the web, it turns out one of the forms on my slide into a fill pattern graphic of that image. Is this a bug or a configuration setup?

Steps to reproduce:
- Insert a square form from the draw palette
- Insert a graphic from file or paste it from the web.
- Watch the graphic fill the form instead of adding the image to the slide.

Regards.
Last edited by jza on Tue Oct 13, 2015 8:01 pm, edited 1 time in total.
AOO 4.1.1 on Arch Linux
User avatar
jza
 
Posts: 239
Joined: Mon Nov 03, 2008 11:33 am
Location: Cancún, Mexico

Re: Pasting images transform into forms fills.

Postby RoryOF » Tue Oct 13, 2015 2:41 pm

Right click on the bitmap and choose Area from the popup. On the Area tab, uncheck Tile and Autofll and your picture will be the original size, not tiled across the frame.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.4 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 30614
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Pasting images transform into forms fills.

Postby acknak » Tue Oct 13, 2015 6:01 pm

It's a known problem in the current release.

As far as I know, the workaround is to first insert the image on a slide with no content areas, then copy/paste into the slide where you want the image. You may need to insert an extra slide and change the layout to "empty", then insert the image.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Pasting images transform into forms fills.

Postby jza » Tue Oct 13, 2015 7:15 pm

Thanks.
AOO 4.1.1 on Arch Linux
User avatar
jza
 
Posts: 239
Joined: Mon Nov 03, 2008 11:33 am
Location: Cancún, Mexico

Re: [Solved] Pasting images transform into forms fills

Postby loudemartelly » Fri Oct 30, 2015 1:19 am

Sounds like the same problem I noticed. Work-around seems to similar to the one I found: Past drawing into OODRAW, then paste it into Impress's .ppt slide. My guess has to do with inter action between Impress and Windows (Vista Home Premium) clipboard. Irregular. Particular problems with pasting from Google to Impress and Google-Paint-Impress. Does look like glitch in 4.1.1. No Problem in Vsn 3 with XP
loudemartelly
 
Posts: 3
Joined: Thu Jul 28, 2011 4:57 pm

Re: [Solved] Pasting images transform into forms fills

Postby jza » Fri Oct 30, 2015 1:25 am

loudemartelly wrote:Sounds like the same problem I noticed. Work-around seems to similar to the one I found: Past drawing into OODRAW, then paste it into Impress's .ppt slide. My guess has to do with inter action between Impress and Windows (Vista Home Premium) clipboard. Irregular. Particular problems with pasting from Google to Impress and Google-Paint-Impress. Does look like glitch in 4.1.1. No Problem in Vsn 3 with XP

This was on ArchLinux KDE box. I think this is like a feature, that gets activated somehow. I can see the usfulness of filling an area with the clipboard image. But is just random.
AOO 4.1.1 on Arch Linux
User avatar
jza
 
Posts: 239
Joined: Mon Nov 03, 2008 11:33 am
Location: Cancún, Mexico


Return to Impress

Who is online

Users browsing this forum: No registered users and 3 guests